Issues after migration to Conbee III

I am also on fw version 26500900 when experiencing these issues.

Batteries issues ? on ikea stuff too ?
And by curiosity, you are using wich one deconz version ?

Hi, i’m the Firmware Developer of the Conbee III, i was able to reproduce your issue on 26500900 with the Shortcut Button. Im still figuring out the root cause of this. i will reply here once i found a solution.

Best Regards


Thanks a lot for the update!

Small update:

Yesterday I recreated the issue with my Testing ZHA Setup. I’ve seen that the Button kept searching for a matching binding target and because of that never went to sleep.

Today i started with a fresh install of deCONZ and i can’t recreate the issue here anymore… i will leave the tracer running over the weekend, to see if the issue pops up again.

Could you give me some info about your Network? Like what kind of parent the button binds to ?

Best Regards

My main issue now is pairing Aqara sensors, they just won’t pair after both mashing/spamming the pair button or doing the regular hold ~5s till the lights blink reset/pair that have worked before.

I also had to change a lot of batteries on the Aqara sensors and Ikea Trådfri buttons that was drained. I haven’t cared about trying to pair the Trådfri buttons again after installing deconz 2.26.3-beta. At first I imported a backup from Conbee 2 but I also tried a clean install of deconz and pairing all lights again from scratch, but I’ve only managed to pair a couple of Aqara sensors.

I will probably just go back to Conbee 2 unless some deconz/fw updates arrive in the near future.

The one I’m currently testing binds to a Lidl HG08673-EU plug. But I have seen the same behavior on other shortcut button that were bound to Trådfri white spectrum lights.

Migrated to ZHA a while ago in an attempt to mitigate the issues I had when I switched from the Conbee II to III, but the issue persisted.

I have paired the button again 2 days ago, and currently so far so good.

Using the Conbee II and ZSHARK + Wireshark, I sniffed for Zigbee packets for a few hours after I paired it. But there seemed to be very little communication happening, unless the button was pressed, obviously.

If it does suddenly drain the battery again, I will test again by rigging all the shortcut buttons to a buck converter, and sniff their packets for a while to see what happens.

So i can confirm, that the shortcut buttons currently has issues with ZHA. But using deCONZ everything seems fine. I’ve reached out to the ZHA dev, i will give you an update once i got a response.

@Drumdevil could you send me your captured pcap logs to ?

So more Updates:

The Issues seem to be (at least partly) related to the ZHA Integration of HomeAssistant. I tested with the ConBee2, ConBee3 and Home Assistants own SkyConnect. In all three cases the Button was unresponsive.

I’m in active Contact with the Zigpy Dev (Backend that ZHA uses), to find a solution.

But i can confirm, that the Button works without issues in deCONZ. So if you have 2 ConBees anyways, you could use on of them temporaly with the deCONZ integration to get it working for now.

Further Updates will posted here.

Best Regards

Shortcut buttons works with SkyConnect just took quite a while to initialize.

I may have found the issue. I will monitor battery drain over night.

Would you guys volunteer for a preRelease Firmware test? If anything goes wrong (bricking should not be possible) we would of course provide you with a replacement conbee.

A post was split to a new topic: Conbee 3 Aqara hack request

I’m up for testing a fw preRelease if you still need testers.

Hi, just migrated and run into the battery drain issue with my ikea shortcut buttons, took only a few hours to drain them.

I am using home assistant and deconz 2.25.3
Firmware is: 264E0900 conbee iii

On off the buttons seems to not having the issue, not sure if I resettet or repaired the button, I will see tomorrow if it drains as well.

Another button I re paired was still draining and is now empty but before I could pair it and had a very strange issue, it seemed as it controlled another group (one without any switch assigned)…

But: I am using the deconz plug-in and not zha…

Tldr: happy to test as well!

Just updated to latest firmware 0x26510909.

Does this fix your issue ?

I should get a new set of cr3032 batteries today to test.
The one button survived more than 10h now, but this one seem to not have had the issue or I resolved it by resetting the button via deconz and repair…

After the new batteries will arrive, I will test one by one, first just adding batteries without anything and monitor via home assistant.

If I see the issue again, any specific logs you would be interested in?

As described above, the issue seems to be related to some pairing/grouping/whatever that is messed up after an upgrade as the device seems to constantly looking for another device that does not exist or something…
By reseting the device via deconz, I guess I cleared this for my working button (find device, click on 0000, exec “Reset to Factory Defaults”).

I will post what happened after my replacement batteries arrived today

If someone feel adventures your can try the Firmware i attached to this post.

You will have to remove the .ota file extension for it to be flashable via the GCF Flasher (can’t upload gcf files for some reason).

Please provide feedback if this solves your issues.
firmware52_PreRelease.gcf.ota (177.4 KB)

Best Regrads Eric

I will test with the new firmware in the next days.
I now have the problem that after re-pairing a ikea tradrfi on/off it controls all lights even before adding any bindings.
Not all lights are really switch, just some, but all show up in the ui…

Any tips why this is happening?