Issues after migration to Conbee III

After using deCONZ in Home Assistant for a couple of years, I decided to move my Zigbee network to a separate device, a Raspberry Pi 4, with the official deCONZ image. It is a bit of a long story, however, someone working in IT, I know that details can be cruicial.

Essentialy the key steps for the migration were:

  • Prepare/image the Raspberry Pi with deConz Buster Desktop image.
    • Pi will boot to CLI for daily usage. Will reconfigure it to boot to desktop whenever I need acces to the deCONZ GUI via VNC.
    • Networking over Ethernet.
    • Disabled WiFi and BlueTooth to prevent interference.
  • Backup deCONZ 2.22.2 configuration in HA Addon. Disable addon. Remove Conbee II stick.
  • Connect Conbee III stick in Pi in the USB2 port, using a 50cm USB extension cable with ferrite beads.
  • Then boot, confirm everything is working as expected. deCONZ works and recognizes the Conbee III.
  • Restore backup on the Pi, confirmed the network was indeed there.
  • Had to re-pair 2 sockets and 1 light.

So this looked good, at first, but then found several problems.

Problem 1: Batteries
I found that most of my IKEA buttons, namely the E1743 On/Off Switches and E1810 remotes, were out of battery juice. I thought the switch to the Conbee III might have caused the remaining power to be used due to changes in the network, so I replaced all 10 devices their CR2032’s with fresh new VARTA ones that usually last about 12 to 15 months. However, yesterday morning I found I flushed €7,50 worth of batteries down the toilet, since ALL devices drained their batteries overnight. After replacing batteries, you will have to re-pair them as well.

Problem 2: Pairing issues
I had a LOT of trouble pairing the buttons again. It took 3 to 10 attempts per switch to have it paired. Sometimes after pairing, they would control ALL devices in the entire network. After trouble shooting that issue, I managed to workaround it by manually binding them to groups via the REST API. To rule out a faulty batch of fresh batteries causing this behavior, I directly wired a switch to my bench supply and gave it 3V of juice. It showed the same behavior as the rest.

Problem 3: Firmware update backlash
I figured I’d update the gateway’s firmware, hoping this would solve the issue. I updated it per deCONZ wiki instructions, which worked fine. However, the network broke and the Conbee III was unable to communicate with the devices. There was no link between them. After troubleshooting and analyzing a backup, I found that the firmware caused the network PAN ID, Network Key, TC Link Key and Channel Mask to change. I guess it reverted to default (auto generated) values based on the coördinators properties. I changed them back manually, which seemed to have fixed it.

Problem 4: Random connection loss
After fixing problem 3, I found that many lights and plugs, from all brands (IKEA, Lidl and Lumi) would randomly loose their connection and become unavaible for several minutes, after which they become avaible again. Several IKEA lights and plugs still had to be re-paired, which took several attempts for each. This issue doesn’t seem to occur anymore. However, the firmware update did not fix the issue with the battery drain. I had some cheaper cells lying around I put in several of the switches, and they all ran out over night. In short this means we are currently are out of practical means to control the lights in our house.

Problem 5: Device names
When I mention re-pair in In above described issues, this means I remove the device from deCONZ, and then pair the device again, and then renaming them to what they were called before.
However, It seems that when re-pairing devices without removing them first, will cause them to loose their names anyway, having to manually rename them. This is new behavior, and not sure if it is intended or desireable.

Current biggest issue
So for now the main issue is the battery drain. Not sure if it is related to Conbee III or Deconz itself. I’d like to avoid reverting to a previous backup or the Conbee II, since I’m affraid new issues will be introduced. Are there any tips or solutions in sight against the battery drain?

Battery drain is a known issue: Force classic join/re-join for devices by manup · Pull Request #7497 · dresden-elektronik/deconz-rest-plugin · GitHub

Thanks, missed that.

Anything I can do, besides not using these switches?

Can try the v2.25.1 version, to see if the issue is still here ?

Thanks, I figured as much, and did so last night. Swapped out all batteries with cheap ones, and all of them are still working. So far so good!

Nice, thx for return ^^

Problem is still present, all IKEA switches are very quickly running out of battery. It takes about 12 to 36 hours for them to drain entirely, after which they require removal and re-pairing in deConz when inserting a new battery.

Looking at the graphs of the Rodret switches, they show the same behavior. But it takes way longer for an AAA battery to run out so they keep functioning longer.

So far this includes:

  • Trådfri on/off switches
  • Trådfri remotes (the 5 button round ones)
  • Trådfri shortcut buttons
  • Rodret dimmers

It seems to coincide with the recent changes regarding DDF’s for these devices.
Not sure how I could troubleshoot this issue or potentially work around it. It’s a big nuisance, so I’m considering switching to Zigbee2MQTT or ZHA.

I had the same issues, there many central heating control valves are managed by deConz, I went back to the Conbee II. (it is freezing presently)
But much is recognizable. The stick requires a better firmware.
For the moment the stick stays in storage.

@de_employees

So yesterday spent a good portion of the day to migrate my 68 devices to ZHA. Not asking for ZHA support, but this might perhaps give some clues to the devs of what is going wrong. Roughly the migration steps were:

  • Backup deCONZ config
  • Reset gateway from web app
  • Plug Conbee III in Home Assistant system (via the USB 2 extension cable, ofcourse)
  • Configure ZHA, adjust channel to 20 (like before) and started pairing

Nearly all devices paired in one attempt. When done a few hours later, everything was in perfectly working order. LQI’s were all greener than the neighbours grass, and the whole system was snappy. Perfect!

Unfortunately, this morning I noticed the following:

Multiple lights unresponsive:

  • All Trådfri E27 1000lm white spectrum lights that were in the same ZHA group became unresponsive. One bulb that isn’t in any group still worked, but it is a newer bulb listed as 1055lm. Not sure how groups in ZHA work, but it might be a relevant detail. A couple of them showed up as working but were unresponsive. Another few showed as offline.
  • The one E27 Trådfri color bulb we have was unresponsive

Multiple remotes and dimmers drained and/or unresponsive

  • Gave them new batteries last night
  • Two of three Rodret dimmers Unresponsive
  • Trådfri E1810 remote: All 4 of them drained
  • Trådfri E1743 on/off switches seem to be working for now, but a few show significant battery drain. (One of them shows 180% battery, dropped over night from 255%)

Stuff that kept working:

  • 1xTrådfri E27 white spectrum bulb (not in any group)
  • 3x E14/E27 monochrome dimmable Trådfri bulbs
  • 2x E14 Trådfri color bulbs
  • 7x Trådfri plugs
  • 7x Lidl HG06337 plugs
  • 2x Lidl HG06338 powerstrip
  • 1x Trådfri motion sensor
  • 3x Lidl HG06335 motion sensors
  • 5x Aqara Temperature/Humidity/pressure sensors WSDCGQ11LM
  • 6x Sonof SNZB-04 door/window sensors

Things I did to troubleshoot/fix:

  • Restart ZHA > No effect
  • Replugged Conbee III dongle > No effect
  • Reboot system (with HA/ZHA/Conbee III) > No effect
  • Replugged lamp sockets > Fixed unresponsive /offline lights
  • Reseated batteries > Fixed unresponsive Rodret
  • Replaced batteries > Fixed Trådfri remotes, no repairing needed
  • Checked WiFi interference / Zigbee channel overlap, this looks good (little overlap)

Changes I made after the above issues:

  • The physical setup is currently exactly the same as before the upgrade to the Conbee III. But I moved the Conbee to a different position now, but I don’t think this will really make a difference, since it has been in various locations over the few days to troubleshoot.
  • I downgraded the firmware from 0x264e0900 to 0x26450900 this morning.

I will let you know what happens next. Hopefully the firmware downgrade helped.

1 Like

I think there are more problems than the firmware for the Conbee III.
deConz 2.24.2 has some issues as well, which where Not present in the previous versions.
I have for example a switch and groups which works fine, but are not present in the web interface.
The group with two light and dimmer/switch can be operated but are Not present any more.
After going back from the Conbee III, I still have more small issues than before.
Presently the system is not 100% stable as before. The system has a lot of errors parsing http request to devices.

In the Github issue it is suggested that after going back from Conbee III to Conbee II, the issues may persist.

However, in my case, I moved from deCONZ to ZHA, and have reset the gateway as well as reset/repaired each and every device by doing so. That pretty much rules out deCONZ, since I have no active install running anymore. Yet my issues persist.

It will probably take a day or two before I can say that the firmware downgrade helped, and can try the next thing if issues occur again.

I also bought the conbee3 stick. My Conbee2 caused some trouble (random restarts) on Home Assistant with ZHA. Since the Stick was over five years, I thought… lets buy the new version.

I am having big issues with the conbee3 usb stick with ZHA on Homeassistant

  • Ikea rodret are not working ( I can pair all three after a while, but nothing else. No events are fired. Once paired, no interaction)
  • Aqua E1 thermostat are not working - I can pair them or at least initialize them, but then I can not send commands from HA to them (like change temperature). But changes on the thermostat by hand are transmitted to home assistant

All the issues I did not have with the conbee2 stick… So since my home automation is currently not working my wife is almost killing me.
So either I find a solution with the conbee3 stick or I have to switch to a SkyConnect stick.

Any help, or how can I provide more details?

Actually, I had the same issue with the Rodrets in ZHA, and deCONZ aswell. In deCONZ it took many attempts to pair them until they were recognized.

I got them to work in ZHA by putting brand new alkaline batteries in them, and then put them right next to the Conbee when pairing. Do not touch them while they are pairing. After pairing they won’t work yet, but you can reconfigure them from the Rodret device page. Press “reconfigure”, and then wait 2 or 3 secs, and then press the on or off button to wake up the Rodret. It will take several attempts because the reconfigure will fail often. Be persistent and keep trying. After each reconfigure attempt, press the on/off buttons, and then check in the logbook on the device page if you see any activity. If you do, the device is finally properly paired.

Thanks for your help.
for 3/4 Rodret this worked. The 4th I still dont get working.
Still have issues paring other devices (where I did not had a problem with Conbee2)

  • lumi.sen_ill.mgl01
  • lumi.airrtc.agl001
  • aqua e1 thermostat

Still not sure how to continue with the conbee3 stick…
Keep or return?

Since I went back to 0x26450900, the network seems to have stabilized somewhat, no more unavaible lights. There still seems to be battery drain on the IKEA remotes though. Two Trådfri remotes ran out in three days time, which is still better than one night.

are you using TRADFRI signal repeater?

Didn’t use my IKEA repeater until 2 days ago, to see if it would make any difference.

In the last 2 weeks, several Trådfri on/off dimmers, Trådfri remotes and Trådfri scene buttons drained. Seems like they last 2 - 5 days, depending on the battery brand. The ones that are barely used drain at around the same rate.

Their LQI range between 200 and 224, and the RSSI between -37 and -53.

All my other battery powered devices seem to work fine as before.

EDIT:
Just noticed 0x264f0900 firmware was released. Guess I’ll try that one later on.

Hey all,
just chiming in I’ve been seeing the same with Conbee III and my IKEA Tradfri Shortcut button.
Glad to see this thread and I hope it gets fixed soon.
At first I thought the device was randomly loosing its connection but it seems like it’s a firmware/software issue.

Will update Conbee III to 264f0900, same with deCONZ.

Sadly it’s not been fixed with 2.24.3 / 264F0900.
The TRADFRI Shortcut button lasted maybe 1-2 days more than prior, but it’s still draining the battery.