Sonoff ZBMINI Extreme not compatible?


My Conbee 2

Version : 2.20.01 / 19.9.2022
Firmware : 26780700


i tried the last hours to add the Sonoff ZBMINI Extreme to pair, but i cant get it to work deconz or phoscon dont find the device under Lights.

is the switch not compatible?


May be you could have a look to #6671. It will be suported in a next release but you can test it with a DDF file if you know how to do it.

1 Like

Okay, but the DDF only takes effect when a device has been detected or not? I simply don’t recognize a device at all

You’re right, once in pairing process the DDF is loaded for the device if modelId and Manufacturer names fit to the DDF.

Are you sure that you’ve done the correct pairing ? In which state is the led indicator ?

ah okay i found the device in deconz it was hidden under another, when i now try to add a json file with the ddf where can i upload the file ? i found the path that is under the ddf editor in deconz not in my filezilla.

i have HA OS installed and all the guides dosnt work, i have no of the paths over filezilla where there should be, and over putty there is no docker under HA OS

As previously suggested please read #6671 or may be this one else refere to HA. Sorry

On HA you need to put the file in the hiden folder /data/.local/share/dresden-elektronik/deCONZ/devices/

yeah i tried it with the name : ZMMINIL2 or ZMMINI-L2

the device is now as on/off Unit but i cant get it in phoscon or Homeassistant


Ha, it s a new modele ?
Can you check the model id ? on the cluster Basic 0x0000, on the attribute list (press “read” to fill the table)
BTW on your capture the device is disconnected.

yeah it disconnects after a few hours, or when i toogle the switch in HA. then the green led goes off and i must pres multiple times the hardware button on the device to get it back on.

i used the ddf for the zbmini and changed the name to zbminil2 and saved it under the other path and hot reloaded it.

here are the sreens

settings 1/2

Settings 2/2


This PR support both, the ZBMINI-L and the ZBMINIL2 Add support for Sonoff Zbminil2 by Smanar · Pull Request #6726 · dresden-elektronik/deconz-rest-plugin · GitHub

For the disconnection issue, it’s another problem, perhaps SNZB01 - ConBee-II - Home Assistant disconnnecting

Okay, i get them to work,
But normally this should be repeater and not battery-powered devices that are connected to 230V, but are defined with the DDF as a battery device, how can you change that?

You can’t. The device firmware tells deconz that is battery operated.

Hi Guys,

Can someone tell me in layman’s terms for to get the Sonoff ZB Mini-L2 working with HA?

I have deCONZ installed, but it’s not finding is under any switch or sensor (other)

I’ve tried to understand the above, but there’s no explanations to go with the screen shots.

What am I trying to do here, copy what’s on the screen shots into my setting?

I did see a couple of things that were set to False in my cluster info , True in the screen shots, but was unable to change them?

I’d be grateful for some pointers please.


Hello wich one deconz version are you Using ?


Just updated it to 6.19.0

I also forgot to state previously, I have the Conbee2

Nope your deconz version, visible in phoscon, I don’t know HA numeration.
The PR was merged recently DDF for Sonoff ZBMINIL2 by Smanar · Pull Request #6726 · dresden-elektronik/deconz-rest-plugin · GitHub

Are you asking for the Phoscon GW version?


I’ve got it working now.

It was a little over-my-head tbh, but it works.

Weather it works after a restart, I guess we’ll find out.

The video was the most help, so here it is for others if they’re having trouble and can’t find the video;


1 Like

If Home Assistant is restarted I loose function and the DDF is gone.

Any ideas?