Constant disconnecting sounds trying to set up CONBEE II

I am having no luck trying to get my conbee connected with my Home Assistant that is installed on my beefy Windows 10 PC.
I have set up Usb 2.0 in Virtual Box USB settings, I’ve plugged it into a USB 2.0 port, and I flashed the firmware to the latest using my husbands PC (which has no problem with this conbee disconnecting, deCONZ software sees it and everything). Meanwhile Im the one that has HomeAssistant on my PC So I need it to work for me.

Please tell me what I am doing wrong before I return this and give up alltogether.

Here is my error log:
01:14:42:204 discovery network reply error: SSL handshake failed
01:14:42:789 Skip idle timer callback, too early: elapsed 929 msec
01:14:42:808 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)
01:14:43:788 DEV Tick.Init: booted after 8000 seconds
01:14:43:806 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)
01:14:44:806 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)
01:14:45:809 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)
01:14:46:806 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)
01:14:47:807 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)
01:14:48:805 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)
01:14:49:806 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)
01:14:50:790 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)
01:14:50:808 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)
01:14:51:805 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)
01:14:52:807 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)
01:14:53:807 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)
01:14:54:807 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)
01:14:55:806 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)
01:14:56:806 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)
01:14:57:789 networkState: CC_ReconnectNetwork
01:14:57:789 start reconnect to network
01:14:57:808 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)
01:14:58:805 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)
01:14:59:806 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)
01:15:00:789 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)
01:15:00:805 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)
01:15:01:805 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)
01:15:02:789 failed to reconnect to network try=1

Can you share some logs as described in How to get logs?

It should produce an additional error/notification.

Yes sir I did in the above, in my post. Do you see? It is just a repeat of ‘failed to connect to network’… here again:

09:24:47:039 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:24:48:025 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:24:49:099 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:24:49:468 discovery network reply error: SSL handshake failed

09:24:50:026 Skip idle timer callback, too early: elapsed 930 msec

09:24:50:039 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:24:51:022 DEV Tick.Init: booted after 619081155890650944 seconds

09:24:51:039 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:24:52:039 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:24:53:039 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:24:54:040 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:24:55:039 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:24:56:039 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:24:57:039 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:24:58:025 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:24:58:039 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:24:59:039 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:25:00:039 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:25:01:039 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:25:02:039 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:25:03:039 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:25:04:039 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:25:05:026 networkState: CC_ReconnectNetwork

09:25:05:027 start reconnect to network

09:25:05:040 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:25:06:039 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:25:07:040 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:25:08:026 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:25:08:040 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:25:09:039 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:25:10:025 failed to reconnect to network try=1

09:25:10:040 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:25:11:040 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:25:12:039 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:25:13:039 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:25:14:040 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:25:15:024 failed to reconnect to network try=2

09:25:15:039 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:25:16:040 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:25:17:039 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:25:18:024 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:25:18:039 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:25:19:039 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:25:20:026 failed to reconnect to network try=3

09:25:20:040 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:25:21:039 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:25:22:039 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:25:23:039 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:25:24:039 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:25:25:024 failed to reconnect to network try=4

09:25:25:039 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:25:26:040 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:25:27:039 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:25:28:025 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:25:28:039 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:25:29:039 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:25:30:025 failed to reconnect to network try=5

09:25:30:039 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:25:31:040 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:25:32:039 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:25:33:039 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:25:34:040 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

I’m expecting somewhere a message with "Reason: "

Are you using an extension cable?

Also, what if you install deconz natively(so not with Virtualbox)?

when you say install deconz natively, I did install the deconz windows 10 software, which is what I was using to see these errors.

As far as a reason, im not sure, besides the SSL handshake failure.

I dont have an extension cable, but it is plugged into the usb 2.0 ports on my motherboard where the other periphrials go.

09:47:54:913 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:47:55:983 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:47:56:376 discovery network reply error: SSL handshake failed

09:47:56:928 Skip idle timer callback, too early: elapsed 945 msec

09:47:56:944 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:47:57:911 DEV Tick.Init: booted after 8000 seconds

09:47:57:944 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:47:58:944 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

09:47:59:944 COM: \.\COM10 : USB Serial Port (0x0403/0x6014)

If I turn of Virtual Box I can see it in my deCONZ software.

I just did a restart with the conbee ii in the usb 2.0 port and ITS WORKING!!!

Hope that was the fix, thanks so much.

1 Like

yay! Good to hear so :slight_smile:

So sorry I think I still have another issue,
When trying to configure conbee ii in my home assistant integrations, it fails to prob USB device.

image

I even added it to my config file:

image

You are tryting to setup ZHA - which is not deCONZ.

You need to setup the dECONZ integration or ZHA. You can’t run both.

If you want to run ZHA, we don’t provide support for that.

Gotcha okay thank you so much, it seems to be working now after I clicked ‘authenticate app’ in the phoscon ui and configured it.

Maybe dumb Q but does this usb stick need to stay in my PC in order for everything to stay connected with my home assistant forever?

Yes, the stick talks to the devices :slight_smile: