Blitzwolf BW-SHP15 shows kWh but not W

Hi guys,

long time no hear (which is quite good :stuck_out_tongue_winking_eye:).

I have got myself some Blitzwolf BW-SHP15 and deconz found them quite easily. The todays consumtion is showing kWh just fine, but the current consumption shows 0 the whole time.

Any ideas how to fix that?


I am not sure if that might be an issue, but deconz adds them as a light even if i go over the add-sensor dialogue.



Looks like your not alone for this device:

The user never followed with a response. Perhaps you can check?

Hi Dennis,

thats funny, as i really searched the forums for fitting plugs and came to this post:

Who could have known that the same plug could behave differently in two home assistant setups with deCONZ :stuck_out_tongue:

My setup shows the sensors by now (did a lot of repairing and deleting), but the current consumption (Wattage) does not update in realtime, it updates in five minute intervals, which differs from the upper post. There is no way to change the update interval or is it?


Hi Dennis,

is there a way to manually change a plug from a light entity in deconz to a plug or sensor entity? The problem i am facing with the plug is, that deconz will only recognise it as a light and so my room tab will show lights as on when the plug is on (see image below). Problem is now, when i turn off the lights the plug goes off too. Not much of a problem in my sleeping room but big issue in the kitchen for example as the refrigerator will then turn off :smiley:


Any help will be much appreciated :stuck_out_tongue:


Thats one for @de_employees to answer.

Hi Dennis,

what response-times can i expect there?


None officially. They seem to reply whenever it suits / theres time.

I can ask again internally, but thats what i can do :confused:

Hi, your Phoscon App version is quite old (and propably also deCONZ version) when the plug is shown as a Light.

In newer Version it is shown in the “Plugs” devices section of the Phoscon app.

Which version of deCONZ do you have installed? I would suggest to install the newest version. It will also install the newest Phoscon App version.

But I don’t know how HA will show the plug. Because it is the task of the frontend how to display the devices. deCONZ just tell it is a ZigBee device with type ONOFF_Plugin_unit or something like that.

But perhaps a newer deCONZ version with perhaps a new DDF descripton file for the plug would solve the problem.

So please update deCONZ and re-pair the plug. Then report back.

Hi Chris,

i have the newest addon-version in home assistant installed:

Am i missing something?


Hi I have checked some things:

  1. I have tested the plug my self and it seems it only shows the consumption when it is above 4W (ca. 26A/230V) when it is lower it shows 0. Which is an issue of the plug itself.

But that is probably not your porblem.

  1. deCONZ sends the “power” value via the ZHAPower Endpoint alongside the values “current” and “voltage”. But there is also a “power” vaule within the ZHAConsumption endpoint which also sends the “consumption” value.

So there is something not quite correct with the DDF of the plug. We will check what is the prober way to deal with that value and then probably update the DDF.

Hi Chris,

so for now there is nothing on my side wrongly configured and i have no to-do in investigating further, am i right?

Do i have to upgrade Phoscon in any way?


Yes. It is a bug that must be fixed.
Getting the latest version of deCONZ Addon for HA is always a good idea. But I think it is currently the newest version.

I just found out that the DDF was already updated 4 months ago. So I think since deCONZ version 2.24 or 2.25 it should be already working.

The deCONZ version in HA is a little behind because there where some other problems that had to be fixed. But I think there should be a new HA addon relese soon and then this problem with the Blitzwolf plug should be gone.

(not related to your kWh problem)
You might want to update your raspbee to latest firmware: Firmware Changelog · dresden-elektronik/deconz-rest-plugin Wiki · GitHub

Hi hawthorne,

thanks for the tip. I tried using the following guideline:
Update deCONZ manually · dresden-elektronik/deconz-rest-plugin Wiki (

But i ran in to the following issue:

Is there any guideline to do this step as a home assistant user before continuing?


You can’t afaik.

I recommend putting it in a raspbian OS, then go from there.

the last deconz update did update the Gateway Version as well didn´t it?

Is there still anything i have to do from my side?

Phoscon/deconz is on the latest version, but you still need to upgrade your raspbee2 firmware as you are on old version.

It should be possible if you are running deconz as a HA addon as it’s possible to ssh into HAOS and also into deconz addon container.

There are a few steps to do this though:

Remember to do all backups first.

Hope it helps.