Weird devices beahaviour after power loss

I’m using Hassio on RPI3, with a Conbee II stick, managed with Deconz extension.
I have several zigbee devices from different manifacturers: bulbs (Ikea and Osram) and motion sensors (Ikea, Philips, Xiaomi Aqara)
The whole thing was running fine for 2 years, until last month.
After a power cutoff (I had others in the past, without consequences) I experienced a lot of issues.

  • most lights went offline and couldn’t reconnect; only Osram where online and working
  • the sensors started going randomly online/offline (each at different moments) and, when connected, randomly didn’t react or reacted very slowly; only Xiaomi seemed to work

I tried changing both wifi/zigbee channels, restoring a working backup, rebooting the RPI and so on, without luck. So I decided to give it up for the moment (it was a month ago).

A couple of days ago, one of the Ikea bulbs came back by itself, without any intervention! So I decided to check again.
It seems that changing zigbee channels “unstuck” some devices for a while; for example, sensors come online but then they tend to become randomly unresponsive after a while.

I tried to install hassio + deconz + conbee stick on a old notebook, then I imported the mesh configuration, but nothing changed!

I live in the countryside and my house is very little, so I don’t suspect interferences or weak signal strenght. Otherwise, I suspect some issues with the ConbeeII itself (maybe it was damaged by the power cut?).

How can I fix this? I could re-pair the devices but the behaviour is so erratic that I couldn’t figure out if the problem is really solved.
Moreover, how can I prevent the issue to happen again?


When I have changed the zigbee channel from the default to 25 (and you should keep your wifi 2.4 within 1-9 channels to avoid any interference) all the powered devices switched the channel automatically but I had to re-pair every single sensor / battery devices. I did not delete it from phoscon I just used the add button for a new sensor and it paired using same name etc. I suggest you do the same and it should work.

If this is not working I suggest you go to the last good backup before your power loss and start from there (you will still have to re-pair some stuff).

Hope this helps.

Corrently my wi-fi channel is 1 and zigbee channel is 25, but it worked flawlessy on the default channel (15) before the power loss.
Anyway switching channels doesn’t change anything: devices with issues (both bulbs and sensors) still have issues, others don’t.

Do you mean that I should recover a working Hassio backup, or just a Phoscon backup?
I tried both, without luck.

I think that eventually I’ll re-pair all devices, since other methods didn’t work.
But, in short, what happened? Did the power loss corrupt something? The issue is in the devices or in the bridge itself (or both)?

But try to repair the devices with issues first and then try to restore just the phoscon addon from backup.
I am not sure what could have happen but files might get corrupted at power loss…


After such a thing it might help to power-cycle the lights involved while you are searching for devices.

Can you also share some logs while your doing that? In #deconz you can find out how and what log levels are needed :slight_smile:

If the sensors are sleeping, they don’t get the “message” of switching channels. Hence they are not switching either.

Il’try your suggestions.
Anyway, I point out that a Tradfi bulb reconnected automatically one month after the issue started (the power cutout happened on 28th July); this just happened “out of the blue”: I was sitting on the couch and I saw the light blinking.
Does this suggest something?

I m agree with @Mimiix , first thing to try is a simple power cycle, and after check the logs.
Using a backup is a good idea, changing the channel is something “heavy”, and if it worked previosuly on the same channel, no reason to change it for me.

The issue is in the devices or in the bridge itself (or both)?

I have ever see a “freezed device” that impact the whole network.
You have used a backup so I don’t think it can be something corrupted on the gateway.

Can take a look on logs at least if you can’t take a look on the zigbee network picture.

Where can I find the logs? I’m using the Phoscon webapp.
I’m not experienced at all with zigbee. I just followed some tutorials and set up a simple network, so perhaps I did something wrong at the very beginning. :roll_eyes:

There’s a topic in #deconz that describes it.

This one ^^ How to get logs?
And no, I don’t think it’s your fault

Yes that one.

Thank you.
In the next few days I’ll be away so I’ll do some tests, as you suggested, after returning back.

1 Like