Upgrade to ConBee III from ConBee I


I just recognized that the new ConBee III is available but on the upgrade page it is only mentioned that it is possible to uprade from version 2 to 3. So my question is: can I also upgrade from ConBee I to III?

Yes short story: it’s possible to migrate between all ConBee / RaspBee versions even from newer to older :slight_smile: We’ll update respective docs to mention that.

Great! Thank you for the information. I guess I will then order a new one :wink:

No success in upgrading from Conbee II to Conbee III.
Backup within Phoscon, shutdown, changing the stick, power on, phoscon recognizes the stick as Conbee III but unknown manufacturer.

Loading the Backup, wait for 2 Minutes, but I can ´t control the devices.

Now I ´m back to Conbee II.

official HomeBridge image (bullseye) from Github with all latest updates
HomeBridge 1.7.0
Node.js Version 20.9.0
Phoscon 2.24.1
deCONZ plugin 1.0.6
headless version

Same problem on my side

Hello just by curiosity, one of you have acces to the GUI ?
To check the network picture or the network config ? Network lost and configuration restore does not help · dresden-elektronik/deconz-rest-plugin Wiki · GitHub

The gateway contain only the network setting (at least up to version 2), so it can be a network config issue (all the devices data are on the host)

Do you have a firmware version visible on phoscon/gateway ?

Unfortunately no firmware version is visible on Phoscon gateway (nor on deconz GUI).
The ConBeeIII Stick is visible through GCFFlasher but the stick can’t be connected to deconz (even it appears in the tear down menu to be connected).
Here is the deconz log debug, on my PC Win 10, deconz 2.23.2, ConbeeIII connected with an USB cable on a USB2 port of the pC:

14:41:40:046 wait reconnect 13 seconds
14:41:41:045 wait reconnect 12 seconds
14:41:42:050 wait reconnect 11 seconds
14:41:43:037 wait reconnect 10 seconds
14:41:43:693 Daylight now: solarNoon, status: 170, daylight: 1, dark: 0
14:41:44:045 wait reconnect 9 seconds
14:41:44:728 networkState: CC_ReconnectNetwork
14:41:45:043 wait reconnect 8 seconds
14:41:46:043 wait reconnect 7 seconds
14:41:47:046 wait reconnect 6 seconds
14:41:48:036 wait reconnect 5 seconds
14:41:49:043 wait reconnect 4 seconds
14:41:49:063 COM: .\COM5 : USB Serial Port (0x0403/0x6015)
14:41:49:064 GW firmware update select USB device
14:41:49:065 GW update firmware not found:
14:41:50:048 wait reconnect 3 seconds
14:41:51:048 wait reconnect 2 seconds
14:41:52:041 wait reconnect 1 seconds
14:41:52:045 COM: .\COM5 : USB Serial Port (0x0403/0x6015)
14:41:52:111 auto connect com .\COM5
14:41:53:697 Daylight now: solarNoon, status: 170, daylight: 1, dark: 0
14:41:59:059 GW update firmware not found:
14:42:02:567 device disconnected reason: 1, device index: 0
14:42:03:041 wait reconnect 15 seconds
14:42:03:044 COM: .\COM5 : USB Serial Port (0x0403/0x6015)
14:42:03:696 Daylight now: solarNoon, status: 170, daylight: 1, dark: 0
14:42:04:049 wait reconnect 14 seconds
14:42:05:038 wait reconnect 13 seconds
14:42:06:036 wait reconnect 12 seconds
14:42:07:037 wait reconnect 11 seconds
14:42:08:045 wait reconnect 10 seconds
14:42:09:035 wait reconnect 9 seconds
14:42:09:055 COM: .\COM5 : USB Serial Port (0x0403/0x6015)
14:42:09:056 GW firmware update select USB device
14:42:09:057 GW update firmware not found:
14:42:10:042 wait reconnect 8 seconds
14:42:11:047 wait reconnect 7 seconds
14:42:12:037 wait reconnect 6 seconds
14:42:13:045 wait reconnect 5 seconds
14:42:13:701 Daylight now: solarNoon, status: 170, daylight: 1, dark: 0
14:42:14:036 wait reconnect 4 seconds
14:42:15:038 wait reconnect 3 seconds
14:42:16:043 wait reconnect 2 seconds
14:42:17:047 wait reconnect 1 seconds

Edit : the solution is to use at least deconz version 2.24.1. It seems the Conbee III is not supported by older versions of deconz

Ha ! Good to know because the issue relay look like a firmware issue

Somes infos here too (from you) Conbee III no firmware · Issue #7346 · dresden-elektronik/deconz-rest-plugin · GitHub

Damn good catch, my bad I thought the related code was already in v2.23.2 but this patch slipped through.

The older pre v2.24.x versions can connect to ConBee III too but require setting the baudrate manually.

On Linux this can be done by following command prior to starting deCONZ

stty -F /dev/ttyUSB0 115200

Can anyone confirm that die Conbee III should work with 2.23.02?

I’ve just tested it on a Raspberry Pi4 ConBee III + deCONZ v2.23.2.
It’s not the prettiest workaround but does the trick.

So I can, runing on deCONZ 2.23.2:

  1. make a backup
  2. stop deconz
  3. remove conbee ii, insert conbee iii
  4. run stty -F /dev/ttyUSB0 115200 (once?)
  5. start deconz
  6. restore backup

and it should work?

Yes that should do — but I haven’t tried this yet with older versions, only basic connection.
The stty -F /dev/ttyUSB0 115200 is needed once per system boot (or after unplug/reattach ConBee).

Is there a chance 2.24 is released as stable any time soon?

Does this apply to Docker installs as well?

I can’t get my new Conbee 3 to work. It isn’t found at ttyACM0 like my Conbee2 is. Container won’t even start.

Tried both latest stable and 2.24.1 to no avail.

Can get the container to start if changing device in Docker Compose to ttyUSB0, but the Conbee isn’t found by Deconz. It says unknown device with no firmware present and I just get “wait reconnect” messages in the container log.

Should I change anything in my Docker Compose file to get it to work?

For the Docker container there is a PR #217 pending to support setting the baudrate.

We have now added a further step 6 to the installation to set baudrate automatically . I’m not sure if this will also be forwarded in the Docker container yet (if not we need to wait for the PR being merged).

From step 6. create UDEV rule (on the host system): (ConBee III Installation)

 echo ACTION=='"add"', SUBSYSTEMS=='"usb"', \
      ATTRS{product}=='"ConBee III"', \
      RUN+='"/bin/stty -F /dev/%k 115200"' | \
      sudo tee /etc/udev/rules.d/99-conbee3.rules
1 Like

Thanks. I will try that.

Should it be recognised as ttyACM0 like the Conbee 2? Or should I use ttyUSB0 or something else in Docker Compose?

For ConBee III it is /dev/ttyUSBx.

You can check on the Host the symlinks in /dev/serial/by-id/

ls -l /dev/serial/by-id/
usb-dresden_elektronik_ConBee_III_DE12345678-if00-port0 -> ../../ttyUSB0

Got a little closer now I guess - but still not working…

The log in the docker container looks like this:

15:27:44:595 COM: /dev/ttyUSB0 / serialno: , ConBee
15:27:49:543 start reconnect to network
15:27:54:793 failed to reconnect to network try=1
15:27:58:595 COM: /dev/ttyUSB0 / serialno: , ConBee
15:28:00:043 failed to reconnect to network try=2
15:28:00:421 created username: 31154E642D, devicetype: Phoscon#B1920x911
15:28:05:043 try to reconnect to network try=3
15:28:10:042 try to reconnect to network try=4
15:28:11:595 COM: /dev/ttyUSB0 / serialno: , ConBee
15:28:15:042 failed to reconnect to network try=5
15:28:20:043 failed to reconnect to network try=6
15:28:25:042 failed to reconnect to network try=7
15:28:25:595 COM: /dev/ttyUSB0 / serialno: , ConBee
15:28:30:043 try to reconnect to network try=8
15:28:35:043 try to reconnect to network try=9
15:28:36:561 COM: /dev/ttyUSB0 / serialno: , ConBee
15:28:40:043 failed to reconnect to network try=10
15:28:45:043 reconnect network failed, try later
15:28:45:543 start reconnect to network
15:28:50:595 COM: /dev/ttyUSB0 / serialno: , ConBee
15:28:50:793 failed to reconnect to network try=1
15:28:56:043 try to reconnect to network try=2
15:29:01:043 try to reconnect to network try=3
15:29:02:596 COM: /dev/ttyUSB0 / serialno: , ConBee

And in Phoscon it looks like this:

Skærmbillede 2023-11-14 152855

It seems it can not read the firmware of the Conbee 3