[Support needed] Conbee II | HA OS/RP4 | Pair Tradfri motion sensor

Hi team,

Kindly looking for some support on getting my Ikea motion sensors into HA.

I’ve HA OS installed on a RP4, which in turn is installed into a Nespi Case. Having read about the issues with USB3 and SSDs, I’ve reversed the USB connectors from the PI to the case, as per instructions from various sources. I also have plugged in the Conbee II stick into an extension cable, so there’s less interference. The firmware on the stick has been updated to 26780700.

I’ve tried all day yesterday adding an Ikea motion sensor via Phoscon, and I’ve successfully managed to find the device once, however it disappeared on system restart :man_facepalming: and never managed to find it aftwerwards. I’ve reset it countless times, placed it in close proximity to the stick, plugged in the stick straight into the case, switched usb ports, nothing seems to work in finding the sensor.

Any help would be appreciated :pray:

Can you share some logs while trying to pair? In #deconz you can find out how.

The USB3 + SSD might make me think there’s some interference.

I tried pulling out logs but i’s giving me even more of a headache. :frowning_face: I have access to the logs in the deconz integration, would that work?
Also, I can see the live logs in the Deconz Web UI of HA, but can’t get into copying them.

Read the deconz post thoroughly. It says what to do if you use the addon.

In the meanwhile managed to get this log while pairing from the add-on logs directly: Logs pairing - Pastebin.com

Please only provide the log levels as provided in #deconz.

1 Like

TIL - vnc connections to HA :grinning_face_with_smiling_eyes:
Finally managed to understand how to get logs using a VNC viewer. Wasn’t clear for me from instructions how to add the password (had to do it in YAML mode instead of GUI) and that I had to use the HA IP address to connect with the 5900 port (writing this for those going through the same struggles). Used VNC viewer and all connected properly

@Mimiix Here is a 5-6 minute log during which I reset the sensor about 5 times.
Thank you for the patience and assistance.


The Log is behind a Password :sweat_smile: .

1 Like

[facepalm moment] apologies, forgot to mention, my user name is the pw

Did oyu use the Conbee with another system like ZHA or Z2m?

Can you please open deconz and share a screen of the network settings?

IT’s under “Edit” tab.

Additionally, I see some interference and a disconnection.

  1. 11:58:40:969 APS-DATA.confirm id: 3, status: 0xE1

  2. 11:54:54:145 Serial com disconnected, reason: 1

  3. 11:54:54:155 device disconnected reason: 1, device index: 0

Not using stick with anything else.
Screenshot with the network:

Can you go in deconz - click “leave” on top (next to the In Network green text)
Open Network settings
Change APS USE EXT PAN ID to 0x0000000000000000
hit “save”
click “done”
Click JOIN where you clicked leave.

Try to pair the device and share the logs again.

Did that, now it doesn’t want to join? Says not in network and logs say it gets timeout
Edit: Also getting bad gateway in the HA plugin
Edit 2: now it kicks me out of the device as well, can’t get to change anything in the network settings

Do you have something called Zigbee Home Automation running at the integration page?

Yes, I do:

I just reflashed the firmware on the stick, and re-installed the deconz integration as well, and also changed the APS USE EXT PAN ID to 0x0000000000000000

I don’t see the gateway in Phoscon no more, didn’t even try adding anything.
Logs from VNC here

That’s the issue.

Zigbee Home Automation (ZHA) is the deCONZ equilevant of Home Assistant themselves.You can’t use both at the same time as they use the stick to communicate. You need to remove ZHA and then the addon will be able to attach the stick again.

disabled ZHA in the front end, performed a system restart, and I could succesfully see the gateway in Phoscon. Tried to pair my sensor again, but no luck this time either. Log file no.3 here

Now the stuff caused by ZHA is gone! so the network settings are good now.

I do see the root cause now: Interference:

  1. 15:27:22:507 APS-DATA.confirm id: 55, status: 0xE1

  2. 15:27:22:607 APS-DATA.confirm id: 56, status: 0xE1

The SSD is probably causing that. Is the SSD close to the PI?

I’m using a 30cm extension cable from the usb to the stick. The SSD is inside the Nespi Case. Will go buy an USB extender for 1m and see if that works?