[solved] RaspBee not found on Bullseye

Hello and a happy new year,

I have a Raspberry 3B with a RaspBee 1 which is working pretty fine on Raspbian Stretch. On a second SD-Card I set up Raspbian Bullseye but when I put this card in the Raspi, the deCONZ Software won’t connect to the RaspBee.

“GCFFlasher_internal l” just shows 0 devices.

Bluetooth is deactivated in config.txt and the serial interface is activated.
deCONZ is the latest beta from 31th December - I had to use this because the latest stable didn’t work, the guy seems to be missing or not working. The firmware should be 26350500.

Is there anything I can do to make it work?

Did you recover a backup after installing on Bullseye?

No, I just installed Bullseye, FHEM, Homebridge some Perl stuff for FHEM and deCONZ

It might be worth a try to make a backup on stretch and restore on bullseye as the software probably assumes its a new raspbee.

Additionally, can you share some logs?

What should I backup?

In phoscon, you can create a backup.

Ah, ok. It might take me a little to get the logs…

So I installed the Phoscon Backup, Firmware says “not connected”
here is the log:

13:12:30:064 dev /dev/ttyAMA0 (/dev/ttyAMA0)
13:12:30:065 COM: /dev/ttyUSB0 : CP2102 USB to UART HM MOD : Silicon Labs (0x10C4/0xEA60)
13:12:30:081 COM: /dev/ttyACM0 : CUL433 : busware.de (0x03EB/0x204B)
13:12:30:098 COM: /dev/ttyUSB1 : CP2102 USB to UART Ecometer : Silicon Labs (0x10C4/0xEA60)
13:12:30:114 failed open com status: (-3), path: /dev/ttyAMA0
13:12:30:506 reconnect network failed, try later
13:12:31:016 networkState: CC_ReconnectNetwork
13:12:31:016 start reconnect to network
13:12:31:017 wait reconnect 5 seconds
13:12:31:109 COM: /dev/ttyAMA0 :  :  (0x0000/0x0000)
13:12:31:110 dev /dev/ttyAMA0 (/dev/ttyAMA0)
13:12:31:111 COM: /dev/ttyUSB0 : CP2102 USB to UART HM MOD : Silicon Labs (0x10C4/0xEA60)
13:12:31:130 COM: /dev/ttyACM0 : CUL433 : busware.de (0x03EB/0x204B)
13:12:31:151 COM: /dev/ttyUSB1 : CP2102 USB to UART Ecometer : Silicon Labs (0x10C4/0xEA60)
13:12:31:006 wait reconnect 4 seconds
13:12:32:007 wait reconnect 3 seconds
13:12:34:006 wait reconnect 2 seconds
13:12:35:006 wait reconnect 1 seconds

Looks like it can’t use the raspbee (failed to open com status).

I am not sure if its USB0 or USB1.

You might want to check that
Also, did you follow RaspBee Installation on installation?

I followed the installation guide, but the stable version didn’t work. The guy was not started and service deconz-gui was not found if I tried to start it. So I downloaded the latest beta .deb and installed it.
Do you mean that one of the USB devices is blocking the Raspbee?

It is not seeing the raspbee. The software is selecting the wrong USB device or it cant access it.

But the raspbee is not USB… it should be the ttyAMA0 device
Can I tell Deconz which device to use?

When you start deconz, its not in the list?

What do you see when you start it?

Also, did you install wiring pi?

When I start Deconz raspbee is in the dropdown. Wiring Pi is not installed, I thought it is only necessary on Pi4?

Ah wait, your right.

But you can’t click "connect"on the raspbee?

Can you share the output of ps aux | grep -i deCONZ?

Correct I can’t click connect. In the statusbar it says connecting for a while…

root       340  0.1  0.3   7896  3012 ?        Ss   13:34   0:00 /bin/bash /usr/bin/deCONZ-update2.sh
root       341  0.3  0.3   8424  3556 ?        Ss   13:34   0:00 /bin/bash /usr/bin/deCONZ-WIFI2.sh
mkr        343 10.4  7.7 174048 72752 ?        Ssl  13:34   0:06 /usr/bin/deCONZ -platform minimal --http-port=80
mkr       2337 21.1 10.3 303428 97732 ?        Ssl  13:35   0:03 /usr/bin/deCONZ --http-port=80
mkr       2577  0.0  0.0   7580   560 pts/0    S+   13:35   0:00 grep --color=auto -i deCONZ

If it helps, here are some lines from the FHEM log:

2024.01.05 06:00:01 2: RaspBee: websocket closed
2024.01.05 06:00:30 2: RaspBee: failed to open websocket
2024.01.05 06:00:30 2: RaspBee: http request failed: Verbindungsaufbau abgelehnt (111)
RaspBee: empty answer received for
2024.01.05 13:31:08 2: HUEBridge_OpenDev: error reading description: Can't connect(1) to IO::Socket::INET: connect: Connection refused
2024.01.05 13:31:08 2: RaspBee: empty answer received for
2024.01.05 13:31:08 2: HUEBridge_OpenDev: got empty config

The last log quote is from after I installed wiring pi and restarted some minutes ago

deCONZ is already running(you see the platform minimal).

Thats why you cant use deconz-gui.

Can you execute

sudo systemctl deconz stop

and see if it works then?

This is the output now:

ps aux | grep -i deCONZ
root       340  0.1  0.3   7896  3004 ?        Ss   13:34   0:03 /bin/bash /usr/bin/deCONZ-update2.sh
root       341  0.4  0.3   8536  3752 ?        Ss   13:34   0:10 /bin/bash /usr/bin/deCONZ-WIFI2.sh
mkr       6360 22.7 10.3 303568 97288 ?        Ssl  14:14   0:02 /usr/bin/deCONZ --http-port=80
mkr       6789  0.0  0.0   7580   596 pts/0    S+   14:14   0:00 grep --color=auto -i deCONZ

Still Deconz can’t connect

I found this in the reading of the RaspBee device in FHEM:

Internal error, 951     2024-01-05 13:55:22