[SOLVED] Not able to assign button to scene

I’m trying to assign a switch to a scene and then add some dimming to the buttons. But unfortunately, I’m not able to assign the switch to the scene…? Used to work earlier…

Anyone have a clue…?

Perhaps the same?

Thanks for referring to this. However, to me it remains unclear in this thread here what exactly does not work for @widert . Thus, I would not understand how these 2 problems are related. Besides, it’s not clear which switch he uses.

Finally, please note that while his whole screenshot shows English language, there’s one button in German (“Anlegen”), which might be of minor concern, though.

Ah okay. I only moderate the phoscon section, i don’t do a lot of support/bug things as its closed-source.

The buttons are of type Busch Jaeger. I’m running Deconz headless, could this be related to access? Altough I just added a button and that worked without any issues…?


I’m facing the same issue: Assigning a scene to a button let’s me end up in an infinity loop.

Starting from a button, after selecting a scene and clicking “Anlegen”, the next screen asks to select a button.

So what to do then? To me this seems to be a bug that needs to be rectified, how can we notify Phoscon then?


There was a bug regarding Busch Jaeger switches. It should have been fixed with the latest version of the Phoscon App. This version comes with deCONZ 2.13.2 or when using the discovery server at www.phoscon.de/app
You can check the date in Phoscon App > Menu > Gateway > General > behind the deCONZ version. There your should see 10.11.2021.

Are the issues with the Beta fixed (Chrome security)?

You mean the “password wrong” errors with the Dicovery version?

Yes. This one: https://github.com/dresden-elektronik/phoscon-app-beta/issues/425

As far as I know, our developers are still working on it. But the problem is known and on their radar.

So this wouldn’t work in that case.

Yes your are right. But in Firefox it should work.

Not so sure what you mean. I have the following screenshot:

You use the Phoscon App version 19.08.2021. The issue is fixed in the current version 10.11.2021.

You need to update to deCONZ 2.13.2 (you use 2.12.6) to get the newer Phoscon App version when you use the local Phoscon App. If you use Home Assistant you only get stable versions. The next is 2.13.x and there is no exactly date for release.

It should also work using the newer Phoscon App from our discovery server by not updating deCONZ. For Home Assistant you need to set the port 40850 in deCONZ add-on settings and open the app this way: phoscon.de/pwa/login.html#host/<local-ip-adress>:<port>

There are 3 version for your ConBee:

Thanks, that solved it :grinning:

For info, I found the right version here:

1 Like

Hi @Mimiix

I’m running community docker image and using deCONZ 2.13.2

I’m still stuck in the select button loop when assigning a scene to a button. In particular, this is IKEA STYRBAR.

I don’t do any support for Phoscon as it’s closed source. You really need @de_employees here :sweat_smile: