Request: Rodret Wireless Dimmer Model E2201 support in Phoscon

Hello there, I have several IKEA devices, philips and Aqara, all working flawlessly for years
I just bought two E2201 Rodret which is reported to be compatible with Deconz IKEA Rodret Wireless Dimmer E2201 Zigbee compatibility
I am unable to add to my deconz (Raspbian) it, tried using IKEA then Other no luck.
I am using Conbee II with firmware 26780700 on raspberry
Update 1: Temporarly installed deconz in windows and worked but when restored in the raspbian deconz, it didn’t work.
Update 2: I have then updated deconz to the latest version and the Rodret was recognized but it is unusable
Clerly an issue with Deconz on Raspbian since with Zha it does work but I am not willing to abandon Deconz since so far has been rock solid.


Your using the unofficial list.

The rodret can be used using Rules probably, just phoscon has no support for it. deCONZ has support for it.

I’ve moved this topic to the correct category so Phoscon (@de_employees) can pick this up.

Kind regards,

1 Like

Which deCONZ version do you have installed?

The Rodret should be supported in deCONZ v. 2.23.2

Just testet it on Raspberry Pi and deCONZ 2.24.0

It took a while but the Rodret switch joined deCONZ and Phoscon app via the devices switches page.
It is also usable in the switch editor.

P.S. Phoscon App does not need to implement support of switches or sensors. They will always appear in the App with a generic switch icon or a sensor icon of the specific sensor type as long as the device is supported in deCONZ. Some popular devices will be added with their own icons eventually.

A generic switch looks something like this. In this case an icon with two buttons is shown:


Does this also allow users to configure the buttons ?

Yes in the switch editor there is also the same picture and the buttons are interactive and can be allocated to the actions.

1 Like

Thank you Chris for your prompt reply
I have 2.23.01! deconz is the latest and also raspbian

Will update and report back


I have now the latest beta

With Deconz Beta 2.24.0, I was able to add the two Rodrets, which now also work in Home Assistant using the blueprint for the STYRBAR. However, there is one bug to report: once both switches were recognized, they didn’t work. I had to go through the process of adding the switch again (without deleting the old ones) and repeat the pairing process.

Please note that the switches won’t get recognized the first time you put them in pairing mode (pressing the button 4 times). I had to put them in pairing mode twice, right after the light went off, and then I received the message that the switch was ready.

Thank you for your help hope this post helps someone

I will post here eventual glitches


I just buy one rodret. I can add it on my phoscon and home assistant see it. But nothing happen when I press a bouton… I reinclude it three times.
I’m on 2.24.2.

How did you include yours ?

Did you check this? deCONZ - Home Assistant

Yes I’ve got a lot of deconz switch in ha.
When I press the switch nothing happen in the deconz log too. I think the inclusion is not completed.

This could be… Some people have problems with this switch; including myself.

There are a few bugfixes for this switch in the next deCONZ vesion 2.25.0 that will be released in a few days.

Perfect I wait for this version.

I run Phoscon 2.25.0 with Conbee III (Fw 264E0900) and several tested RODRET (v1.0.47) behave strange and inconsistent. I tried three different RODRETS with same FW Level and full Batteries and managed to bind all of them to Conbee III but only one is working properly…the others are present but either don’t react on Button press in Connected Switches Overview nor am i able to link them in Switch Editor to a Group. Only one is working out of three. Deleting and rebinding does not help. Very strange behaviour. The Switches are all OK and work flawlessly when i bind them to Original IKEA Gateway for testing. Maybe i give my Conbee II a try when i have time.

I have also just installed the beta in 2.25.1 unfortunately I get the switch paired but without any action. Is there any information whether it is being worked on or should I first order a compatible one. I naively thought that it is the same as its predecessor model, which is unfortunately broken

I have now got the switch working. I have to connect it in TRÅDFRI remote control mode and have kept it only 10cm away from the Conbee 3.
Unfortunately not all functions work. As short press works but not long press

Getting back to this RODRET Switch after months, upgraded to latest deCONZ / HA, but I am still stucked with no functionality.
It’s found immediately and joining the mesh, but I don’t have any events when pressing the buttons.

I tried the 10cm approach as well as multiple joins… What I am doing wrong?