RaspBee2 Firmeware Flash failed, not connecting devices anymore

Hey Guys,
hope you can help me out here.
I decided to get my PI up to date and updated the deCONZ to the latest version 2.22.2 and also flash the latest firmware deCONZ_RaspBeeII_0x26780700.bin.GCF to my RaspBee 2.

It seems like this was a bad idea as now RaspBee is no longer connecting to any devices and also refuses to connect to new devices. Also some of my existing devices got cryptic names like “0x1234” in the deCONZ network view.

In the deCONZ About menu it shows the current version and also the firmware that I flased and failed is displayed.

I stopped deCONZ and Homebridge before flashing

sudo hb-service stop
sudo systemctl stop deconz-gui

The used GCFFlasher v3 to update.

sudo GCFFlasher_internal -t 60 -f deCONZ_RaspBeeII_0x26780700.bin.GCF

This ended with “retry, failed”. I tried again with -x 3 for logging getting the following result at the end:

09:19:00:253 bootloader v3 finished all data
|09:19:01:204 verify application is running
09:19:01:205 query deCONZ firmware version
09:19:03:207 failed to query application
retry, failed

I also tried GCFFlasher v4 but this one is not working at all:

sudo ./gcfflasher/GCFFlasher -t 60 -f deCONZ_RaspBeeII_0x26780700.bin.GCF -d Raspbee
read file success: deCONZ_RaspBeeII_0x26780700.bin.GCF (163244 bytes)
flash firmware
retry connect bootloader Raspbee
retry connect bootloader Raspbee
retry connect bootloader Raspbee
retry connect bootloader Raspbee
retry connect bootloader Raspbee

Now devices are no longer connecting and it refused to pair new devices.

When I now switch to my Backup SD-Card with was created before the update the issue remains the same which means this has something to do with the firmware flashing.

Thanks in advance!


Did you update the Pi in full? Meaning other packages as well?

If that is the case, you might be affected by this: After a sudo apt update && sudo apt full-upgrade and a reboot deconz no longer connects to the conbee 2 · Issue #6937 · dresden-elektronik/deconz-rest-plugin · GitHub

Thanks Mimiix,
I performed the following before:

sudo apt-get update
sudo apt-get upgrade

If I remember correctly it was still working after this. But never the less if I switch to my Backup SD-Card that was created befor this, I have the same issue with the Backup

Screenshots on how deCONZ looks now:



Looks like it doesnt remember the devices.

What devices are this?

Mostly IKEA Bulbs and one OSRAM Plug.
The ones with the cryptic names aren’t visible in the Phoscon App anymore.
For testing I deleted one of those with cryptic name from the network view and tried to pair again. But no success. The App is not able to find the device.

Are there other devices that work?

Not exactly sure what you mean. But no, none of the devices connected to deCONZ works.
Trying to switch them on in the Phoscon App changes the icon to “on” for some seconds and then goes back to “off”.
Other products from Eve that directly connect to Apple HomeKit work normal.

Could I provide some logs or something?


Logs might be useful. In #deconz theres a topic How to get Logs which instructs how to get them.

Please use pastebin for sharing.

Sure, here we go, logs as described in your post:


I actually see no communication is going on. Can you try to pair a device while making logs?

Thanks for checking.
Here is the log covering the whole pairing time (3 min). Also with a bulb available for paring but has not been found.
INFO; INFO_L2; ERROR; ERROR_L2; APS; APS_L2 were enabled.

Did you reset any of the devices and put it in pairing mode during search of devices?

Yes, just to be 100% sure I reset the device while pairing mode was running here a second log of this:

I have no clue whats going on. Asked @manup to check in.

1 Like

Does anyone else has a clue? I’m still stuck here…
@Mimiix Could you maybe follow up with someone from Phoscon? Thank you!

I have no clue, otherwise i would’ve replied ofcourse. @de_employees?

Hi I’m not 100% sure but from what I see communication to the firmware works, but the network settings might be corrupted. What was the previous RaspBee firmware version installed?

Not all is lost, also older network settings are stored in the database file.

As next thing to check please open the “Zigbee configuration” page in the Phoscon App, here we should see if there is something wrong with the parameters, the usual suspects are panid and channel:


Can you please provide a screenshot of these?

Hi @manup, thanks for reaching out!
I’m not 100% sure about the previous firmware but I guess it was 26710700.

Here is the screenshot of my Zigbee Config-Page:

Ok thanks, the values look valid, no changes on the parameters. However I did expect also an entry for the current installed deCONZ version. Can you please also provide a screenshot of:

deCONZ → Edit → Network Settings

Here we should see the same parameters.

That was what I was also wondering. Here are my screenshots from the Network Settings: