Raspbee 2 not recognized on Pi Zero W 2

I got my Raspbee 2 and Pi Zero W 2 (which has the same Broadcom BCM2710A1 as the Raspberry Pi 3) and I put them together but there doesn’t seem to be a connection.


I flashed Phoscon_Gateway_Headless_2021-08-23.xz and used raspi-config to setup the wifi connection.

According to the documentation I could use VNC to run deCONZ, but I wasn’t able to establish a connection using Remmina, Vinagre or TigerVNC from my Ubuntu machine. Either this feature doesn’t work or it could use some improved documentation. Also the webserver doesn’t work even though according to top deCONZ is running in the background (without GUI).

So I ran ssh -X (with X11 forwarding), so I could run deCONZ from the Pi on my local X11 server.

See https://user-images.githubusercontent.com/1702193/141219353-032b798e-221e-477a-abaa-355dcf2294bd.png

As you can see in the yellow circle, the “connect” button is greyed out. Now that deCONZ is running, the webserver works. But it appears there is no connection. I cannot connect any lights.

See https://user-images.githubusercontent.com/1702193/141219750-3ad69239-bd1f-4bd5-8e1c-07c345afa021.png

Are there any additional steps I need to take to get the Raspbee 2 to work on a Pi Zero W 2?
Is this Pi Zero model 2 too new and the Phoscon images not yet compatible?
Should I format the card and just use Raspberry OS?

I am not allowed to embed more pictures or links to documentation because I’m a new user, not yet vetted by spam protection. For a more pleasant read see original post on github.

$ sudo GCFFlasher_internal -r
GCFFlasher V3_17 (c) dresden elektronik ingenieurtechnik gmbh
Reboot device RaspBee (RaspBee)

952: Error: failed to open device, status: Permission error while locking the device (2)

Deconz need to be closed to update firmware.

Can you provide some logs of deconz if you cant click the connect button? How to get logs?

BE adviced that deCONZ-gui (the thing in X11) and deconz can’t run at the same time. You either run deCONZ-gui or deconz. They share the same files so that doesn’t make a difference.

In addition to that, please make sure to update to the latest firmware https://deconz.dresden-elektronik.de/deconz-firmware/deCONZ_RaspBeeII_0x26720700.bin.GCF

That setup runs flawlessly over here :slight_smile:

Thank you for taking the time to help me out! :smiley:

@Mimiix in the process of getting the logs, I got it to work. This helped:

Basically after running sudo systemctl stop deconz everything worked as expected.

I believe there is a deficiency in the documentation, because I did follow the installation steps. Now that I understand, I don’t believe it’s necessary to attach those logs now. :grin:

Here is what I believe caused the problem.

  1. Documentation indicates I incorrectly read the headless image provides VNC login.
  2. I couldn’t connect to VNC.
  3. I used X11 forwarding as alternative for VNC (only available on Linux desktops)
  4. This worked but couldn’t connect because deCONZ is already running in the background.
    • I understand only one instance is allowed a connection to the RaspBee2 hardware.
    • Logically this means deCONZ wouldn’t work even if the VNC connection worked, right?
  5. Webserver mentioned in the terminal output (:8080) is not connecting either because there is already one running on :80

Can someone provide a bash command that starts a VNC client connection that should work?

It appears my RaspBee2 is new enough, it already contains that version. :smiley:

No problem :slight_smile:


What documentation are you reffering to?

Indeed. But VNC needs to be served. Docker version has it build in for example.


I just edited my post at the same time as you responded :slightly_smiling_face: Turns out I read the VNC details wrong. The logic-center of my brain auto-corrected the documentation so I read:

Login via VNC

The headless images can be viewed without monitor, the graphical login can be done from another PC via VNC.

But I turned off auto-correct and now I see it actually reads:

Login via VNC

The desktop based images can also be viewed without monitor, the graphical login can be done from another PC via VNC.

I assumed the VNC is for the headless one, because in my experience, VNC is always for the headless one. Otherwise the page doesn’t explain how to connect to the headless one.

I don’t believe I can submit a PR to the website, but this mistake can be prevented by explaining that a webserver is running in the lineup of login methods. For example:

Login via WebApp

The headless image automatically start the deCONZ webapp on port 80. All you need to do is connect to this port and create a password.

Login via SSH

The login through SSH allows access to the Raspberry Pi via terminal. On Linux and macOS this can be done via terminal. For Windows, Putty provides the same functionality, it can be downloaded from https://putty.org.

Login via VNC

The desktop based images can also be viewed without monitor, the graphical login can be done from another PC via VNC. The RealVNC Viewer is required for the VNC login. It can be downloaded from https://www.realvnc.com/download/viewer.


(Could not add link to previous post due to spam protection)

Wow this webapp is really nice. After an initially bad start, I am happy to see this is way easier than I had anticipated. :star_struck:

I think that goes for the images you can download from the phoscon site. Not sure how this works tho :sweat_smile:

Happy it works!

@gautama : Probably something to fix on the site.

1 Like