does not work anymore

I’ll see if i can ask Manup to expedite the next version to be stable instead of another beta.

thank you Mimiix

Hi the v2.23.2 stable version also contains the fix in v2.24.1-beta to tame the HTML cache in browsers.

Technically speaking this forces browser and in-between proxy caches to refresh not only HTML and Javascript files but also Javascript modules imported from other .js files (these could get out of sync after updates in older versions).

Accessing the Phoscon App via <local HA instance>:<port> works, in my test setup I’m logging in via http://homeassistant.local:8099 where port 8099 is set in the HA add-on configuration.

However in my test setup the add-on is still on version v2.22.2 showing no update?

To update to 2.23.2 someone needs to create a PR in HA addons repo to bump up the version, I can do that but refrained as it takes me long time to set up something to test everything together, and it’s very brittle, I haven’t found a quick way.

If you have a test environment, could you please test that it works also without specifying the port in the HA plugin? By default there’s no port and it used to work without one being set (there’s a way to get to deconz without a port, accessing it through the plugin, let me know if you don’t know it and I can explain).

Without specifying the port in the configuration tab I can only access the Phoscon App via Ingress, e.g. http://homeassistant.local:8123/core_deconz/ingress

Also scanned via nmap and it doesn’t look to be exposed otherwise:

nmap -p 80-50000
Starting Nmap 7.94 ( ) at 2023-10-19 18:36 CEST
Nmap scan report for
Host is up (0.00023s latency).
Not shown: 49916 closed tcp ports (conn-refused)
111/tcp   open  rpcbind
4357/tcp  open  qsnet-cond
5355/tcp  open  llmnr
8123/tcp  open  polipo
40000/tcp open  safetynetp

Nmap done: 1 IP address (1 host up) scanned in 1.48 seconds

if you enable the sidebar icon on the HA deconz addon,

you can then access phoscon by clicking on that sidebar icon.

Have you tried that? Don’t know how it works internally (ingress and so on), but that is what it should still work, and be able to login, and see the gateway page (not blank).

Maybe I am stating the obvious and that’s what you are doing already, wanted to be sure :slight_smile:

I downgraded to latest stable docker 2.23.2 - but still have the same problem. Login via IP works, login via domain (remote proxy) shows ony an empty screen with the P no gateway button. See Screenshot. Is this the same error or not?

I’ve now setup a reverse proxy on public server to test what’s going on (took me ages to setup the SSL subdomain stuff, holy moly…)

The initial login worked fine, the gateway with subdomain was listed and I could control everything just as local version. After logout in a second try it didn’t work, I see the API key is created fine but then the code somehow tried to proceed on port 80 instead 443. So there is something wrong here early on.

I’ve collected a few logs and forwarded it so the team can have a look for fixing this and test with my server setup.

1 Like

Oh might to add that the login.html site works but the login2.html site shows the problems.

And this is my proxy setup for the HTTP headers:

 location / {
        proxy_set_header X-Real-IP $remote_addr;
        proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
        proxy_set_header X-Forwarded-Proto $scheme;

1 Like

I am glad i dont be the only one with this problems. And when i read this now, i would say it worked for me one time, too after that only by p not by domain anymore.

For me on iOS 17/Safari neither Login via IP (nor login/login2) nor the new App works (starts, but then “spleeps”).
Version is 2.23.02, Conbee II Firmware is 26780700
Any idea what I can do to work on IOS - or just wait für 2.24? Any ideas when it will arrive?

2.24.2 is out now (Release v2.24.2 · dresden-elektronik/deconz-rest-plugin · GitHub), can someone now take care for updating the HA deCONZ addon?

1 Like

I could but I have no idea if anything has been done in this version to address the problems described in this thread. From the changelog I don’t think so.

Both 2.24.1 and 2.24.2 works well with Phoscon on my iPad again

Great. We have clarified already at does not work anymore - #59 by bcutter and the few posts before that, that 2.24.1 (beta) already fixed the issue. So it should be the right time now to update the HA addon.

1 Like

Still miss the addon update for HA.

Update: seems like we need users to test it first before the update gets approval:

Hi, is this issue now fixed? I understood that 2.24.2 should work, but neither iphone nor ipad works for me. Thx

Should work as reported above.

Did you try another browser?

Ahhh, obviously I forgot to restart the Rasberry. Now it works. Sry

1 Like