LIDL LED Stripe - color does not work anymore

I have a LIDL LED Stripe (TS0505A). Had it running for month with the same color. Yesterday I wanted to change the color but it does not work anymore. I cant control the color, just the color temperature.

  "capabilities": {
    "alerts": [
    "color": {
      "ct": {
        "max": 65279,
        "min": 0
  "config": {
    "groups": [
  "ctmax": 65279,
  "ctmin": 0,
  "etag": "583f187002ebf609fecd1a22e6f104a4",
  "hascolor": true,
  "lastannounced": "2023-04-11T17:15:51Z",
  "lastseen": "2023-08-10T05:16Z",
  "manufacturername": "LIDL Livarno Lux",
  "modelid": "HG06104A",
  "name": "LED Streifen",
  "state": {
    "alert": "none",
    "bri": 254,
    "colormode": "xy",
    "ct": 885,
    "on": true,
    "reachable": true,
    "xy": [
  "swversion": null,
  "type": "Extended color light",
  "uniqueid": "58:8e:81:ff:fe:fb:d0:7f-01"


What can I do to debug this? I already tried a factory reset

I just noticed even color temperature is broken. Setting it to “cold” makes it more warm, setting it to “warm” makes it colder…

No idea how to fix / debug this?


I’ve just tried with my sample of this device, fresh from the package so first join. The stripe isn’t yet a DDF device but in my setup works fine. Here dimming color and color temperature works without problems from the Phoscon App.

I don’t really know how yours got in that state :thinking:
Perhaps you can check within deCONZ GUI if the raw commands do work as indented.

  • Open the Endpoint list on the Node
  • Double click on the 0300 Color Control cluster
  • In the Cluster Info panel on the left scroll to “Move to Color Temperature” command
  • Enter 500 for “Color temperature Mireds” and click excec

The color temperature should go to max. warm, and for a 0 value it should become cold color.
Does this work?

The command works - but 500 goes to cold, 0 goes to warm :face_with_monocle:

That’s what I was wondering of, it should be the other way around. So it gets the right command but the device firmware does the wrong thing somehow.

And you already tried to factory reset the light?
According to the manual:

  • 3 × on/off
  • on (light flickers)

Yes. I just did it again (without removing it in Phoscon first) - no change. But it keeps the groups etc - is there a way to reset it without losing the ID?

For the reset you don’t need to delete the device in the Phoscon App. Just the physical reset is needed and then join again by searching for lights. The still existing entry will be picked up again and work.

Yea I know and did this 2 times but nothing changed

Any Updates? is it possible build a DDF for the Device? Which Information are necessary for this?

I did not find a solution for the problem…