IKEA SYMFONISK paired with IKEA Range Extender does not work

Hallo Community,

this is my first post here. I really like the ConBee Gateway and use it since almost 3 years. But sometimes i do not understand the behaviour.

I trying to optimize my ZigBee MESH using LQI. I added two additional IKEA range extenders to act as routers. In terms of the new Beta functionality Source Routing Routers are meant as Hops?

As a next step i re-learned one IKEA SYMFONISK Switch an my goal is that the Switch should be linked to the Range Extender. I learned in the past that new devices should always be added to the Gateway in that Space where the Device will be used. So i do not add new devices close the coordinator. I hope this rule is still valid?

Now i have two problems.

  1. It seams that the SYMFONISK Switch does not send any commands since i re-learned the device as i am not able to stop playing music. But i see that in the deCONZ MESH that the device is active and LQI is 108. In general is my ConBee Gateway linked to FHEM and the Switch configuration is done there.

  2. Another problem is that sometimes my devices are linked to an Router which acts as a light. But this router is one floor above the IKEA range extender. It’s a light, and sometimes my son turns off the light switch so that devices connected to it have to find another router. I wanted to solve this problem by using the IKEA range extender, which is permanently connected to the electricity.

But how can I ensure that devices are permanently assigned to this router?

Thank you in advance for your support!


that LQI is a bit low. Probably too low:
LQI value meanings:

  • 255 excellent
    • 200 good
  • 130 flaky but can work
    • < 100 problematic

Probably with source routing. https://github.com/dresden-elektronik/deconz-rest-plugin/wiki/Source-Routing

With this device there are some bugs currently:

can you perhaps add some logs?

Ok, i can create a log file connecting to deCONZ via VNC like described here.

Question: Will the output also written into a file or is it only displayed in the Viewer? If yes where is the file stored?

If you use option 1 from that link, it’s in a window. Then you can copy paste out of it.

How can i clear the Debug View?

Remove the checkboxes and close.

Ok, but when i reopen the Debug View the previous logged content is still in there. I would expect an empty window.

So it looks like that the content is stored somewhere in a file which is now growing and growing. Any idea how to clear?

It isn’t growing as long as the checkboxes are cleared.

Ok, understand but it gives no answer ho to get a clear window in order to create a new log?
Otherwise i keep all old entries which makes really difficult to read and is overhead.

Doesn’t matter if there’s old stuff with it :slight_smile:

After a restart of deCONZ is the re-added SYMFONISK Button now visible and works as designed.

1 Like


my first time here. First of all, I’d like to shout out a big thank you in general for all the marvelous implementations. I use several Ikea, Xiaomi and Philips devices and nearly all of them work as expected.
Thank you!!!

Now to my issue :smiley: … I bought recently a Ikea Symfonisk sound remote, 'cause I saw that it was supported from the device list itself.
Since the day before yesterday (date of purchase), I tried to add it somehow to my existing Raspi4/HomeAssistant/deconz integration and it indeed pairs as expected but after that nearly nothing.
What I made: I added the button through Phoscon app → “switches” → “Other” → paired as SYMFONISK controller. The controller is visible in the Phoscon app, but it never shows as an entity, nor can I see any events coming in deconz_event …so I went back to the Phoscon App “Help” → API Information → selected the switch and the RestAPI shows this config:
“config”: {
“alert”: “none”,
“battery”: null,
“on”: true,
“reachable”: true
“ep”: 1,
“etag”: “819ccc4fdbf147d60dbf00cb49433795”,
“lastannounced”: null,
“lastseen”: “2021-12-19T16:27Z”,
“manufacturername”: “IKEA of Sweden”,
“mode”: 1,
“modelid”: “SYMFONISK Sound Controller”,
“name”: “SYMFONISK controller”,
“state”: {
“buttonevent”: null,
“lastupdated”: “none”
“swversion”: “2.1.024”,
“type”: “ZHASwitch”,
“uniqueid”: “68:0a:e2:ff:fe:a2:0d:b8-01-1000”

If I go to “Events” nothing is presented, no matter which action I take on the device.

Tried 3 different new batteries to exclude the faults described in other posts and repaired it now a few times…still the same result.

Could you give me a hint on how to advance and what I should try to get this thingy running?

Thanks in advance!

Just wanted to give a short update. Now I recently updated deconz on HA to ver. 6.11.01 and the Symfonisk knob began to work. Thank you!

1 Like