Getting back unreachable devices


I‘m using different Aqara temperature and water leak sensors. Sometimes the one or the other gets unreachable.
How is the best practice to get them back to work?
Currently I delete the old device and pair again. But then they also get a new ID. Is there a other way to bring them back without access to deconz gui but to phoscon and REST API?

Just don’t delete it before the new inclusion and you can make it with phoscon, all will be invisible.
If you have too much disconnections, are you using the USB extension, bad routers ?

1 Like

You mean just include the device again without deleting it before?
Edit: Read you sentence again and you exactly wrote this… :expressionless: :sweat_smile:

Yes, I use a usb extension.
I have two IKEA Tradfri plugs, one hue plug, a led trading dimmer behind a wall switch and 2 hue bulbs as routers.

Edit2: I think I have more a problem with interferences. I have a hue bridge on same ZigBee channel for most of the lights.
But I will add some more powered devices soon to deconz network so after that I will have a deeper dive on this.

Just a side comment: The Aqara devices need to be paired with your deCONZ device at the spot where they will be used. Meaning they need the nearest zigbee router (a lamp or so) be visible when pairing.

I have an aquara leak sensor here and i suffer from a similar problem.
ConBee 2 on a Raspi4 with USB extension worked for some month an then (after some updates?) it was grayed out in Phoscon. I checked the battery of the sensor and it was still OK.
I tried to reconnect, (without and with deleting the device) but I was not able to get it working again.
In the end I gave up because for a water sensor (Gas heating in the attic) it is much too unreliable.

It´s hard to say what causes the issue here. There could be a to long way from the sensor to the next parent for example.

Forgot to mention that the sensor is just 5 m away from the ConBee stick, only light walls in between, no ZigBee routers at all.

Did you checked the parent for the device? Maybe it was routed not close enough. Our source routing in deCONZ could help here.

Is this actually really the case at least for Aqara? So not include as near as possible to the deconz stick but as close as possible to the to be mesh partner?

Better to include devices at their definitive place, and more for Xiaomi and Aqara.
Sensors from this brand never (rarely) change their parent, so they are not able to move in the network. If they parent move they just disconnect.

At least, that’s what I do. My (small) house has 3 levels (concrete) and I have Aqara sensors on every door and window. So, works for me.

This might explain why my aqara temp sensor in the garage is not working even its 20 cm away from a innr plug :man_facepalming:

Ok, so I‘ll include it again in the garage instead of in the house close to the stick.

Thanks guys!!!

Thats in fact very interesting. I thought until now that the deconz zigbee network is self healing like a zwave.
Picking the device a new parent when I bring them back as mentioned before?

They should. However, Xiaomi doesn’t stick to this standard.