Disk write very hight


I use deconz with jeedom. Since the last update 2.16.4 and last firmware update, my ssd write a lot.
After it use 400\500 ko the it near 2 MO !
When I stop deconz everything become OK again.

I juste made the update on my configuration. I run on a VM in proxmox debian buster (with the last update). I don’t know what can I do in order to stop it.

On proxomox :

On my vm when I use the iotop commande a mysql seems to be very active. When I desable deconz it seems OK :

Thanks for your help.

Hello, what was your previous version ? Because from my memory the last change was realy old.

My previous version was the last stable 2.11.5

The small little detail to note here is that deconz does not use mysql leading to the conclusion that it’s system specific and an induced dependency, if any.

The last change made on deconz using its DB was that the disk writes have significantly decreased by raising the write interval from 5 to 60 seconds as I recall.

Ok thank you for your answer

The developper tell me :

“It is Jeedom which uses MySQL but the concern must come from their application which must have a problem at the level of the websocket which sends the events of the modules. They have to buckle up or something and that overloads Jeedom.” (it’s a google traduction).

How can I see where is the buckle ?

Because of sensor data probably. deconz sends data to jeedom. If you recently added sensors which report every x seconds, that generates data. MySQL writes to disk more often: MySQL :: MySQL 5.6 Reference Manual :: How MySQL Uses Memory

Did you add any sensors or power monitoring devices lately?

That’s what I don’t understant. I juste made the update don’t add sensor yet.

Than you should check what is saved. I suggest listening to the websocket.

Ok good. But I’m a newbee… Can you explain how can I do please ?


This is a good place to figure it out :slight_smile:

To check websocket you can use jeedom logs, or phoscon beta http://phoscon.de/pwabeta in help / api information / Event

But It still a mystery for me, there is no more websockets events added recently for me.
It have increase when we have added “lastseen” and “lastannounced” with the “attr” notification, but it s not something recent …

You save me ^^ it’s easy for me to use jeedom or phoscon !
I look at the events. But now I can’t see anything…

Thank you for the discovered of this menu ! It’ll be very usefull for me !

Same for me, if you can ask to jeedom dev which one websocket event disturb their code ?
I realy don’t see something new on them.

I try to have other user retourn but anybody do the update. Maybe it a default on my environnement…

I don’t understand, you are the only one that have done this update ?
The other user have same version for the jeedom plugin and deconz ?

I hope I’m not the only one who use deconz on jeedom ^^

But I’ve no return of other user with this new version 2.16.4 and the jeedom plugin. The plugin doesn’t change since February.

I’ve ask on rhe Jeedom community but nobody answer.

There is a special option in deconz, that decrease websocket notification size

websocketnotifyall > Bool > When true all state changes will be signalled through the Websocket connection (default true).

But it can broke the plugin, can make a test, IDK how work jeedom.

There is a way to disable the jeedom plugin and let deconz working ? (easy to check, just check if phoscon is still working.

Can too try to disable spamming device like power measurement sensors (time for tests)

Arf, not possible Disable notifications if the config/on is false for sensor. by Smanar · Pull Request #4960 · dresden-elektronik/

Arf… I can’t put off my plug because it’s the fondation of my network. I have 5 plug legand netatmo and my sensor are link on them.

I probably found an other who has the same issue with jeedom. I keep in touch.

I don’t know if i can leave deconz alone without the plugin.

Nope, I was thinking just disbling the reporting, not the plug itself, but the command is not working.