deCONZ looses connection on a frequent basis

Describe the bug

deCONZ looses connection to all bulbs, motion sensors and remote controls, sometimes it shows “firmware not connected”. The issue can sometimes be fixed by going in to the advanced options of phoscon (alt+click) and loading an older configuration. Sometimes it can be fixed by searching for lights in Phoscon but sometimes none of these steps work and i am back at resetting bulbs with the dimmer switch which takes quite a while of time. This behaviour is not brand specific as it happens with Philips Hue and Ikea Floalt or Tradfri. *.dat-Files were send to, if you need more data like logs etc. please let me know.

Steps to reproduce the behavior

Quite random appearance, sometimes after rebooting HA, sometimes from one second to the other.

Expected behavior

No connection loss or firmware not connected status. I had the setup of deCONZ and Raspbee II running without issues for at least a year but since a month or so i run into this issue at least once a week.



  • Host system: Raspberry Pi 4B 4GB
  • Running method: Home Assistent deCONZ Add-on
  • Firmware version: 26520700
  • deCONZ version: 2.12.06
  • Device: RaspBee II
  • Do you use an USB extension cable: no because RaspBee II
  • Is there any other USB or serial devices connected to the host system? If so: Google Coral USB Accelerator

deCONZ Logs

that is quite an endless list, can you provide an email to send that files? As the system is running at the moment it might be usefull to send that information when the next occurance happens as i am pretty sure, that this is just a matter of time.

Can you please provide the full log in pastebin?

Is this the right way? Cause deCONZ does not put anything in the cache after pressing copy? And it looks like it covers ca. 20 minutes, but the last down is four days ago.

Thats because of the HA Addon. You need to use a native client to VNC to it :slight_smile:

How to get logs? the above page describes how to get them and provides links that can help out :slight_smile:

Please note the log levels.

1 Like

There you go:

Pastebin - Logs

But as stated before, there is no issue at this actual moment. I surely do another log as the problem occurs.

There are errors though:

  1. 13:22:25:587 APS-DATA.request id: 232, addrmode: 0x03, addr: 0x0017880106797d25, profile: 0x0104, cluster: 0x0008, ep: 0x01 → 0x0B queue: 0 len: 5 tx.options 0x00

  2. 13:22:25:723 0x0017880106797D25 error APSDE-DATA.confirm: 0xE9 on task

  3. 13:22:25:725 APS-DATA.confirm id: 232, status: 0xE9 MAC_NO_ACK

See the wiki for the errorcodes.

Thanks for pointing that out. So one of my ceiling lights has not send an acknowledge-message to the controller. The ceiling light is changing to all light modes at the moment so i think that is no real issue and to be honest i would not know what to do about it after looking in the wiki (“Is issued when the coordinator sends out a command but no acknowledgement (ACK) was returned from the target receivers next hop (1-hop only).”). I can read and write the light in the deCONZ-GUI without problems.

I would like to let that issue open and repost any logs here as soon at is appears again if that is a workable solution for you?

Thanks for your time so far.


1 Like

Sounds great!

1 Like

Just one question relating the Error-Logs. Is there any need for action or a workaround regarding the Acknowledgement-Error (0xE9)?

It depends on how the light is used. Do you power it off (off the grid) sometimes?

Is it in a metal shell?

1 Like

Good Morning Dennis,

indeed the ceiling light (group of three Philips Hue Color E27) is going off the grid as soon as i turn off the wall switch (Homematic IP BSM). I would like to turn just the bulbs off, but that is not possible with the current setup, as the Homematic BSM turns off as soon as there is no power consumption from the bulbs. I might have to use a “Grundlastelement” to be able to have the bulbs on the grid without consumption, not sure for now. But you are totally right, if they are off the grid, they can´t send ack-packages for sure :stuck_out_tongue:

Cheers, Philipp

I have to correct myself. The Homematic BSM only turns off automatically if you use the wrong setting in the Homematic CCU3. As soon as i switch from “Wechselschaltung” (changeover) to “Ausgang 1 aktiv” (Output 1 active) in the CCU3 Settings, i can turn off my lights without Homematic automatically turning off the switch. Just if somebody searches for that specific behaviour i document it here.

Wrong setup:

Correct setup:

Output one or two depends on the wiring on the Homematic BSM.

I am going to correct eighty scripts now :stuck_out_tongue:

Goodmorning Philipp,

Than that is probably the case. It might be worth while to match the timestamps with when you actually turned it off.

Cheers, Dennis

Hi Dennis,

as promised, here is a log from the actual down of my deconz.


If you need more information, please let me know.

Added another pastbin, half is back up running the rest refuses to:



Hi Philipp,

I see a lot of interference errors:
the 0xC4 in log 1 and the spam of 0xE1 in log 2.

This has to do with USB 3.0 interference or WiFi.

do you use a SSD or anything else on USB?

but it is the raspbee II, so i thought that one should not have interference issues with USB 3.0 and that only is an issue with the Conbee II or am i wrong?

I again lost all connections. See log below:

I use an Google Coral Edge TPU for Object Detection on the USB 3.0.


So everything is backup und running now. I created a new log with the process of repairing etc.


It does as it has nothing to do with the Conbee. It has to do with USB and devices connected to it.

Your logs indicate trouble:

  1. 14:40:34:327 0x001788010845EC35 error APSDE-DATA.confirm: 0xE1 on task

i go buying an extension-cable for the Google Coral then. Would be an easy solution if that works. I will keep you updated.


1 Like