Deconz is not working anymore or only with enorm delays after repluging the hardware

Hi exprienced deCONZ users,
I did use the Conbee Stick 2 with Deconz at my Synology NAS DS716+ since ages and it was always running quiet good. Since I replugged all my hardware on the weekend it is not working anymore. Some Zigbee devices have endless delays other don’t work at all.
I don’t find the problem.

Does someone can help me finding the error?
My setup:

  1. I did plug the conbee 2 Stick with a 1m USB extension to the first usb port of my Synology NAS DS716+
  2. I run in docker the deconzcommunity/deconz:2.24.2 container (as before)
  3. In the phoscon app the sensors get back to (not grey) after a very long time and I need to use them first.
  4. If use a light switch it can take more then 20seconds that the light turns on. very often it does not work at all.
  5. I did replug the hardware and rebootet the docker container again. same problem.
  6. the docker container constantly takes like 20% CPU time. This was before usally only 1% or so.
  7. here is the log of the first 3minutes after a restart:
    DS716date,stream,content2024-02-28T09:32:32.968582347Z,stdout,09:32:32:900 S -
    Is there anything wrong shown in the log?
  8. This is how the VNC deconz GUI looks like after 30minutes:

    Most connections seem to be finde. Some are still missing because I didn’t use them yet maybe.
    It is pretty slow to use the GUI.
  9. All other services on the NAS seems to run fine.

My wife is running crazy because lights and so on are not working anymore. HELP!
Any advices?
Thank you so much.

I believe there were fixes for high CPU issues in the most recent updates. Perhaps try installing 2.52.3 or 2.26.0 beta?

Thanks for your time and help!
I did install the 2.25.3 now .
It works just a little better but I’m still having massive delays. Also the CPU load remains higher then 20%.
Any other advice?

Give it a try with the last beta (v2.26.1-beta)

Please Check this Thread too:

Mine was workung perfect with 2.23.02 all of the versions beyond made the system unresponsive and lagging. for me it got better with the conbee II with version 2.26.0 hope it helps.

I’m running v2.26.1-beta now. CPU from this container is now down to 16%.
The lights react again, but still with a greater delay than usual. Devices that I had just used seem to work immediately. Devices that I haven’t used for a while have a delay of 1-5 seconds.
I’ll keep monitoring this.

Does any of this in log may cause the CPU load?

libpng warning: iCCP: known incorrect sRGB profile
GW sd-card image version file does not exist: /opt/deCONZ/gw-version

a lot of 'DB legacy loading sensor' for example:
DB legacy loading sensor Consumption 30 30, later handled by DDF wireless relay with neutral

a lot of 'skip legacy loading' for example:
skip legacy loading 00:17:88:01:06:03:51:95-0b / LWA001 

a lot of 'DB skip loading sensor' for example:
DB skip loading sensor WS Zisterne 5% 60L 163, handled by DDF Aqara Water Leak Sensor SJCGQ11LM

Device firmware version 0x26780700 ConBee II

a lot of 'TY_DATA_RESPONSE' for example:
TY_DATA_RESPONSE: seq 207, dpid: 0x04, type: 0x02, length: 4, val: 96

Can you share logs with log levels
Info , info L2, error, error L2, aps , aps l2

Delays often have relevance to Interference.

Hi @Mimiix ,
i just return from my travel for work. My wife is pretty angry because the zigbee is still not working. :-/

I’m not able to copy and paste the log from the VNC.
I tried all the ideas from this page: vnc viewer - How to enable text copy and paste for VNC - Super User

My setup is the following:
Synology NAS DS716+ with docker.
In docker I ran the container deconzcommunity/deconz:2.26.1 with
ad so on.
I did login from two different computers with different VNC clients:

  1. RealVNC VNC Viewer 6.21.406
  2. RealVNC RealVNC Viewer 7.10.0

Both times everything is turned on in the vnc config:

I’m able to see the log. The shortcut for select all works. I copy it.
But I can’t paste it to any editor in my 1. Windows 10 or 2. Windows 11 system.

Any ideas how I can show you the log?

@Mimiix : Okay I found a way. I installed TightVNCViewer and was able to copy and paste.
Here is the log:

Can you find a reason for my problem I described in detail in the first posting?
Thank you so much for your time!

IDK for other but on my side I don’t see something special on logs :

  • No missing bind in loop.
  • No tuya device spamming
  • In general no spamming request
  • No error
  • No “busy” error

You have a constant 20% cpu load ?

for TY_DATA_RESPONSE They are from the device itself, and deconz manage only 1 request, and the same device only do it every 10 mn.
There is an issue about that for some TRV, but you are far away the spamming result of them

@Smanar Thank you so much for looking into that. Sadly you didn’t find anything I could change and my system is still under >23% CPU load and absolutly not running smooth. I have very long delays since I did replug all the hardware. :frowning: I did restart everything many times now, but it does not help.

Do you have an idea what I can do to debug it further?
This is how it looks in the GUI:

You can’t install deconz on an other machine to test if it’s from deconz itself ?
You can clone your zigbee network using the phoscon backup/restore feature.

Make a test with a more recent version ? ATM there is a lot of update on performance on deconz version.

I agree withsmanar. No issues.

Can you circle the affected devices on the screen shots?

@Smanar @Mimiix: I would not be able to circle the devices because I have the delays on all items. If I send a light on via openhab it can take 10-20 seconds till the Hue bulb turns on. If I do it via a Aqara switch the time is around 20-50 seconds…

As I did not find a solution with 2.24.2, 2.25.3 and 2.26.1 I now installed 2.23.02 and everything is running perfectly again. It just takes milliseconds to turn on the lights and the CPU of the docker container is now only 3%. :slight_smile:

To double check I then did start the container again with deconz 2.26.1. The Container has >15% CPU load seems to go till over 20% in the next hour. And the delays are back. So something changed in 2.24.2, 2.25.3 or 2.26.1 which makes the system not stable anymore.

I will have to stick with 2.23.02 till a solution is found.
I did share my log already and don’t now what else I could do to assist.
Can anyone inform the developers of this issue?

Just by curiosity do you have Tuya router ?

I m searching what you can have on your network that others users don’t have …

@Smanar: I don’t have a Tuya router.
I can just list my network items:

  • ConBee II USB Stick on a 1m extension line attached to my Synology NAS DS716+
  • 3x Hue outdoor motion sensors
  • 10x Aqara indoor motion sensors
  • 2x Aqara FP1 presence sensors
  • 7x _TZE200_bjawzodf temperature, humidity sensors
  • 2x Aqara Multisensor temperature humidity
  • 18x Aqara window contact sensors
  • 4x Aqara vibration sensors
  • 4x Aqara water sensors
  • 12x Aqara OPPLE Schalter 3-fach WXCJKG13LM
  • 2x Aqara OPPLE Schalter 1-fach WXCJKG11LM
  • 2x Aqara Smart Switch WXKG12LM
  • 4x electric plugs as router _TZ3000_2putqrmw TS011F
  • 7x IKEA TRADFRI lights
  • 16x Hue lights
  • 2x Smart Relays with lights on it
  • 8x dimmer relays HK-LN-DIM-A

@de_employees :slight_smile:

1 Like