Can't pair Fyrtur

Allow me to ask a question related to this topic.

I am using version 2.25.3 of DeCONZ which comes with HomeAssistant. I have two IKEA Fyrtur covers, one of which has been happily doing its job with DeCONZ for over a year now. The other one I bought last week.

I cannot seem to be able to successfully connect my new Fyrtur to Phoscon.

I am using the new “blinds” menu (i.e. wasn’t there when I connected the old Fyrtur - I used “lights” back in the day) and click “add new blind”. On the Fyrtur I push both buttons for a few seconds until the motor buzzes and the light starts flashing.

After a few seconds, I can see a new device in DeCONZ without a proper name. Instead I see a hex numbers (which varies with each attempt). Meanwhile Phoscon will time out and report “failed to connect”. Only the old Fyrtur remains in the list of blinds. The new one does not show up.

In DeCONZ I can see the following settings:

Screenshot from 2024-04-29 08-22-51

When I click Edit->Edit DDF, DeCONZ shows me ikea/fyrtur_block-out_blind.json, which tells me, the Fyrtur is correctly recognized as such. (By the way, I have not changed anything.)

Why then does it not show up on Phoscon? (Also, it does not show up on HomeAssistent.)

I tried deleting the device through “Edit->Delete node” several times to start over. The result is always the same.
When I try pushing the two buttons on the Fyrtur once quickly, the light with turn on permanently, however, nothing shows up on DeCONZ (Phoscons times out again).
I am out of ideas of what to do next.

Please help! I could really use some advice.

I’ve moved your posts to a new topic.

Can you share a screenshot of the basic cluster?

1 Like

The DDF is not used (and I speak about the official one on the repo)
"status": "Draft",

Can you change the status to “Gold” ? No sure it’s possible on HA using the GUI, you probably need to create a new one.

1 Like

A huge thank you for your prompt reply.

I have to apologize for my ignorance right away. What exactly would be the “basic cluster”? A screenshot of the entire DeCONZ screen? Or anything more specific? Or do you mean this tab below?

Thank you so much for responding. As for the DDF, I am using the regular HA integration which as far as I know comes as a container. No idea, how I could gain write access to the DDFs or create a new one (I’m really a fish out of water, sorry). In DeCONZ when I choose “Edit DDF” I get this dialog where I can set the status to “Gold” as demonstrated here. Is this what you meant?

Unfortunately, even when I hit “File->Save” it will just revert back to “Draft”.

P.S. What might be the cause for my installation not using the right DDF from the repo? All I ever did was updating the integration trying never to mess with any of the DeCONZ settings. I am curious as this might give me an option to revert any undesirable changes.

Supplemental: I was able to “docker exec -it {ID} /bin/bash” into the container. To my surprise, the file in /usr/share/deCONZ/devices/ikea actually shows status “Gold”.

  "schema": "devcap1.schema.json",
  "manufacturername": "$MF_IKEA",
  "modelid": "FYRTUR block-out roller blind",
  "vendor": "IKEA of Sweden",
  "product": "FYRTUR block-out roller blind",
  "sleeper": false,
  "status": "Gold",
  "path": "/devices/ikea/fyrtur_block-out_roller_blind.json",
  "subdevices": [
      "restapi": "/lights",
      "uuid": [
      "items": [

Elsewhere they mentioned a directory named /data/.local/share/dresden-elektronik/deCONZ/devices/ which is completely empty in my container.

However, the “status”: “Draft” persists in the Phoscon API Information as well as on DeCONZ->Edit->Edit DDF.

[A sad update, the old Fyrtur stopped working as well. It’s still in the blinds list on Phoscon and also shows up in HA, but won’t move. No idea whether this was my fault for renaming the HA entity as well as the name on Phoscon. Usually renaming DeCONZ-Entities doesn’t cause trouble.]

This is the Ikea specific one. We need the basic cluster, it’s called like that :slight_smile:

In the GitHub wiki there’s a document describing how to do so

1 Like

Thank you for the hint. I believe this is what you requested:

Strange, it have the bad state by defaut deconz-rest-plugin/devices/ikea/fyrtur_block-out_roller_blind.json at master · dresden-elektronik/deconz-rest-plugin · GitHub
And not easy to correct that using docker.

For me the easier thing, is creating a new DDF with the status"Gold" in the folder for HA /data/.local/share/dresden-elektronik/deCONZ/devices/ (and yes this folder can be empty, if it’s your first DDF)

After that, when you make right clic + edit DDf, you need to see this one on the editor title bar.

1 Like

And it’s still a hex name? The device?

1 Like

Yes, it is.

I tried pairing again after a reboot last night. But it’s still a hex name (albeit a different one from the one in the screenshot above).

So it mean, it don’t use the DDF. As you can’t edit the actual one, try to create a new one with the good status.

1 Like

Thank you so much for taking the time to respond. It’s very much appreciated.

Following your instructions mentioned here, I took a look at the inside of the container again.

root@core-deconz:/# mount
/dev/mmcblk0p8 on /data type ext4 (rw,relatime,commit=30)

This leads me to expect that anything stored under /data will survive a container upgrade.

So, I established a new fyrtur[…].json file in that partition.

root@core-deconz:~/.local/share/dresden-elektronik/deCONZ/devices# mcedit fyrtur_block-out_roller_blind.json

I pasted the contents of this source into that json file:

I noticed the same file in the v2.24.2_stable and master branches both list "status": "Draft". :thinking: That is why I used the older version from the v2.23.x_stable branch.

Your instructions earlier in this thread as well as the link you referred to (How to add/edit a DDF on Home assistant using text editor? - #18 by bcutter) both mention something about a “hot reload” using a right-click when accessing “Edit DDF” in DeCONZ. Right-clicking that menu item does not seem to do anything. The dropdown menu just disappears. So I clicked “File->Hot reload Ctrl+R” in the DDF Editor window for ikea/fyrtur[…].json. Well, the status in the dialog persists at “Draft”.

What did I do wrong?

Maybe interesting side fact (at least for me): Upon rebooting the Raspi last night, the file in /usr/share/deCONZ/devices/ikea listed the “Draft” status again, after it showed “Gold” last time I took a look inside the container. So, apparently I has been able to change it using the webui prior to peeking inside the container, although that change did not persist (and apparently wasn’t picked up by DeCONZ?!).

General question: Seeing the Draft status in that file in the master branch on Github makes me wonder why not everyone using these Fyrtur roll-out covers would be affected. Or are they?

P.S. Also tried to pair it. Again, it’s just a hex number and “Edit DDF” shows “Draft”.

The path need to be
and not
(The folder is invisible, thx docker, always so easy to use)

I pasted the contents of this source into that json file:

Don’t forget to change the status too.

both mention something about a “hot reload” using a right-click when accessing “Edit DDF” in DeCONZ. Right-clicking that menu item does not seem to do anything. The dropdown menu just disappears. So I clicked “File->Hot reload Ctrl+R” in the DDF Editor window for ikea/fyrtur[…].json

Yes, this menu is in the editor, but on your side, as you edit the container, you need to restart deconz.

1 Like

@Smanar, you are brilliant! It’s working now!!! :tada:

Turns out, what I needed to do was to enter the DDF Editor and then choose “File->Open”. The freshly added DDF was the only file listed in the selection. So, I opened it and got “Status: Gold” right away. After another attempt at pairing the Fyrtur cover, it showed up as “Window covering device 32” in DeCONZ as well as in the blind menu of Phoscon. :clinking_glasses:

Thank you so much for keeping up with me (and spoon-feeding me - I know I can be a little thick at times). Merci, danke schön, gracias!

P.S. I am still concerned others using the same setup (HA+Conbee II) might hit the same roadblock as long as the fyrtur[…].json in the master branch is designated as a draft. Maybe I’m wrong, though.

1 Like

They shouldnt be draft!
Happy to see its fixed. I wasnt aware this could even happen.

I made a PR to correct the fault: Update fyrtur_block-out_roller_blind.json by Mimiix · Pull Request #7736 · dresden-elektronik/deconz-rest-plugin · GitHub

1 Like

Asked @ebaauw about this. Looks like theres another DDF in play:

1 Like

Ok, so the issue is from deconz.
If you have more than 1 DDF for the same device, you can set 1 on “Gold” and other in “Draft”, deconz will take one of them randomly, even a “Draft” one.
I have the same problem for Lixee device.

1 Like

Interesting to see two DDFs interfering. Seems, though, like this only happens once in a while.

Update: Just FYI, upon re-joining the IKEA open/close button, it receives a new designation in HA which confused me. If anybody else runs into that, just check Developer Tools->Events-Listen.