Can not add Aqara Window and Door Sensor to Phoscon

Hello all,
first - i am new no conbee 2, deconz and phoscon, so I hope you can help me.
I have running a raspberry with deconz and a conbee 2 stick.
In phoscon I have added some switches, lights and sensors - most IKEA Tradfri.
This all is working fine.
Now I tried to add so Xiaomi Aqara Sensors. First a water sensor what is working
fine as well.
But I fail on the Aquara Window & Door Sensors. I could not get them recognised in phoscon.

The status LED on the sonsor is flashing 2 times after short pressing the button what meens, the sensor is in the network. (…but not shown in phoscon)

Version 2.13.04 / 18.12.2021 - Firmware 26660700

Can you please help me? Where is my mistake?

papamorpheus

Hello, so if I remember Xiaomi device make 2 blinks followed by 3 blinks (or the reverse)
You can press shortly the reset button every second AFTER the pairing procedure to prevent the device going to sleep.

Hello Smanar
and thanks for your input. You are right - the Xiaomi device first blinks 3 times for signaling its reset and then 2 times for signaling “contact to the net”.
So far so good. Thats what my device is doing as well.
But its not shown in proscon…
I have tried this innumerable times.

You already have added device, so I don’t think it s a problem from your side.
Do you have something to access to the deconz application ? A Desktop OS or VNC stuff ? To check how/if the device appear.

Are you sure for battery ?

Something that can help too, is using the device during the pairing (use the magnet for exemple)

Is yours a P1 door and window sensor? I don’t think this new version of the door and window sensor is supported by deconz yet.

Hello Smanar
and thanks again for sharing your thoughts.
I checked the battary and I tried to use the device while trying to pair.
At the moment I have running a headless raspberry, so I could noch check in the deconz application, but I will setup a new SD-Card on the Weekend and will try set.

Hello Ar-Eh
and thanks for your input. Good question. Es I can find an E1 on the box, it seems, that these sensors are the “new” version. Grrr
I hope, there is a solution. The sensors from the Ali Link are the old ones?
…and they will work?

Can you pleasE:

  • Update to the latest firmware (267xx)
  • Share some logs (after the firmware update, if they still dont work) > How to get logs?

Hello Mimiix
and thanks for the support.
I Updated the stick to 26720700 what makes no change.

Then, to make it a bit more easy to test, i installed the conbee2 an deConz on my Win10 PC to have a GUI for deConz. Just with one light and one switch for testing. Then I tried to pair the Aqara Windows Sensor again.
In Phoscon nothing happens, but in the GUI from Phoscon App, I can see the sensor.
…and it seems, as the sensor ist working. If I open or close the sensor (by magnet), the “indicator light” in deConz is flashing 5 times.
But the sensor is still not shown in Phoscon (or ioBroker).
Now I will try to get some logs. I will post them, as fast as possible.

https://pastebin.com/embed_js/MRW7xjAW

sorry - I am not sure how to show the logs here. (after using a pastebin service)

What you can see in the logfile every time you open or close the sensor (0x6a07)is:

10:49:47:403 APS-DATA.indication srcAddr: 0x6a07, srcEp: 0x01 dstAddrMode: 2, profile: 0x0104, cluster: 0x0500, lqi: 255, rssi: -41

10:49:47:403 asdu: 193100000100000000

10:49:47:403 APS-DATA.indication from child 0x6A07

10:49:47:405 void DeRestPluginPrivate::handleIasZoneClusterIndication(const deCONZ::ApsDataIndication&, deCONZ::ZclFrame&),196: assertion ‘itemIasState’ failed

10:49:47:405 void DeRestPluginPrivate::handleIasZoneClusterIndication(const deCONZ::ApsDataIndication&, deCONZ::ZclFrame&),197: assertion ‘itemPending’ failed

Can you show a screenshot of the device in deCONZ? Also, what does the basic cluster read?

No Problem.
I am not sure about "basic cluster read). Is that what is shown on the “cluster info” tab?
This tab shows nothing for all of my components.

Here you have the procedure How to read Clusters · dresden-elektronik/deconz-rest-plugin Wiki · GitHub
and inside we will see the model id, but I think they are right, the device seem totally integrated in deconz, if you still have nothing in the API, it s probably a new device.

Hello Smanar
and thanks for the Link to the guide.
See the results below.

I have to select a specific cluster to get so informations. Here are the results for BASIC Cluster.
But its the same in the other clusters - nearly no information.

It seems, that the new version of this sensor is not supportet today (Version MCCGQ14ML).
There is an older Version (MCCGQ11ML) of this Sensor what is working fine. I got one from a friend this afternoon for testing. Both Version are looking absolutely identical. The versionnumber is only written on the packaging. Manufacturing date of the old version was Oct. 2021.

So first news, this device is not in the API core.
Second new there is already a DDF for this one deconz-rest-plugin/xiaomi_mccgq14lm_openclose_sensor.json at master · dresden-elektronik/deconz-rest-plugin · GitHub

So if you enable DDF (in the Menu Panel/control) it can work.
To force detection, after enabled the DDF, right clic on the node title ,“edit DDF”, you will see the DDF editor with the previous path file on the title, then on the new menu “hot reload” (perhpas you need to set phoscon in permit join = “add new sensor”)

If it work you will see a better name for the node (other thing than 0xXXXX)

Thanks again to Smanar.
Again a little success. I set DDF in the control panel to: Basic → Silver
After a few Seconds the name of the sensor changed in deConz to “OpenClose 7”

In Cluster Info => IAS Zone you can see the Zone Status od “Alarm 1” changing if you open or close the sensor. That seems to be good.

Next good news - the sensor appears in phoscon as well.

BUT - it only appears. Ther is no change of the status. Its always closed (geschlossen).

The sensor "Fenster- / Türkontaktsensor (2) is the old version working fine and “OpenClose 7” is the new version - not working / always closed (geschlossen)

I have a different but related problem adding this door and window sensor. I was actually successful initially adding it using phoscon and the deconz GUI. The node appeared in the GUI as a non-descript device, and I was able to get it to pair and show up in Phoscon by reading the descriptors and cluster info while pressing the button repeatedly to keep the sensor awake.

However, I did not like the router that the door/window sensor bonded with and I foolishly deleted the sensor from Phoscon (not realizing how lucky I was to have successfully paired the sensor at all). Now when I try to re-pair it (even using bronze DDF and hybrid mode), it will not show up in the GUI. Do I need to delete an entry for this device somewhere so I can try to re-pair it “fresh”, and if so, how do I do that? Thanks!

@Ar-Eh if you have deleted it using deconz, it have deleted it too in the API.
And it can not appaear in the API or phoscon, but nothing can prevent it to be visible in deconz itself (the GUI), except if you realy have an issue.

Check if you have not for exemple phoscon open on 2 browser page.

@papamorpheus can you show the device JSON ? You can find it in phoscon / help / api information / sensors
Can you try too the 3 DDF mode, Basic / hybrid / strict ?

Edit:
BTW I m reading the DDF, one the DDF it use the Xiami cluster and not the IAS cluster, I will try to ask if I can find the one that have make this DDF.