Aqara Wireless Switch H1 - High-Speed Click Mode

I’m enjoying using deconz on a PI 4. I’ve just added my new Aqara Wireless Switch H1 successfully.

However it seems by default to have the same 1/2 second delay previous switches had. The manual says to go to the Aqara app to configure high-speed click mode. I’m guessing this means I’d need to buy a hub and configure each switch via the Aqara app once first.

Is there any way I can avoid buying the hub just for this, and do it via deconz? I was hoping to see some config option via the REST API but don’t.

I’m on Phoscon 2.12.06 / 19/08/2021 and ConBee II with firmware 26660700.

Thanks!

Additionally, the Aqara site states that it’s possible to control devices even if the hub goes down. I therefore expected to see a config.group setting for this, but none is listed. Any idea if this is possible as well?

Further to this, I bought the E1 hub from Amazon in the hopes I could enable high-speed click mode and then use that via deconz after. However switching between the PI with deconz and the Aqara E1 hub and back required the switch to be reset each time. And in doing so it forgot the high-speed click setting, that appeared to be enabled by default after pairing with the E1.

Do I need to somehow sniff the zigbee traffic to work out what commands/attributes are used? I’ve no idea how to do that, but would be open to trying it as long as I don’t need to buy more stuff!

Asked @swoop to check this as hes the Xiaomi master :slight_smile:

1 Like

It’s always recommendable to first do some research and ask around when not too knowledgable around zigbee. Sorry to say that, but individual expectation very often remain unfulfilled, especially when it comes to most Chinese vendors, as they do as often not comply with zigbee standards. Having the zigbee logo does not mean it is a certified device and even having a certification does also not necessarily mean compliance.

That having said, there’s high chances that whatever high speed mode they advertise is either nothing else than using certain zigbee features or a proprietary mechanism solely working with their gateway. Unless proven otherwise, I consider it as marketing hoax.

To really know what’s going on, it would require to sniff the zigbee traffic between the gateway and the device. This has already been done for other devices and it is know that there’s some messages exchanged which couldn’t be reverse engineered yet, as presumably some encryption or hashing is applied. A 10 minute sniff of communication with the original gateway would be very useful to get some deeper insights.

Other than that, there’s not much more we can do than poke around in the dark while any dev has the device in hands. I’m hoping to get one in the next days so hopefully, I might be able to tickle a bit more out of it.

Lastly worth to note, the device isn’t supported yet. As it is mains powered, some basic features are exposed and it is generally usable, but there’s chances that quite some features are missing.

Many thanks @Swoop

The one I’m using isn’t mains powered, it’s the wireless one.

Happy to attempt to do a sniff. I’m a dev too, though not in this field. Just point me to instructions to do this if it’s useful.

I’m happy to invest a bit of time on this as the switches do seem really nice, but I’m not sure I can live with the 1/2 second delay.

Best wishes,

Justin

Hm, I got the wireless double rocker lying here but as far as I can tell, there is no high speed mode. Of course it could also be that a certain combination of attributes must be set but this is a bit tapping in the dark without knowing what to explicitly look for :thinking:

As of now, I’d rather consider the zigbee groupcast mode as such. However, I also discovered that they seem to have a Xiaomi specific mode of operation…

I’d be interested to see what Zigbee traffic is sent when toggling the mode from High-speed Click Mode to Multi-function Mode and back via the Aqara app, when connected to an Aqara hub. It takes a few seconds to apply the change, and can be sped up by tapping a switch button 5 times.

Unfortunately I don’t have any Aqara lights to test the responsiveness with. I added a push notification action, but they’re delayed about 2 seconds anyway presumably due to internet round trip.

Side note: seems really that Aqara have loads of switches and sensors and only one light, and no ability (that I could see) to use third party, e.g. Hue, lights with the hub. A lot of controls for not a lot of action!

Hm, I just had a quick play around. Interestingly, the 5 press approach seems to force the device to send the Xiaomi special attribute reporting and have it do some mac polling. So in consequence, that allows you to read/write things from/to the device, which is good to know.

Without that trick, it requires you to wait for like 1h for the device to mac poll and be able to do anything. Curious if there’s anything further to discover.

I remain hopeful! Thanks for your help.

Just found that in a youtube vid, so there’s apparently no highspeed in highspeed :wink:

grafik

Not sure I follow. Did the video show it not responding quickly even with high-speed mode enabled? Got a link?

I have the same settings and am able to select the high-speed mode, though am unable to verify due to lack of Aqara lights.

In principle the descriptions seem to make sense. To get high speed mode you would need to sacrifice double tap. (Though removing long press support seems unnecessary)

Don’t have the link anymore as I was looking for something different while going through the depths of YT.

Regardless, I know how to make those setting. In deconz GUI, select the Lumi specific cluster 0xFCC0. The respective attribute is 0x0125, which is currently preconfigured to value 2 (multi-function mode). Double click on the attribute and replace value 2 with 1. Before pressing write (not write config), wake up the switch with a quick 5x button press on the device. When the write is successful, it should be in the above mentioned high speed click mode.

Thanks so much. I’ll give this a go ASAP and report back.

I don’t have the GUI installed currently so might need a bit of fiddling. Is it possible to apply these changes via the REST API? (Assuming not as I didn’t find it in the docs)

Last night I fiddled with my headless PI 4 and managed to get into the deconz GUI and change that setting. I also needed to upgrade to the latest beta (was on latest stable) to see the attributes in cluster 0xFCC0.

The good news is it worked - both buttons were responding near instantly. :partying_face:

The bad news is, when I went to demo it to the wife this morning, it had reverted to the previous 500ms delay. :sob:

I don’t see myself going into the GUI each day to set the mode for 16 or so switches and even if it was possible via the REST API it would seem a pita to have to set up another service on the PI to fire requests to do this.

Is there a general purpose way to solve this within deconz? If not, then maybe a consideration for version 3?

Again, many thanks for your help.

I see your point.

Could it be that deconz has beenr restarted after you switched to high speed mode? The mechanism to apply the switch configuration should only be triggered during pairing or after deconz restart. It sets a bit which is checked against and clears it when the required requests have been send. However, I think I happened to see that bit still being there once during some testing as I recall… Maybe you can try again and oversve it for a bit.

Regarding API exposure, it’s not as trivial as one might think, but it’s definitively on my list as Xiaomi devices are partially capable of so much more than is exposed via API and almost nobody knows that it can be configured via deconz GUI. Will bring that into discussion.

Another option could also be that you compile an amended version for yourself. It’s basically just 2 chars which need to be changed, given that you don’t run HA (which makes thing way more complicated).

Many thanks @Swoop. I’ll set it again and see if it survives a restart. Once I can get the GUI to connect again that is, it’s strangely not working now.

API exposure sounds good, though I can imagine it’s a big change. I’ve added some more general feedback/thoughts to another post. But it would be great if the GUI was a webui on top of an API like (or part of) Phoscon.

As much as I want these switches to work, I’ll probably not go as far as compiling my own deconz.

1 Like

The last comment was a few months ago but any luck on the highspeed-mode? I’ve updated my Conbee II to the latest firmware, Deconz is also up to date but I’m still unable to get the LUMI specific attribute in Cluster info.

Also tried to do something similar with Zigbee2MQTT but also without luck, even bought an Aqara M1S but no Highspeed-mode available in the app.

I’m using the H1 wireless battery powered switch.

Sounds like you’re in a similar spot as me @michel2412 . I was also using the wireless H1.

I’ve not done anything more with this I’m afraid. We verified the switches do have a high-speed mode, and I managed to get that working with deconz briefly. I suspect you might need to get the latest development release of deconz, rather than the latest stable release, to see the required LUMI specific attributes.

However I wasn’t able to keep using this for a couple of reasons:

  • The development release of deconz wasn’t stable enough, switch presses were sometimes ignored. This may be fixed now as it was a while ago.
  • The attribute change via the deconz GUI didn’t persist after 12 hours. I think a code change to deconz would be required to fix it. I’m still holding out hope that this might happen. :smiley: cc @Swoop

I’m surprised you’re not seeing the high speed mode in the Aqara app when using the hub.

I think I know why the attribute is not showing, it appears I’m using the D1 switch instead of the H1 version. The high-speed mode is not mentioned in the specs of the D1 switch but it does wait 0,5 sec for a second press. I think I have to live with the latency and save some money to buy Gira Friends of Hue switches which are a bit expensive (50-60 euro’s).

I’ll keep this topic on my watchlist hoping someone knows how to get rid of the stupid delay.

Thanks for the reply @LinearPancakes