Aqara TVOC is not showing in GUI nor updating to fhem

Hi All,

today I got a Aqara TVOC.
After updating Phoscon to 2.14.01 / 6.2.2022 and my ConBee II to 26720700
I was able to add the sensor.

BUT it does not show up in the GUI.
It says new sensor added, but nothing more.

I also run fhem and it created a device for the Aqara. On this device, temp is updated frequently, but pph only once and never again.

Any idea?

I just saw in the Hue Essential app on my iPhone, there is a sensor called “Temperature 22”.
This seems to be the Aqara.

If I click on it the app is crashing.

If you see devices within deCONZ but not in Phoscon, that is most of the time perfectly normal. Phoscon is closed source and needs devices to be added manually by their developer. However, the device will still be usable with the API/Home-Assistant/OpenHAB etc.

Phoscon doesn’t out of the box show all devices.

Don’t get your point.
All my other devices are visible in the web interface.

The bigger issue is, the sensor is not sending updates, or Phoscon is not processing them.

@de_employees this is a great example on how confusing the whole situation is…

Working fine so far. We have updated the pwa today, please clear your browser cache and reload the web-app. If this doesn´t work, reset the sensor and bringt it in new.

The Aqara TVOC should be shown :thinking: note currently the sensor is only processed when DDF mode Silver is enabled: Supported Devices - deCONZ REST-API

But I’ve recently noticed too that the values don’t update that often and sometimes not all after the initial setup. Unfortunately the attributes don’t support configuration of the reporting intervals.

I think the Xiaomi special report in the Lumi specific cluster is send more regular, even if the values don’t change too much. Work has started trying to leverage this in the DDF but it’s not yet in the release.


Thank you, the sensor is now visible, but still no changes on the ppb.
In my home automation (fhem), the only and last one is from yesterday while initial installation was done.

see Aqara TVOC ZHAAirQuality data

AFAIK there is no fix / workaround yet.

@manup @Gautama did you notice the TODO in the users screen>?

The translation seems to be done, but still no sensor updates:

You mean the exact ppb? I think that’s not exposed yet.

No, not only pph, all values are not updated (see screenshot with “vor 5 Stunden”).

Also i figured out, phoscon is not sending hum to fhem. In fhem there are only ppb and temp.
But also for sure, values are not updated here as well.

Phoscon doesn’t send anything to fhem, deconz does that. Either way check this url

1 Like

After two days, I can tell you the sensor is sending at least a view time a day some values.
Not sure how frequent it should be, but I think this is okay.

What is still missing, humanity thru API.