Aqara Temperature and Humidity Sensor update intervals

One of my many Aqara Temperature and Humidity Sensors suddenly slowed down its update frequency from being approx. every 15sec down to only every 10 min. which pretty much makes it useless. While the updates for air pressure and temp. from the same device remains as usual.
What could have caused this to happen, and only for humidity?
Is there a setting somewhere reachable from deConz via a cluster, where the update interval for the Aqara Temperature and Humidity Sensor can be set?


It happen suddently ? and only for humidity ?
Do you have the device modeld id ? (to check the DDF)

Tell me where to find the “device model ID”, please…

Using Deconz GUI you can find it in displaying the basic cluster. Using REST-API, Phoscon or third-party in the json returned for the sensor you could find somewhere something looking like this :

"manufacturername": "Xiaomi",
"modelid": "WSDCGQ11LM",

You’ll have probably other values than in my example :wink: …

Yeah, as the device is already included in the API, your third app surely display it somewhere, what are you using ?
Phoscon too is able, but something it change the real value.
Else can use Phoscon/help/API Information/sensors

This the info I found in the API:

    "config": {
        "battery": 100,
        "offset": 0,
        "on": true,
        "reachable": true
    "ep": 1,
    "etag": "eed8511077ced32218c98302c9ab6cc6",
    "lastannounced": "2023-03-26T08:27:50Z",
    "lastseen": "2023-04-01T14:58Z",
    "manufacturername": "LUMI",
    "modelid": "",
    "name": "Sensor Bad 1",
    "state": {
        "humidity": 4308,
        "lastupdated": "2023-04-01T09:24:31.524"
    "swversion": "20191205",
    "type": "ZHAHumidity",
    "uniqueid": "00:15:8d:00:01:c1:e0:be-01-0405"

And here is an event:

    "16:58:35:64": {
        "attr": {
            "id": "56",
            "lastannounced": "2023-03-26T08:27:50Z",
            "lastseen": "2023-04-01T14:58Z",
            "manufacturername": "LUMI",
            "modelid": "",
            "name": "Sensor Bad 1",
            "swversion": "20191205",
            "type": "ZHAHumidity",
            "uniqueid": "00:15:8d:00:01:c1:e0:be-01-0405"
        "e": "changed",
        "id": "56",
        "r": "sensors",
        "t": "event",
        "uniqueid": "00:15:8d:00:01:c1:e0:be-01-0405"

This is what a typical normal curve look like:

The above curve has 36 measuring points (events).

But now suddenly it looks like this:

This curve has only 7 measuring points (events).

So, for some reason the sensivity, or measuring intervals has suddenly changed dramatically.
I tried to remove the battery in order to “reset” the device, but to no avail.

The only change I m seing is for temperature Ignore invalid Aqara -100 temperature (#6723) · dresden-elektronik/deconz-rest-plugin@6f6f4a0 · GitHub

And now I remember Xiaomi don’t use report/bind, all is native, so can’t be a setting issue.

It happen suddently ? you haven’t updated something ?

No, nothing changed. And this problem only affected one device (I have 4 of them).
Also see this post:

And why only humidity ?
If it was a battery issue, you will have the same reaction for temperature too …

Exactly, that’s my question too.
Only humidity is affected. Temp and pressure is working just fine. And if course I did replace the battery - just to be sure, but to no avail.

So, I bought a new device, same brand, same type.
And the problem remains the same. That rules out any HW issues. So this must be related either to deConz or Home Assistant. I doubt it is HA, so there’s something fishy going on.
Again, remember; I have three other units, exactly identical. All three connected to HA through deConz and they all work perfectly.

And there is no difference ?
Same swversion ?
Perhaps with enabling/disabling DDF ?

Yes, all have Firmware: 20191205.
How do I enable/disable DDF?

Mine still works as it should.

Well, as I said; I have three units that work as they should. But my fourth unit fails.
Please guide me on how to enable/disable a DDF?

Not sure how that would help.

Check the wiki on github, there’s a ddf cheatsheet.

Couldn’t find it - do you have a link?

I won’t be able to until at least tommorow.

It’s on the GitHub wiki.

That’s ok - have a good Easter :+1:

You can disable all DDf in a row using the GUi on Panel/control
Else you can disable only the DDF for this device.

And make a backup before, I m not sure the operation is safe.

1 Like