Aqara Roller Shade Driver E1


I just wanted to add that using the ‘Window Covering’ device cluster info panel, I can operate the shade driver with the up (open), Down (close) and stop functions. I just cannot see the device in the API.


Hi all,

Been researching but not found much, is there a way I can add this to Home Assistant or to the API manually in order to test it? Using the cluster in deconz I can control the device fully, I am missing battery info and not sure about position feedback, but for a start I can open and close it fully or based on a percentage - although without it being available in Home Assistant or NodeRed I cannot automate, so it’s manually operated via a mouse click.

I know that the next beta will start to bring DDF to allow us to integrate our own devices but I don’t know if I can use the beta in Home Assistant, is there a way to do that?

Any help is much appreciated!

Kind regards,

Have just purchased one of these and in my deconz it is showing up as a dimmable light with no functionality. Can’t wait for it to work!

Same here… dimmable but no action. this is going to be the next big thing in rollershade world. Next to the Zemismart stuff which is namely tuya zigbee I think if conbee2 supports this one it will help the sell of the sticks for them!

How did you get to get the “cluster info there” mine is empty:

Nevermind. I can control this way yes:

Any news on integration of the E1 to deCONZ?

I’m about to buy a couple of those but it’s not of interest if there is no integration with deCONZ/Phoscon.

Check the corresponding github issue and pr.

Can’t believe this is still not supported 3 months later. Is DeConz-dev really done at such a slow pace? (no blame intended just being curious here!)
Guess I’ll have to ditch the DeConz-Integration and finally go with ZHA…

Just did a test with ZHA yesterday and the Roller Shade Driver E1 was (almost) perfectly detected and usable with the ZHA-integration! (battery level was missing but up/down/stop and percentage position have been available!)

As I’m thinking of replacing the ConBee II with a CC2652P stick (ZigStar v4) I’ll have to either go with ZHA or Z2M in the future anyway.

Did you even check the issue? Feel free to switch when ether you want :slight_smile:

What do you mean? The Aqara device is still unsupported in the DeConz-integration and the request to support it is 3+ months old…
And the device is already working in ZHA and Z2M

Regardless of the underlying I ssue I was wondering if this is the expected pace for these kind of requests.

There’s been a lot of backend work to ease the work required to add support for new devices, so it should be quicker going forward. It will also be easier for any user to add support for a device decoupling the dependency to c++ knowledge for device support.

If you have checked the url in the first post of this topic, you would have seen what the current implementation status was Aqara Roller Shade Driver E1 · Issue #5330 · dresden-elektronik/deconz-rest-plugin · GitHub

The suggest it is working on the latest versions :slight_smile but that there’s an issue with the device new firmware not working properly.

Doubting to get these as well.
Are they stable now and worth buying?

I read its working on latest versions but then theres an issue not working properly.
Does this means it works or not? Its double…

If working half, then what are the remaining issues?

After using Phoscon/Raspbee with Nodered for years with a bunch of different manufactures (inc. Aqara) without any problems ever, I instantly ordered 5 Roller shades when I saw them online - not even thinking they could not be supported. Now im sitting here with some 350.- worth of roller shades scratching my head. I’m running the latest version of the Gateway and the roller driver still gets recognized as a “Dimmable Light”.

As stated above the roller driver is recognized by deCONZ and can be fully operated using the “Window Covering Cluster”. I dont get why this isnt passed on to Phoscon? Or is there any way to direclty send commands to deCONZ from NodeRed, bypassing Phoscon?

I read through the GitHub but the stuff discussed there is quite a bit beyond my level of knowledge. What i took from there is basically: If you are willing to tinker around with a whole bunch of firmware upgrades and coding, you MIGHT get it to work in HA.

Im however not running HA. Im going directly from Phoscon to NodeRed and would prefer to keep it that way.

Do I have to send all the roller drivers back or is there a straightforward way of using them in Phoscon/Nodered by now?

So with the v2.15.0-beta the Roller shades are still displayed as Dimmable Lights in de Phoscon GUI, but in Deconz they show up as “Window Covering devices” and are also exposed accordingly to NodeRed. All good so far. However no matter what command I try sending from NodeRed i get an error. Has anyone managed to activate these from within NodeRed? I suppose one would have to send a JASON command, since there is no native open/close or up/down command exposed by Phoscon.

I have read around the 2.15 documentation for the roller shutters but i’m not knowledgabel enought to fabricate my own JASON-code out of that is written there.

I tried injecting {“state”: “on”} and {“state”: “open”} into the device node, but NoderRed gives me the debug-message “deconz-out ERROR: parameter, state, not available”

Any ideas anyone?

Hello, can you try with {“open”: true} to /state or {“on”: true} to /state too.

But strange you still have the issue, on the 2.15.0 I m reading

Starting with this PR the sub resource “type” attribute will overwrite the one given by the C++ implementation, like here “Dimmable light” is replaced with “Window covering device”, this might be handy for other devices as well.

Thank you for helping me out here! I tried your suggestion, unfortunately i didnt work either. But at least there is a new and improved error message:


I have no idea if im even doing this right in terms of the node-config:

True and false are boolean values, but you’re providing them as sting values, hence the API tells you the values are invalid. Remove the quotes for the provided values.

Thanks for the input! I removed the quotes, however now the node generates an error about the transitiontime-parameter and still nothing happens


The parameter being exposed is obviously a consequence of Deconz still thinking the device is a dimmable light.

EDIT: Ha! It just came down to manually deleting the default “0” in the transition time field and then redeploying the node with an empty field. Now it works!

Thank you all for your great help. For whoever is trying this at home, here comes the NR-Code

[{"id":"b6302fe7.c8ec7","type":"deconz-output","z":"822afcf4.d37ac","name":"","server":"5df02e6e.9abef","device":"54:ef:44:10:00:32:9e:1f-01","device_name":"shade_bedroom : Window covering device","command":"json","commandType":"object","payload":"payload","payloadType":"msg","transitionTime":"","x":1590,"y":260,"wires":[]},{"id":"994adead.38984","type":"inject","z":"822afcf4.d37ac","name":"","props":[{"p":"payload"}],"repeat":"","crontab":"","once":false,"onceDelay":0.1,"topic":"","payload":"{\"open\": false}","payloadType":"json","x":1250,"y":280,"wires":[["b6302fe7.c8ec7"]]},{"id":"138a33b6.fa25cc","type":"inject","z":"822afcf4.d37ac","name":"","props":[{"p":"payload"}],"repeat":"","crontab":"","once":false,"onceDelay":0.1,"topic":"","payload":"{\"open\": true}","payloadType":"json","x":1250,"y":220,"wires":[["b6302fe7.c8ec7"]]},{"id":"5df02e6e.9abef","type":"deconz-server","name":"Raspbee","ip":"","port":"80","apikey":"5B6EFDA413","ws_port":"443","secure":false,"polling":"15"}]

What i Havent found out is how to have the shades close to a certain position. All i can do is fully open or close them. If anyone has an input on that, i’d highly appreciate it!