3 gang remote switch - Tuya_TZ3000_TS0043

I have just obtained one of the above switches and am struggling to get it fully recognised by deCONZ v2.22.2. It will only appear as “0xB732” or similar and shows as linked to the nearest powered node. I have tried adding it several time and all I get is the value that appears to change. It has been “online” for some 36 hours.
It does NOT appear in Homeseer 4.
I have restarted deCONZ and no change. Removed and replace the battery. The device is within 3 m of a Zigbee power socket.
Clicking on the right hand button of the node shows the “expected” 3 on / off controls and the top level control. No battery symbol appears in the node diagram.
How may I get deCONZ to recognise the switch?
Many thanks.

Looks like it’s unsupported. I recommend opening an new device request on GitHub.

Thanks for this - I have looked at GitHub and can see a DDF there which appears the same as the one i see on my system. I will raise a request.

Check the Basic cluster for the model ID and manufacturer name.

With the node selected in deCONZ, the “Cluster Info” panel is totally blank - not even headings! Going to the “Node Info” panel I get a product name of “0xa4c1389664b74f66” with both Manufacturer and Model Identifier shown as “Unknown”.
As I have not raised a request before I am struggling to navigate the deCOnz support to find out where / how to ask for help!!

You need to click the basic cluster, and click “read”.

That page describes how to read it.

This page describes how to create a request: Request Device Support · dresden-elektronik/deconz-rest-plugin Wiki · GitHub

@Mimiix - many thanks for link and for bearing with me - I had, I thought, been following the advice on how to read the clusters info and, looking at it now, I realise the error of my searching! I can now see the expected information reproduced below.
The node info is reported as below
I will have another look at the Git Hub request page and see if I can find the template this time if only for future reference.
Thanks again.


You need to read the clusters instead of the node info :slight_smile:

Now then, One day I will learn how to proof read before pressing send…thanks for your patience!

Hope this makes more sense…

You can try to add your model like for this one DDF for Tuya 3-gang switch (_TZ3000_w3c7ouru) by Smanar · Pull Request #6728 · dresden-elektronik/deconz-rest-plugin · GitHub

Let’s first create a device request.

I’ll check in a bit

Looks like it is indeed not supported.

I recommend opening a device request.

Basically, you need to make screenshots of all clusters like you did with this basic cluster and put that in the template.

Thank you - will try to do so but will need to get my head around the template which could take a few days!

1 Like

Have submitted a device request - hopefully with the correct and enough information this time…

1 Like

Looks good

@Mimiix - thanks for letting me know!

1 Like

Many thanks for prompt help - switch now working.

Having updated to deCONZ v2.23.0,I find that this switch will o longer work. It is showing in deCONZ but none of the programmed scenes will work. I have tried “re-pairng” the switch and no change.

Did the DDF get over written?

The DDF is dated 31st July so probably overwritten? I am assuming the location below is correct?

Looking at the DDF I cannot see the model number “_TZ30000_pkeqinnt”, present so have added same but closing and restarting deCONZ finds the switch but it is still not functioning.

Is there anything else I can try to get the switch working again?

Thanks for any help.