Zigbee2mqtt openwrt ser2net working!

I just want to share my config in case someone else tries the same. I’m not sure it works with the ser2net package from the current release, so I installed an up-to-date version from Index of /snapshots/packages/x86_64/packages/

The Conbee II is attached to a x86 Openwrt box (APU3D4). Here’s the config:

config ser2net 'global'
	option enabled '1'

config controlport
	option enabled '0'
	option host 'localhost'
	option port '2000'

config default
	option local	'false'
config proxy
	option timeout '0'
	option baudrate '115200'
	option databits '8'
	option parity 'none'
	option stopbits '1'
	option protocol 'raw'
	option device '/dev/ttyACM0'
	option enabled '1'
	list options 'kickolduser'
	list options 'NOBREAK'
	option port ',20108'

you can make sure ser2net is bound to a port with netstat -lnp | grep ser2net. From some other machine on the lan you can check nmap -p 20108 <openwrt-ip>. You might need to open a port in the firewall.

Zigbee2mqtt is running on a systemd-nspawn container with archlinux:

# Serial settings
  # Location of CC2531 USB sniffer
  port: 'tcp://<openwrt-ip>:20108'
  # port: '/dev/ttyACM0'
  adapter: deconz

The ser2net connection also works for a Conbee II attached to an archlinux box with the following config:

connection: &con01
  accepter: tcp,20108
  connector: serialdev,/dev/ttyACM0,115200n81,nobreak,local
    kickolduser: true

i’m too stupid for this. The conbee II is running on a raspberry, ser2net is configured and running. But how can i connect the phoscon gateway on the second machine? What configuration is needed there?

It worked with zigbee2mqtt, not phoscon/deconz.

1 Like

funny, ser2net is not necessary for me. I can use the conbee II stick at the first machine with deconz on the second machine. Also, i use FHEM, i can use the stick with the second instance of FHEM, no problem.


1 Like

yes, with HUEBridge