Visual Zigbee Mesh Overview on Raspi?

I have a Conbee II plugged into a Raspi 4. The latter is not connected to a monitor, but I only can access it by SSH or web frontend.

Is there any way to get a graphical overview of my Zigbee Mesh to see which device talks with which other devices?

It does seem to me that I would have to plug the Conbee II into my windows PC and then run a windows deCONZ software on it to get this mesh view, right? I do not want to change my physical setup and still hope I can use some tool to get a graphical overview of the Zigbee mesh on my headless Raspi.

Use vnc to connect to the Gui of the pi :slight_smile:

I did a quick google, so that seems to be a viewer thing. Any hints on which software I would need to install on the Pi and my windows machine?
There seem to be many variants.

The most noob friendly solution would be appreciated.

Realvnc works natively with Raspbian

1 Like

but you already have installed Raspian OS with desktop support, don’t you? And the Pi starts with desktop, so when you connect via HDMI you see the desktop?

A vnc server is running on the pi already? check it with e.g.

sudo systemctl status vncserver-x11-serviced.service

On my client I use “realvnc-viewer” (aur/realvnc-vnc-viewer 7.11.1-1 (+57 1.55) (Installiert)


Thank you. I have started the server via raspi-config and now have GUI access.

Sadly now I am stuck in a situation where I do see the deCONZ app in the menu under developer, and I can click on it but nothing ever happens thereafter. No program UI shows up. No error.

This is even more surprising, because the iobroker and the deCONZ adapter in there does work.

Am I missing something?

you miss this GUI?

Try to use “Run” / “Ausführen” → deCONZ, on my side double click to deCONZ does also not open the GUI.


Deconz is perhaps already running but headless ? If you have access to phoscon, it mean deconz is running.

This is it.

Yes, exactly.

That could be, as I have access to phoscon.

But all this does not solve my request to find a way to see a graphical overview of the zigbee mesh.

How can I get to see a deCONZ UI?

try this in the “terminal”: sudo systemctl start deconz-gui


1 Like

You need to stop the headless one first.

sudo systemctl stop deconz

And after that you can run deconz using the menu if I m right.
If you want to have deconz in GUI mode by defaut

$ sudo systemctl disable deconz
$ sudo systemctl stop deconz
$ sudo systemctl enable deconz-gui
1 Like

Thanks. :+1:

Before I try this:
Since I only now and then might want to check the mesh visually, but continually want to make use of the iobroker adapter:

  1. Will the iobroker adapter (which seems to make use of the headless deconz) still work with headless deconz being stopped and deconz-gui running?
  2. Assuming your approach will stop the adapter working, how do I revert things back to working conditions after I have checked the GUI?

Currently I understand that I should run the GUI by

sudo systemctl stop deconz
sudo systemctl start deconz-gui

Would I afterwards just type

sudo systemctl stop deconz-gui
sudo systemctl start deconz

to revert it?

Exactly, complete requests are


$ sudo systemctl disable deconz-gui
$ sudo systemctl stop deconz-gui
$ sudo systemctl enable deconz


$ sudo systemctl disable deconz
$ sudo systemctl stop deconz
$ sudo systemctl enable deconz-gui

Those command, disable previous service, remove it and install the new one.

Thip apps are not able to see if the application run in desktop or headless mode, they just connect them to the API, using the same port and same url.
You can switch when you want, or stay the one you prefer.

Just a comment. I had an issue previously on an user with a Headless OS, because when he was launching the Deskstop mode, was a second instance of the OS in reality (and deconz was already running on the first one)
From my memory It can’t happen on Raspbian with the native VNC enabled with raspi-config, but it’s something to take care.