Unable to start deConz

I just installed the operating system in a new Raspberry Pi 3 and completed the process of importing the Phoscon public key, the beta version of APT repository for deCONZ, updated the APT package list and installed deCONZ. Although the deCONZ icon appeared after the installation, I cannot get deCONZ to open. Nothing happens when I press the icon.
Can someone please assist me in diagnosing the problem?
Thank you.

hello.

You are using the native vnc server on the pi ?
Can you try thoses command

sudo systemctl status deconz
sudo systemctl status deconz-gui

You need to have 1 working and 1 with error.

Yes, I am using native vnc server on the pi.
When I try ‚Äúsudo systemctl status deconz‚ÄĚ I get the following:

deconz.service - deCONZ: ZigBee gateway ‚Äď REST API
Loaded: loaded (/lib/systemd/system/deconz.service; disabled; vendor preset: enabled)
Active: inactive (dead)

And, when I try ‚Äúsudo systemctl status deconz-gui‚ÄĚ I get the following:

deconz-gui.service - deCONZ: ZigBee gateway ‚Äď GUI/REST API
Loaded: loaded (/lib/systemd/system/deconz-gui.service; disabled; vendor preset: enabled)
Active: inactive (dead)

Nov 28 09:02:37 raspberrypi systemd[1]: /lib/systemd/system/deconz-gui.service:11: Unknown key name ‚ÄėStartLimitIntervalSec‚Äô in section ‚ÄėService‚Äô, ignoring.
Nov 28 09:07:58 raspberrypi systemd[1]: /lib/systemd/system/deconz-gui.service:11: Unknown key name ‚ÄėStartLimitIntervalSec‚Äô in section ‚ÄėService‚Äô, ignoring.
Nov 28 09:09:20 raspberrypi systemd[1]: /lib/systemd/system/deconz-gui.service:11: Unknown key name ‚ÄėStartLimitIntervalSec‚Äô in section ‚ÄėService‚Äô, ignoring.
~

Have you updated the whole system ?
sudo apt-get update
sudo apt upgrade

It s the new raspbian version ? Bullseyes ?

If it s still nor working can try to run it in debug mode https://github.com/dresden-elektronik/deconz-rest-plugin/wiki/deCONZ-debug-flags

/usr/bin/deCONZ --dbg-info=2 --dbg-error=2

Hello,
Thanks again for the reply.
Yes, I updated the whole system. The operating system is Bullseye.
I updated/upgraded everything and it still will not work. I was able to get it working in debug mode as you suggested. But, long term I need to get to the heart of the problem.

Any other thoughts?
Thank you again!

I was able to get it working in debug mode

lol ? So it work on debug mode ? my objective was to have error displayed in log, not make it working in this mode.

So using command line can run the deconz desktop version without problem, but not using the desktop ?

Yes! In debug mode deConz opens and it appears to function properly. How do I view the error log?
Please advise.
Thank you!

The command line you have used display logs on the same console you have used the command.

But if it work, you will not see usefull information.

Your issue remember the one we have long time ago, when users use for exemple TightVNC instead of the integrated one. Using the icon in the menu was nor working.

But if the command line is working, why the service is not working ?

sudo systemctl disable deconz
sudo systemctl stop deconz
sudo systemctl enable deconz-gui
sudo systemctl start deconz-gui

Do nothing ?

Hi Smanar,
Thank you for the reply.
I disabled/stopped deconz and then enabled/started deconz-gui. Again, deconz opened up this way but I cannot get deconz to open up using the icon.

This feels like the shortcut (the icon) is broken. I am not sure hwo to fix this in Linux, for windows it would be right click and check the settings.

On, my side, with right click and property I have
/usr/bin/deCONZ-autostart.sh as command
Can be too a problem in the /usr/share/applications/deCONZ.desktop file ?

You can try the command line /usr/bin/deCONZ-autostart.sh

Hello Smanar,
Thank you for the message and information.
This is what I see when I select file properties for the deCONZ icon
image
Do you see /usr/bin/deCONZ-autostart.sh ?
Thank you.

I have it on the second tab, it seem grayed on your capture.
tmp7

Thank you Smanar, for the information.
This is what I get when I use enter the command ‚Äú/usr/bin/deCONZ-autostart.sh‚ÄĚ.
image
I then did the fix: sudo apt install -f but it did not seem to do anything.

What if you install wiringpi

Hi Mimiix,
Thank you for the suggestion. I loaded wiringpi and a few other missing files and now it seems to work okay. Thank you for your assistance!

I noticed that wiringpi and a few other files were missing. I instaled them and now it seems to work okay. Thank you for your assistance!

1 Like

Thank you Smamar. I installed a few missing files and now it seems to be working.
I appreciate you help!
Thank you.