Unable to open sensor details of Tuya _TZ3000_fllyghyj

Device: Tuya _TZ3000_fllyghyj
Platform: Rpi4 8gb with RaspBee II
Version: 2.16.01 / 4/21/2022

So I recently bought a Tuya temperature and humidity sensor. And it has one of the most interesting name “_TZ3000_fllyghyj”. I had some issues connecting it but after some googling and experimenting I figured it out and it now shows in deCONZ and in the Phoscon App.

When I opened the sensor page it showed the entry but did not have a icon. And when I tried to open the sensor details to change the device its name it did not do anything. All I got was a javascript error in the DevTools console.

Being a programmer myself I checked if I could fix it myself. So the problem is that the device does not have an icon. Because it did not have an icon the device details page failed to show.

So I ssh’ed into my rpi and edited the device-sensors.js and I changed

html = html.replace("{icon}", sg.clone().outerSVG());

into

if (sg !== null)
{
    html = html.replace("{icon}", sg.clone().outerSVG());
}

restarted deCONZ and refreshed the webapp and voilà (and there you have it) it worked. I can now rename the device and it show the device details (although limited).

So the technical side:
There is a dependency between the device icon and opening the device details. Why there is not an icon in the first place I have not investigated and I leave that up to you guys. Having such a dependency makes the webapp bridle (easy to break).

Ha nice, can be usefull for phoscon dev ^^.
And BTW about phoscon, there is some new features planned ? Long time we haven’t new about it.

Same issue here with the same device. I’m using the Home Assistant add-on v6.15.0 (deCONZ 2.17.1), which has the devices-sensors.js somewhat minified, so it’s difficult to edit.

@michaelblight what I did was take the minified javascript. And run it through a un-minifier online service like https://unminify.com and then patch that. And overwrite the un-minified javascript file. But before you blindly overwrite it, I advice you to create a backup of the file.

I am also having the issue you described. Is it possible for you to post a copy of the modified devices-sensors.js file? As mentioned, there is some room for error with the minified file etc. and I would like to ensure I don’t foul it up by trying to fix it!

I wonder if the developers are looking into patching this in an upcoming release; end users shouldn’t have to fiddle around with the web app source to use their sensors…