Unable to make a backup

I have synology DSM 7.x with docker deconz conbee 2. Everytime I do an update dsm or image conbee II the data seems to be old and I have to put everything from the last months back in the conbee II system. Even a stop and restart gives me headaches. I can make an backup from within the app but afer that I cannot download it. Well hope someone will help me with this.



If you believe it’s a bug in Phoscon, it needs to be posted in #phoscon:bug-reports . I have moved the topic there.

Additionally, it’s clearly stated that Phoscon bugs are done on the forums [Announcement] Closing User questions and feature requests on Github. Moving to forums! · Issue #5113 · dresden-elektronik/deconz-rest-plugin · GitHub.

1 Like

I had this a couple of times with Docker based installs of Phoscon and it was always down to file permissions, the user Phoscon was running as didn’t have write permission to that directory.

1 Like

This probably is whats going on here indeed. In DSM you need to set the volume mount (if i recall correctly).

1 Like

I normally fix it by looking at the UID & GID of the user Phoscon is running as in Dicker, then set at least the GID on the host to be the same and give write permissions to the group. I’m not sure if that’s the “right” way to do it, but it works.

1 Like

Stubbs. Yes I solved my problem. Did a duplicate of the container and created the folders again. Now it works. As it seemed in the folders root had somehow no write permissions, like you mentioned. Strange that the programmers did not put in code that explains this. So I believe it is a bug in the Deconz software. It would have made sense it I was getting a webpage that stated the the backup could not be writen to the disk. That would start me thinking why the db was of June. No w I was thinking where does it stores the changes I make? Well as it seems out, it did not, Well only in the cache. Thanks for helping out guys.

Leaves me with one small problem, what might have caused the write issue? Since I did nothing with the folders. There where updates from Conbee and DSM, somehow the updates must have caused this.

Perhaps a folder permission on DSM with the user you are using? Did you update DSM in the time between?

I found Docker on DSM very buggy, i’ve had similar issues like you before but with another container. That stopped me from using Docker on DSM and solely use VM’s in DSM.

1 Like

It could be, I can not see all the folders in WinSCP so there might be indeed an issue with the user. I have disabled the admin, since the user has admin rights. I will look in this. I’m thinking of running Home Assistant in VM, since with Docker bluetooth is a problem and add-on is impossible. But for now I’m happy that deconz can make backups. Gives me more room to experiments without loosing to many devices. Now have 89 in Conbee.

I used to run Home Assistant in DSM with the Addon. This caused me other issues and the lack of updating to specific versions as HA only sticks with stable versions.

What i did in the end: Have 2 VM’s. 1 for HA and 1 for deCONZ with Raspbian as OS.

Hello, I have the same problem on a Raspberry Pi 3 running Buster and deconz running in docker.
While I understand that this is related to write permissions, I don’t get which user I should grant permissions.
I did not specify a user when starting the deconz container, so I guess the default user “pi” is running the container?
User “pi” is owner of the folder “/opt/deconz” and all subfolders.

Any help appreciated!

I think root should have write access. I did a duplicate and made the folders with read and write. Had to add everything again, bt this time I could make a backup and the database was updated.

What exactly does the backup do? Which files does it contain?

I can manually backup config.ini, session.default and zll.db . Is that all?

Deconz use the application 7za.exe to make a backup file called raspbee_gateway_config_XXXX.dat.
This archive contain an archive called deCONZ.tar
This archive contain :

  • deCONZ.conf
  • zll.db
  • session.default

I have made a try 5mn ago and the file session.default is no more inside …

I cannot find the file deCONZ.conf. Do you know in which folder it can be found?

This one is made by deconz itself, it a ini file deconz-rest-plugin/backup.cpp at master · dresden-elektronik/deconz-rest-plugin · GitHub

So effectively, it’s a problem if there is right issues, can just make a backup of the complete folder with all config file and the zll.db file

On docker, just make a backup of the “persistent” folder, but I m agree not a solution, for exemple if you want to migrate from docker to a real OS.

I don’t know if it’s possible to use the phoscon backup/restore feature on docker OS ? If someone know the answer ?

1 Like

On docker, just make a backup of the “persistent” folder, but I m agree not a solution, for exemple if you want to migrate from docker to a real OS.

I just want to migrate to a new SD card, because I want to change from Rasperry OS Buster to the new version Raspberry OS Bullseye. So I just backup the folder…

For me it need to work, but IDK how are making dockers users.
I know docker are limited OS but this feature is important for me, strange there is nothing for that since the time …


Yes I can now, look if the zll.db has a new date when you make a change in the configuration. If not you proberly have a no write permissions. If your problem is the same as was mine, you will notice that zll.db does not change. Mine zll.db was from June after Synology got updated the backup was not working anymore.

As I mentioned before it looked like it was created but as soon as I hit Dowload I got an error that the fle was not there. Since I had no clue where the file had to go, I thought it was inside an other folder, so I tried finding the file, with no luck. Never accured to me it had something to do with me not having write permission (root or user) on the folder.

Strange Deconz or Conbee programmers have not put in a mechanisme to see if the folders are writable. Hopefully they will put this in so people are not on the wrong path.

But to go back to your question, yes you can. Also somewhere I have seen you can make a snapshot of docker images aswell. Not sure where I found that info, so perhaps somebody knows.

But it’s more than that, zll.db is not used only for backup, it’s the file used by deconz to save all informations, it mean you can’t add new devices for exemple.
You are sure not having a second one, in a not persistent folder ? because deconz can’t work without this file, for me it’s not normal.