Unable to create a backup

I’m having issues to create a backup file. The system (raspi 4, raspbian) was running quite a long time and after an update to openhab 4 the conbee II disconnected all the time.

I did a fresh install of openhab and also deconz. The firmware was also updated to the latest. The issue with the disconnects was probaby fixed with this.
Then I did a restore of the gateway using “backup” “laden” . Since a few items do not exist anymore I cleaned them up and would like to create another backup of the current config. That brings an error

I also tried the backup before importing the old settings, it also did not work. Logs are here: Logs
Any help is appreciated

This is not good

apsUseExtPanid is 0xDDDDDDDDDDDDDDDD but should be 0, start reconfiguration

The last backup you have restored have break something.

If you have acces to the GUI, you can reconfigure it yourself. Can use a PC to do that, you need to have something like

If the openHAB upgrade, have upgraded too the OS, can be the issue for disconnection After a sudo apt update && sudo apt full-upgrade and a reboot deconz no longer connects to the conbee 2 · Issue #6937 · dresden-elektronik/deconz-rest-plugin · GitHub

not sure. I tried that but after a reset I was not able to perform a backup, the log is here

thanks, I found that post and already had that fixed, before it was not showing as connected, vendor and product were missing

I imported an old backup and was able to clean it up (delete obsolete devices) and can now backup. I guesss the initial issue came with the update and the problem with the backup was a messup with the old settings.

Why is the backup file named rasbee_gateway_config ??
I do not have any RPi. My deConz/Phoscon runs in a container on a linux machine.

It’s the defaut name, same for me with a conbee too.

Good afternoon. I am new to this forum.
I have a conbee2, plugged into a jeedom RPI. The topic of this post seems to be related to an issue I am facing :

Lately I manually upgraded my Deconz version from an old version to the latest available 2.24.2 on my Jeedom installation.
In the same time I flashed my Conbee2 to the latest firmware (I did this under windows10), and suddenly all my devices stopped working. I could not pair any new, nor were the current working.

The key was detected OK by jeedom, and by phoscon (to which I can connect through IP_of_my_Jeedom_installation:8484), but all the rest was down.

Ater several tests, I manually uninstalled and reinstalled everything from my RPI with no luck.

Eventually I reinstalled AND downgraded the firmware (0x26780700, downgrade to 0x26720700) and all went fine. I could even add a ZBMINIL2 that I could not previously.

But while testing all this, and trying different backups and reloads, the db must have somehow been corrupted, and now I cannot create any backup.

I can restore an old backup, which I am not interested in, because all the current devices will have to be re-appaired.
Also, I have a lerlink switch that I cannot make work although it used to work fine before all this.

I have an installation that is working fine, but no way to dump any backup, which I find very unsafe.
I there a tool of some sort of a DFU I could follow to reppair my current zll.db please ?
Thank you very much from France.


the db must have somehow been corrupted, and now I cannot create any backup.

I can restore an old backup

Hello I m not sure to understand. You have a backup file that is not working and whant to use it. Or if you try the backup feature in phoscon you have an error message or it don’t work ?

For the second one, unlog and relog in Phoscon on the browser.

You have the issue on other browser ?

The backup is just a zip file, you can open and check it with winrar for exemple.
The better backup you have can’t be loaded in phoscon or the network stop working after ?

Sorry if I was unclear.
The current installation generates an error when trying to create a backup, whatever the browser.

Interesting fact : This installation works Ok with all my devices but a switch.

If I restore an old backup, i get an outdated list of devices (either that have been removed, or because new devices have been added since then). When this configuration is loaded, none of the devices work, but I can create a backup OK.
This kinda proves to me that the current db might be corrupted.

I could of course start with a db that allows me to create backup, but I would then have to re associate the whole list of devices, amongst them some devices like a zbminil2 that is now hidden in a wall, and I must admit it would be a lot of troubles to reappair.

Which is why I am wondering if there could be another approach to solve this backup issue.


I remember some issue like yours, but when it was not possible to create a backup, it’s was all the time. It don’t change after a database modification.

Do you have access to the GUI ? if yes it’s perhaps possible to see something usefull in logs.

BTW a backup file is just an archive (can be edited with winrar for exemple), for exemple a file called raspbee_gateway_config_2023-11-26.dat, inside you will found a file called deconz.tar, that is an archive too and inside again 2 files.

  • deconz.conf, this one can be edited with a text file, and you can compare working and not working one, inside you will found network setting, memorised on the gateway, you can edit them in deconz setting, wrong data here mean no devices at all.
  • zll.db this one can be edited with a SQL editor, it’s the device database, it’s just a backup of the exiting file in the deconz system folder (with same name from my memory).

But I don’t see what you can have inside to “break” the backup feature. It’s generaly problem on the OS like right access, or authentification problem on deconz (it’s for that I have asked to try on another browser or relog on Phoscon)


I m reading cde, and there is some check in the config that can invalidate a backup, it’s network setting check

        // simple checks to prevent invalid config export
        if (deviceType != deCONZ::Coordinator) { return false; }
        if (securityMode != 3) { return false; } // High - No master but TC link key
        if (nwkAddress != 0x0000) { return  false; }
        if (panId == 0) { return  false; }
        if (macAddress == 0) { return  false; }
        if (tcAddress == 0) { return  false; }
        if (curChannel < 11 || curChannel > 26) { return  false; }

So you can ave a correct database but a bad setting.
If you have the GUI, it will be possible to see it in setting page, else in the deconz.conf file of the not working backup.


Problem solved, thanks to you.
I opened the 2 backups I have : the one, outdated, that once loaded allows to create backups, and the one, once loaded that triggers an error when trying to create a backup.

I compared the 2 deconz.conf files, and at the very beggining of the file :

the “apsUseExtPanId”: was not “0x0” but the value that is on “extPanId” further in the file.
I edited the conf inside the archive, loaded the so called faulty backup, and surprise… I could create a new backup. (after restarting the services of course).
All my devices (appart from the @#!{@ switch) are working fine.
I just had to wake up some sensors, but no pairing needed.

I have no clue why this conf file suddenly went corrupted, but now I have a working solution.
This is excellent!

Have a nice weekend

So for me during your procedure, something have failed and have corrupted the apsUseExtPanId value, this error is visible on log or on the GUI in the setting panel Network lost and configuration restore does not help · dresden-elektronik/deconz-rest-plugin Wiki · GitHub but without the GUI …

What is your @#!{@ switch ? If you have the model ID/Manufacture name ? Remember there is some problem ATM on conbee 3.

Yes. Something went wrong for sure.
I am not using the GUI, as my conbee2 is plugged into a RPI under jeedom.
I either use the jeedom interface through the deconz plugin, or in the phoscon app.
My switch is a lerlink. It works on its own, just it would not pair, and now that I have a stable installation, I don’t feel like investigating further.
Have a nice weekend

I gave one last chance to my switch… it paired within 3 seconds.
The corruption was also preventing this tuya based device.
All is sorted out.

Ha my bad yes, a bad apsUseExtPanId prevent adding new device.
But for me you database was not corrupted, it was the network setting.

You gave me the right direction.