Unable to connect eWeLink smart plug SA-030

Hi there,
This is a continuation of my post(s) on github.

I’m using as Raspbee I on a raspberry pi 4, Firmware 26400500, phoscon app version 2.23.00.

I got a eWeLink smart Plug SA-030, which are an updated model of the SA-003 (as far as I can find out). I got mine from Aliexpress, but they are also sold on Amazon and eBay, usually under the brand “Woolley”. (SA-030 is the UK version, SA-028 and SA-029 are the same plug for EU and US)
I expected that the SA-030 would also work out of the box as the SA-003 does, but it seems I am unable to connect it to deconz/phoscon.
The problem is not that the device it not identified correctly, it’s that I can’t pair the plug to deconz/phoscon. It seems that whatever signals the plug is sending out during pairing are not (correctly) picked up.
I tried putting the Raspbee and the device directly next to each other, put the plug into pairing mode (according to the manual) and click on “add new plug” in the phoscon app. But the plug does not show up. I’ve not tried to do it via deconz itself, but I would not expect it to make a difference.
I can pair other devices, so the problem is not my setup in general.

I’m happy to provide images of the plug and the manual and follow any advice. I don’t have a Zigbee sniffer on hand to see if the plug is actually sending anything when in pairing mode.