TRVZB SONOFF problem via repeater


I use Conbee III + Zigbee2MQTT + HA. I have problems with pairing devices. When the devices are in range of the conbee III they pair well, but pairing is not possible if they are via a repeater.

I thought it was a feature, so I paired the devices with the Conbee III and then took them to the installation final location, where they normally worked via repeaters (easydevices like sockets or PIR sensors).

But now there is a problem with the SONOFF TRVZB v 1.1.1 radiator thermostat. I pair it with the Conbee III, but once I install it in a place out of reach of the Conbee III, it can’t be controlled anymore. Near Conbee III it works, but via repeater not. In system is TRVZB as online and linquality shows 190. Repater is on the way. I updated the Conbee III to the latest firmware 0x26500900. It didn’t help. How to make it work please? I use SONOFF sockets as repeaters, but I also tried this: 4.52€ 80% OFF|Easy Home App|zigbee Signal Repeater - Smart Home Automation Extender For Smart Life and not fix it.

When try change some settings, it says:

Publish ‘set’ ‘occupied_heating_setpoint’ to ‘0x0cae5ffffebb9d80’ failed: ‘Error: Write 0x0cae5ffffebb9d80/1 hvacThermostat({“occupiedHeatingSetpoint”:2750}, {“timeout”:10000,“disableResponse”:false,“disableRecovery”:false,“disableDefaultResponse”:true,“direction”:0,“srcEndpoint”:null,“reservedBits”:0,“manufacturerCode”:null,“transactionSequenceNumber”:null,“writeUndiv”:false}) failed (no response received (31))’

I will be glad for any help. Thanks Jan

1 Like

I have the same problem. I use sonoff repeaters and tuya plugs but it is only able to work if I pair directly with conbee. Most of the sensors I have are tuya pir and tuya door sensors. The problem appears with devices from multiple brands such as Heiman, Tuya and Aqara.