TRADFRI Button does not work properly

Hello Phoscon-Team,

Today I took the task to bring my Homebridge/Phoscon/Conbee-II combo to Raspbian bullseye (latest Homebridge-Raspbian Distribution).
Within this task, I upgraded my Conbee-II Firmware to 26780700 and the Phoscon-App to 2.24.1 - so far so good.
I have now the issue, that my Tradfri Switches aren’t working properly. As soon I connect them, they will change the status of all connected lights at once, but within Phoscon only - no light is actually turned on or off.
I’m able to set the switch up though directly in Phoscon with the “Switch Editor”, but nothing here is handed through to Homebridge/Apple Home anymore. Setup in the Apple Home App will have no effect.
And even if the setup is done within the switch editor, in the background the status of all connected lights will change, but then the configured ones will really turn on.

I verfied this with another fresh install → Same behavior. Also tested a brand new Tradfri Switch → Same behavior.
My config:
RaspberryPI 2 Model B Rev. 1.1 with Raspbian Bullseye
Phoscon 2.24.1
ConBee II Firmware 26780700

Same issue like HERE

Thanks for your support!

You can check with ie YARC as in the linked post and inspect the /groups URL.
All remotes/switches are listed there. That is what Homebridge is seeing as well …
Will narrow the problem down.
Direct associations and Switch editor setup should not exclude anything going to the REST interface.


Thanks for your reply, this does not solve my Problem, though. The rest-API works in the meantime and I can set up the switch, but the ghost-switching in the Phoscon UI persists.

Anyone who solved this Problem yet?

Thanks and a wonderful evening!

I have the same problems. I tried all the solutions i could find. With this solution the connection to openHAB is unavailable, the error with the switch were solved, but i need the connection to openHAB so switched back and can not use the button.