Strange problem with Aqara Multi Sensor WSDCGQ11LM

1 or 2 years ago I bought 8 multi sensors from Aqara (WSDCGQ11LM).
They all work fine in my installation.

  • hassio:
    • Home Assistant Core 2022.6.7
    • Home Assistant Supervisor 2022.08.5
    • Home Assistant OS 8.5
  • deconz addon 6.15.0
  • conbee II:
    • 2.17.01 / 7/1/2022
    • 26720700

I recently bought 4 more, but they give me different result from the working ones.
I can pair them, but it seems that the sensors visible for Home Assistant are not correct.

Here are the sensors in Phoscon:

As you can see, aqara_multi_sensor_7 and 8 are showed in one way, and the new one aqara_multi_sensor_10 has a different order.
I don’t know if it has something to do with the problem I have.

In deconz I can see the working sensors different from the new one too:

In Home Assistant the failing sensor is showed like this:

FYI the working one is showed correctly:

What is strange is that they have the same firmware version…

I succesfully paired 2 new sensors, but they both give me the same problem.

Right now I cannot access to the REST API, but if needed I can do it later.

Thanks in advance for the help.

Hm they should work like a charm.
Have you pressed “read” in the basic cluster at the new devices?

Yes I did it.

What seems strange in deCONZ is that the working device is showing like this:

and the failing one:

In Home Assistant it’s still showing badly:
image

Probably the new device is not exactly the WSDCGQ11LM. On the device itself, the identifier is written in very small letters. That’s why there is different behavior regarding sorting.

Can you please check the API output of an old and a new sensor. You can find this in the Phoscon app under Menu > Help > API Information.

On the sticker it shows the same model number :confused:

Here is the API output for both sensors:

good one:

"100": {
    "config": {
        "battery": 100,
        "offset": 0,
        "on": true,
        "reachable": true
    },
    "ep": 1,
    "etag": "6be442adca2bece5d304c5229c93bdc3",
    "lastannounced": null,
    "lastseen": "2022-09-19T06:30Z",
    "manufacturername": "LUMI",
    "modelid": "lumi.weather",
    "name": "aqara_multi_sensor_7",
    "state": {
        "lastupdated": "2022-09-19T05:55:38.334",
        "temperature": 2484
    },
    "swversion": "20191205",
    "type": "ZHATemperature",
    "uniqueid": "00:15:8d:00:07:e4:c1:ed-01-0402"
},
"101": {
    "config": {
        "battery": 100,
        "offset": 0,
        "on": true,
        "reachable": true
    },
    "ep": 1,
    "etag": "e09a16c05dd031a90a2032a89dc1f240",
    "lastannounced": null,
    "lastseen": "2022-09-19T06:30Z",
    "manufacturername": "LUMI",
    "modelid": "lumi.weather",
    "name": "aqara_multi_sensor_7",
    "state": {
        "humidity": 6061,
        "lastupdated": "2022-09-19T05:55:38.356"
    },
    "swversion": "20191205",
    "type": "ZHAHumidity",
    "uniqueid": "00:15:8d:00:07:e4:c1:ed-01-0405"
},
"102": {
    "config": {
        "battery": 100,
        "offset": 0,
        "on": true,
        "reachable": true
    },
    "ep": 1,
    "etag": "f93526221b108d55e34b66f4d0586b25",
    "lastannounced": null,
    "lastseen": "2022-09-19T06:30Z",
    "manufacturername": "LUMI",
    "modelid": "lumi.weather",
    "name": "aqara_multi_sensor_7",
    "state": {
        "lastupdated": "2022-09-19T05:55:38.369",
        "pressure": 1014
    },
    "swversion": "20191205",
    "type": "ZHAPressure",
    "uniqueid": "00:15:8d:00:07:e4:c1:ed-01-0403"
},

bad one:

"106": {
    "config": {
        "battery": 100,
        "offset": 0,
        "on": true,
        "reachable": true
    },
    "ep": 1,
    "etag": "b83fd97cc7a753d8a9bf16ae15c94750",
    "lastannounced": null,
    "lastseen": "2022-09-19T07:03Z",
    "manufacturername": "LUMI",
    "modelid": "lumi.weather",
    "name": "aqara_multi_sensor_10",
    "state": {
        "humidity": 6469,
        "lastupdated": "2022-09-19T07:04:03.124"
    },
    "swversion": "20191205",
    "type": "ZHAHumidity",
    "uniqueid": "00:15:8d:00:08:30:44:50-01-0405"
},
"107": {
    "config": {
        "battery": 100,
        "offset": 0,
        "on": true,
        "reachable": true
    },
    "ep": 1,
    "etag": "6aa203ba6d0f0c624344616b0cad7576",
    "lastannounced": null,
    "lastseen": "2022-09-19T07:03Z",
    "manufacturername": "LUMI",
    "modelid": "lumi.weather",
    "name": "aqara_multi_sensor_10",
    "state": {
        "lastupdated": "2022-09-19T07:04:03.107",
        "temperature": 2499
    },
    "swversion": "20191205",
    "type": "ZHATemperature",
    "uniqueid": "00:15:8d:00:08:30:44:50-01-0402"
},
"108": {
    "config": {
        "battery": 100,
        "offset": 0,
        "on": true,
        "reachable": true
    },
    "ep": 1,
    "etag": "697b7d5f138676fd0b7212ebb20a8fa8",
    "lastannounced": null,
    "lastseen": "2022-09-19T07:03Z",
    "manufacturername": "LUMI",
    "modelid": "lumi.weather",
    "name": "aqara_multi_sensor_10",
    "state": {
        "lastupdated": "2022-09-19T07:04:03.139",
        "pressure": 1013
    },
    "swversion": "20191205",
    "type": "ZHAPressure",
    "uniqueid": "00:15:8d:00:08:30:44:50-01-0403"
}

They seem to be similar, except the order they were created.
Is there any reset I can do in deconz/phoscon/home assistant, or physically to the device?
I tried to remove it from phoscon, then pair it again, but same result in home assistant…

Xiaomi never does this in my experience.

The API information of both devices look the same. So Home Assistant should be able to do the same thing with them. Maybe it’s only needed to restart the add on. Or there is no compatibility from HA for the new model.

I reset the device, I removed it totally from HA.
But still the same. I can pair it in Phoscon, the order of the sensors is different, and in deconz the device is showed differently from my old devices, that made me think the problem was from deconz, but maybe it’s on HA side…
As you can see in the previous screenshots, Basic info is a bit different, and Unknown appears in the new sensor, whereas it is not present in the old ones.
“Application version” also is different and “Xiaomi specific”.

I will try to pair a new aqara door sensor I have, to see if it’s more a problem of my installation than deconz or phoscon.

image
My new door sensor doesn’t work neither. Something may be wrong with my installation, and I don’t really know what I can do to solve my problem.

In deconz I can observe the same differences as with the temperature sensor:
_1 is an old one working, _5 is the new one not working
image

Downloading the diagnostic file from HA, I see a difference in the json file:

The new device sensors doesn’t appear in the “deconz_ids” json node. Maybe I should write in the HA forum.

Deconz API is doing fine here. Devices and items have been created, data is updated. I’m afraid we cannot help further in this case, as the root cause of your experienced issue is not the API :slightly_smiling_face:

It’s strange to me that deconz shows the devices differently.
But if Home Assistant only uses the json from phoscon (is this correct?) you’re right and I may ask directly in the deconz integration forum/github.

Thanks for all the help and your time :slight_smile:

Can you share the diagnostics file

Here it is:
Note that in deconz_ids, the 2 new sensors (aqara_multi_sensor_10 and aqara_door_sensor_5) are not present.

Yes something is weird, would you mind sharing a full debug log from home assistant? You can share it in PM to me

What log do you want? the full .log?

Debug enabled from homeassistant yeah

Hi,
I sent you the log in PM.
I’m new to the forum, I don’t know if I did it well and you received it.

Sorry, I’ve been busy so I’ve kept your messages unread to not forget about them