Starting deCONZ without GUI on Windows

So I’m trying to startup deCONZ in headless mode (ie without GUI)

Looking at it gives me the information

platform minimal
In case you want to start headless, use this parameter.
Example: /usr/bin/deCONZ --platform minimal --auto-connect=1

The example is for unix, so adapting it for Windows 10 machine I created a shortcut to the “deCONZ.exe” executable and added parameter to the Target line.

“C:\More Programs\deCONZ\bin\deCONZ.exe” --platform minimal --auto-connect=1

When click my shortcut I get a deCONZ error dialog with the message
“This application failed to start because no Qt platform plugin could be initalized. Reinstalling the applications may fix this problem. Available platform plugins are: windows.”

The error message also appears if I use an alternate Target Line
“C:\More Programs\deCONZ\bin\deCONZ.exe” -platform minimal -auto-connect=1

Any ideas on what might be wrong or other suggestions to run deCONZ headless on Windows ?

I can just add a little more info

  • ‘deCONZ with GUI’ operates ok on my windows machine,
  • the program’s bin folder contains seven 7 dll’s starting Qt5***** including Qt5Core.dll and Qt5Gui.dll.
  • this bin folder is where the shortcut Starts In.

“Example: /usr/bin/deCONZ --platform minimal --auto-connect=1”

seems like you took an “-” to much and thats why it doesn´t work.
-platform minimal --auto-connect=1

Replying to Guatama:

I had already tried
“C:\More Programs\deCONZ\bin\deCONZ.exe” -platform minimal -auto-connect=1
but it didn’t work (gave same error)

“C:\More Programs\deCONZ\bin\deCONZ.exe” -platform minimal --auto-connect=1
as you suggested likewise gave the same error message

Using “C:\More Programs\deCONZ\bin\deCONZ.exe” --auto-connect=1
works fine but of course it’s open deCONZ with the GUI

the problem occurs when I try to use -platform minimal or --platform minimal

“C:\More Programs\deCONZ\bin\deCONZ.exe” --platform anyoldtext --auto-connect=1
produces the 'no Qt platform error
but using
“C:\More Programs\deCONZ\bin\deCONZ.exe” --anyoldparam anyoldtext --auto-connect=1
doesn’t give the no Qt error and opens deCONZ with GUI ok
So deCONZ (on Windows) doesn’t like --platform followed by a space

Working with this I tried some other variations that I thought might possibly work
“C:\More Programs\deCONZ\bin\deCONZ.exe” --platform=minimal --auto-connect=1
“C:\More Programs\deCONZ\bin\deCONZ.exe” --platform-minimal=1 --auto-connect=1
“C:\More Programs\deCONZ\bin\deCONZ.exe” --minimal --auto-connect=1
“C:\More Programs\deCONZ\bin\deCONZ.exe” --minimal=1 --auto-connect=1
These don’t produce the no Qt platform plugin error, but they all open deCONZ with the GUI
(ie still not headless).

But the headless mode is possible on windows ?

I was unclear Smanar if you’re
a) making a statement “the headless mode is possible on windows”
or b) questioning whether the headless mode is actually possible at all on windows

So far I haven’t been able to get headless mode to work on Windows. Does anyone have a foolproof method of successfully starting deCONZ in headless mode on a Windows machine ?

In my mind it’s not possible on windows, but from my memory there is an issue somewhere to start it minimised.

I have consulted with Manup.
The parameter was first wrong ( --platform minimal instead of -platform minimal), this was corrected directly.
The problem is actually the missing Qt platform plugin. This will be integrated in the next version of us.