[SOLVED] Philips Hue Dimmer Switch added in Phoscon, visible, but not available in Switch Editor


I bought a Conbee, and I just added two Philips Hue bulbs to Phoscon : everything works fine.
Then I tried adding a Philips Hue Dimmer switch. So, I go to add a switch, then press the setup button for 10s… and first thing weird : the switch is detected, appear in the UI, but the wizard still doesn’t activate the “Ready” button. I need to close the wizard. But here is the switch added:

Another screenshot of the detail page for this switch:
https:// i.imgur. com/M18aUvp.png (sorry, I needed to add space cause I’m limited to two links per post)

But if I go to a group, then to switch editor, to control this group with a switch, and I click on “Link Switch”, I see no swith in the list of available switches. Here is a screenshot:

What is the problem, here ? What can I do to use this switch (it’s an official Philips Hue Dimmer Switch) to control my lights ?

After some digging of reddit issues, I found this : https://github.com/dresden-elektronik/phoscon-app-beta/issues/367

I managed, with the beta version of Phoscon, to make it work. There is just one thing that doesn’t seem to work : I bound the toggle warm/cool on the bottom button, and it doesn’t do anything. The dimming up, dimming down, and on/off, all work. But I guess it has nothing to do with the switch itself - the switch triggers all the events it should correctly :slight_smile:

Moving from Deconz support to Phoscon.

Also, is this your issue? New Hue Dimm Switch are not Possible to ad to a Group - #5 by Mimiix

Well the thread you link doesn’t give a lot of information so I’m not certain what the person is talking about exactly. It sounds similar tho, yes.
But my issue is the one talked about in the GitHub link I provided in the second post. So it has been explained in detail, and is still present in the stable version of Phoscon.

I’ve basically solved the issue by using the beta version of Phoscon (I didn’t realize first I could directly use it with the gateway I have installed on my Home Assistant setup, I thought I’d have to somehow install the beta Phoscon on Home Assistant… I’m new to this whole ecosystem, I literally installed it last week end).

So I guess issue can now be marked as solved.

The solution was : use the BETA version of Phoscon, in which it’s possible to add and use the new 2021 version of Philips Hue Dimmer Switch (RWL022).


Than I just can’t say anything else but Welcome :slight_smile: