SNZB-02 Device Unreachable

I had to change my setup from a raspberry to a ubuntu server because the sd card corrupted. I installed deconz through docker and set everything up. I had some issues so I did a factory reset and now the SNZB-02 sensor shows as unavailable the whole time. I updated my firmware to the newest and it didn’t help. I resetted the device and moved it directly to the conbee 2, still nothing. I tried the “Xiaomi: Lost devices or functional issues” debug steps, but to no avail. Here are the logs I gathered

I bought a second sensor to try out if that one works, but the same issue was present. The old sensor blinks red when I try to read the node description, the new one (connected through several osram smart plugs) blinks blue.

To add to this:

LQI values of most Routers are not up to par >

Indeed, it seems that the coordinator doesn’t have any strong connection to routers.
Do you have the ConBee connected via USB extension cable?

Yes, its connected with a 2 meters long extension cable and lies propped up nowhere near any other electronics.

Ok that’s good. The next thing I’d check is that the Zigbee doesn’t have interference with other 2.4 GHz devices like WiFi and Bluetooth.
You can use a free WiFi scanner app on your phone, which shows networks nearby and which 2.4 GHz channels they occupy (note that Zigbee and WiFi channels are very different).

Usually Zigbee channels 11, 15, 20, 25 have the least interference.
Your Zigbee network is currently on channel 15, so it would be good to have WiFi channels 3–5 not too occupied.

Since the LQI values between your routers are so low, this can be either too long distance between them, or that they have a difficult time to reach each other. The distance between two routers, like lights and plugs, should only be 5–7 meters in clear line of sight to form a good connection.

I don’t think there is a much better channel around my house sadly. The things is, I have 3 sensor all not working, every one from sonoff. One of the sensors, Humidity 24, isn’t working either and it is right next to the conbee and has a perfect connection

Hm hard to tell, channel 15 is already on the best place according to your WiFi screenshot it should be between WiFi channels 3–4. Here is a better channel diagram:

Is there any other thing which might occupy the channel, like Bluetooth streaming?

No, as far as I know there is no bluetooth device nearby. It did already work once, but then just stopped

@manup could it be due to device firmware?

I don’t think so, at least from the network map the overall connections are pretty weak, from coordinator but also between routers. Therefore my guess that there is either something up in the air or the distance between routers is too large.

The Philips sensor and the Humidity 24 should work though for the latter it could be more a setup thing, like missing bindings/reporting configuration.

Okay, but how would I fix those bindings? I tried reading the node/simple descriptor and resetting often but that did nothing.

In Discord, there’s a entry on it and also in the deCONZ manual: