Silvercrest Smart Button paired and showing up in HA, but no button presses recognized


I’ve got the deCONZ integration installed in Home Assistant Operating System on a Raspberry Pi. Using Phoscon, I was able to pair a Silvercrest Smart Button. However, I want to be able to use button press events in Home Assistant and that doesn’t seem possible at the moment.

It doesn’t help that I’m not that familiar with HA, and therefore don’t know how I should expect the button to show up, but it looks like it’s only showing the button’s battery’s status. I can actually create an automation using one of these two triggers that are provided in HA’s Automation GUI:
“” button pressed
“” button double clicked

…but the Actions associated with the Automation are not carried out when press the button.

When listening for deconz_event on HA’s event bus, nothing shows up when I press the button.

I’ve tried associating the switch with a light in Phoscon’s user interface. After this, when I press the button, the icon of the light briefly lights up in Phoscon, then turns off again. The actual physical light remains turned off.

Debugging: I’m not sure how to use a native VNC application to be able to copy the debugging log, since copy-pasting doesn’t work from the HA integration. I’m not sure if I could even enable the VNC server, since the Raspberry Pi isn’t running Linux.

My deCONZ version is 2.19.3

I would be very glad to receive tips! Thank you.


Hi Danny,

I can confirm to have the exact same issue that you described. However I haven’t found a solution yet. I have not seen this behaviour before with other switches (IKEA, Aqara).
The button will show up as a device in HA and I can use single and double press as triggers in automations. However, as you already described, the trigger event doesn’t seem to be recognized by HA. Even in the VNC view under the deCONZ app I can see that the button is part of the zigbee network and it will show activity when I push the button.
May I ask which FW version your Gateway has? I assume you use the Conbee II as well? Mine has 26660700 and shows an available update to 26720700. Maybe an update would help here, however I’m a little hesitant because other stuff might not work any more after an update…

Any feedback is welcome! Thanks.


edit: I found the solution: Just hit the button 3 times and it will switch to another mode. Then all works fine… :slight_smile:

Thank you, that was it!