SilverCrest (Lidl) motion sensor not visible in Phoscon app

I found this issue at SilverCrest (Lidl) motion sensor not visible in Phoscon app · Issue #409 · dresden-elektronik/phoscon-app-beta · GitHub. I have nearly the same problem:
deconz was running for a long time on a qnap within docker. There - stil on qnap I’ve added several SilverCrest (Lidl) motion sensors - immediately when the firmware upgrade was available. Everything works fine. Unfortunable the qnap crashed suddenly. :flushed:

Therefore I decided to switch to a raspee. I’ve istalled your sd card image without any problem and restored the config from a raspbee_gateway_config_2020-mm-dd.dat file, about 6 month old - still without any problem.

Serveral switches lights and sensors appeared and started working. But not the SilverCrest sensors, I’ve installed before on the qnap and got back from the restore.
I could see them in the app but their states didn’t change anymore!

When I tried to add a new one, the message said the sensor was found and can be used. But in the app they did not appear. (I tried 3 different new sensors) . The cobee II was the same, it’s firmware was the same, even the usb cable was he same!

I ran a update of the app to the newest alpha, without an effort. Then the same with the firmware, then the app to the newest beta and at least the firmware to the newest beta. Nothing helped.
On the link quality diagramm the new sensors are visible as presence, but not in the app.

On github the user was asked for different system facts, so I paste my answers here:

*host system (Raspberry Pi 3B+ / 4B / PC / NAS):*
  • Answer: Raspberry Pi 3 Model B Plus Rev 1.3*
  • execution method (Raspbian / Ubuntu / Home Assistant deCONZ add-on / Marthoc Docker container / Windows / Virtual Machine):*
  • Answer: “Raspbian GNU/Linux 10 (buster)”*
  • firmware version (format 26xxyy00):*
  • Answer: 266B0700*
  • deCONZ Version (Format 2.xx.yy):*
  • Answer: 2.12.05 / 12.7.2021*
  • device (ConBee I / ConBee II / RaspBee I / RaspBee II):*
  • Answer: Conbee II*
  • Is the ConBee I / II connected to a USB 2.0 or USB 3.0 (blue) socket? - only relevant for ConBee I/II:*
  • Answer: USB 2.0*
  • Is a USB extension used? (yes / no) - only relevant for ConBee I/II:*
  • Answer: yes. 2m. Stable running since a year *
  • Are other USB or serial devices connected to the host system? (yes / no) - If yes: which ones?):*
  • Answer: no. only Conbee II Stick*
  • If Raspberry Pi: which power supply is used? (original / manufacturer+model) Specify volts and amps: (e.g. 5.0V, 1.0A):*
  • Answer: original. Stable running since a year*
  • if Raspberry Pi: On which image base is the system set up?: (Phoscon / Raspbian / Raspberry Pi OS / Home Assistant …):*
  • Answer: Phoscon. Linux phoscon 5.10.52-v7+ #1441 SMP Tue Aug 3 18:10:09 BST 2021 armv7l*
  • If Raspberry Pi: Which way was deCONZ installed? (APT repository / dpkg / via a plug-in).*
  • Answer: SD-Card image > balena etcher. Running stable *

ls /dev/ttyA*
/dev/ttyACM0 /dev/ttyAMA0

pi@phoscon:~ $ df
Dateisystem 1K-Blöcke Benutzt Verfügbar Verw% Eingehängt auf
/dev/root 30364012 4358292 24718848 15% /
devtmpfs 439400 0 439400 0% /dev
tmpfs 472680 4668 468012 1% /dev/shm
tmpfs 472680 47840 424840 11% /run
tmpfs 5120 8 5112 1% /run/lock
tmpfs 472680 0 472680 0% /sys/fs/cgroup
/dev/mmcblk0p1 258095 49173 208922 20% /boot
tmpfs 94536 8 94528 1% /run/user/1000

pi@phoscon:~ $ uname -a
Linux phoscon 5.10.52-v7+ #1441 SMP Tue Aug 3 18:10:09 BST 2021 armv7l GNU/Linux

pi@phoscon:~ $ vcgencmd version
Aug 3 2021 18:17:07
Copyright (c) 2012 Broadcom
version 40787ee5905644f639a2a0f6e00ae12e517a2211 (clean) (release) (start)

Best regards, Ludwig.

Hello, have you take a look direclty in the API ?
Using in help / api information

Smanar, thank you. I’ve had a look there, before. But I don’t know what that can help. The sensors are recognized but they don’t appear in the app. This corresponds to the fact that when the sensors are detected, it is reported that they are ready. Yes, they are - but not listed. Therefore they can’t be used within phoscon app.
regards, Ludwig

There is a post about that somewhere, it s a requested feature ^^
But yes, phoscon don’t display all devices by defaut

This one Feature request: Show all devices in Phoscon even if unsupported - #5 by Mimiix

Mimiix: Thank you. There you wrote:

> Currently users need to get Devices supported in Phoscon. This confuses users as sometimes the API supports it but Phoscon does not (yet).

But in the case of those lidl / silver crest motion sensors it seems to be another promblem - they are not visible yet but they are not visible anymore! I had them shown and used in the app while it was running on my qnap within the marthoc container.

When I switched to a raspbee, they where still visible after importing the backup (made before from the container). But new sensors came not visible. It seems, they where supported but not anymore.
Best regards Ludwig.

Just an hunch: is there a language difference between the systems? If the new system(where the devices are missing) is in English, can you switch it to German and see then?

Hi Mimiix
sorry - I was absent a few days.
Now I’ve checked the languages on the raspbee (image from and on the docker image marthoc/deconz.

pi@phoscon:~ $ locale

2021-08-03 22:54:23
Docker 20.10.3 on linux, amd64
root@QNAP:/# locale

phoscon on Marthoc docker image

Meanwhile I was able to reanimate the docker installation. there those Silvercrest sensors are visible. Of course offline, because the conbee stick is now in the raspbee. (But i want to stay on the raspberry because the phoscon app is faster on it :grinning: )

Btw: last night I have made an update to version 2.12.06 and firmware 26700700, but the situation is unchanged.
regards, Michael

I have the same issue, first I thought the sensor is not working, after I had a look into the REST API there it was…
Funny is that you can copy the unique id but just the part that looks like a mac address and use that in the URL.
I just opened a shown sensor and changed that ID in the URL and I got a page for the sensor missing in the list where I can delete and rename it.
So it seems just the listing has a problem…


With version 2.13.0 the SilverCrest sensor should be visible.
Please try this and give us feedback, thx in advance.

I already tried 2.13.0 a few days ago because of the “strange” behavior of clearing presence state of Lidl SilverCrest motion sensors.
2.13.0 solved that problem and also the sensors are now visible in the list so all good with 2.13.0!

Hmm… I do not quite get it. I have deConz Integration in Home Assistant runng in Raspberry Pi 4, and I am using Combee II USB stick in it. When I open DeConz → Phoscon → Gateway, I see version 2.12.06/ 19/08/2021, firmware 26720700. It also says that the version is up to date

It was not long ago I downloaded it, cannot exactly remember from where, and flashed it with Win10/ Balena. (EDIT: Sorry, I did not remember correctly, it was not Balena, it was GCFFlasher…)

I cannot find this 2.13.0 firmware anywhere, where should it be located?

2.13 is still in beta. If you use the integration in the Supervisor, you have to wait until someone updates the repo.
If you use deconz standalone you can manually update by switching to the beta repo described here: ConBee Installation

Are we talking about the same thing now? You are meaning thge Phoscon app now, not the stick firmware?

(I sort of thought the 2.12.6, what it shows now also belongs to the firmware version naming…)

If so, I probably need to wait for the repo to update (EDIT: Any idea when that might be?)

You have to wait for the Phoscon/deCONZ update. Firmware is not that important here.

On they say expected sometime in November.

OK, that’s good news then. Thak You very much!

1 Like