Raspberry B3 - Domoticz - Conbee2

Raspberry is uptodate, Domoticz is uptodate (and working ok for 3 years on this hardware), Conbee/Deconz uptodate.
Installed with water sensors and was working fine until a power reset.
Deconz comes up without problem and connects to sensors.

Domoticz not seeing Deconz…

ps ax | grep deCONZ shows this which I think is ok
438 ? Ssl 0:26 /usr/bin/deCONZ -platform minimal --http-port=80
478 ? Ss 0:03 /bin/bash /usr/bin/deCONZ-WIFI2.sh
526 ? Ss 0:01 /bin/bash /usr/bin/deCONZ-update2.sh
2522 ? Ssl 0:39 /usr/bin/deCONZ --http-port=80
12174 pts/0 S+ 0:00 grep --color=auto deCONZ

sudo systemctl status deconz shows this which I think is ok

? deconz.service - deCONZ: ZigBee gateway – REST API
Loaded: loaded (/lib/systemd/system/deconz.service; enabled; vendor preset: enabled)
Active: active (running) since Tue 2023-10-24 05:36:54 CEST; 14min ago
Main PID: 438 (deCONZ)
Tasks: 4 (limit: 2059)
CGroup: /system.slice/deconz.service
±438 /usr/bin/deCONZ -platform minimal --http-port=80

Oct 24 05:36:54 raspberrypi systemd[1]: Started deCONZ: ZigBee gateway – REST API.
Oct 24 05:36:56 raspberrypi deCONZ[438]: QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to ‘/tmp/runtime-pi’
Oct 24 05:36:58 raspberrypi deCONZ[438]: libpng warning: iCCP: known incorrect sRGB profile
Oct 24 05:37:04 raspberrypi deCONZ[438]: This plugin does not support propagateSizeHints()
Oct 24 05:37:04 raspberrypi deCONZ[438]: This plugin does not support propagateSizeHints()

Domoticz log shows this
2023-10-24 06:06:18.008 deconz-bridge: Pushing ‘onHeartbeatCallback’ on to queue
2023-10-24 06:06:18.058 deconz-bridge: Processing ‘onHeartbeatCallback’ message
2023-10-24 06:06:18.059 deconz-bridge: Acquiring GIL for ‘onHeartbeatCallback’
2023-10-24 06:06:18.059 deconz-bridge: Calling message handler ‘onHeartbeat’ on ‘module’ type object.
2023-10-24 06:06:18.059 deconz-bridge: onHeartbeat called
2023-10-24 06:06:18.059 deconz-bridge: ### Initialisation > config
2023-10-24 06:06:18.059 deconz-bridge: ### Request config
2023-10-24 06:06:18.060 deconz-bridge: Send Command /api/98CE42231B/config/ with None (0 in buffer)
2023-10-24 06:06:18.060 deconz-bridge: Making Request: with params None
2023-10-24 06:06:18.087 deconz-bridge: Request Return: {“UTC”:“2023-10-24T04:06:18”,“apiversion”:“1.16.0”,“backup”:{“errorcode”:0,“status”:“idle”},“bridgeid”:“00212EFFFF085C06”,“datastoreversion”:“93”,“dhcp”:true,“disablePermitJoinAutoOff”:false,“factorynew”:false,“fwversion”:“0x00000000”,“gateway”:“”,“internetservices”:{“internet”:“connected”,“remoteaccess”:“disconnected”,“swupdate”:“connected”,“time”:“connected”},“ipaddress”:“”,“lightlastseeninterval”:60,“linkbutton”:false,“localtime”:“2023-10-24T06:06:18”,“mac”:“8e:42:b7:fa:4b:11”,“modelid”:“deCONZ”,“name”:“Phoscon-GW”,“netmask”:“”,“networkopenduration”:180,“panid”:0,“portalconnection”:“disconnected”,“portalservices”:false,“portalstate”:{“communication”:“disconnected”,“incoming”:false,“outgoing”:false,“signedon”:false},“proxyaddress”:“none”,“proxyport”:0,“replacesbridgeid”:null,“rfconnected”:false,“starterkitid”:“”,“swupdate”:{“checkforupdate”:false,“devicetypes”:{“bridge”:false,“lights”:,“sensors”:},“notify”:false,“text”:“”,“updatestate”:0,“url”:“”},“swupdate2”:{“autoinstall”:{“on”:false,“updatetime”:“”},“bridge”:{“lastinstall”:“2023-10-01T12:32:06”,“state”:“noupdates”},“checkforupdate”:false,“lastchange”:“”,“state”:“noupdates”},“swversion”:“2.23.2”,“timeformat”:“12h”,“timezone”:“Europe/Berlin”,“uuid”:“d188cbe8-7ce6-4a55-af05-cceea41ef477”,“websocketnotifyall”:true,“websocketport”:8088,“whitelist”:{“235159C37F”:{“create date”:“2023-02-13T20:50:47”,“last use date”:“2023-02-13T20:50:56”,“name”:“Phoscon#B1280x884”},“8FE2467DF1”:{“create date”:“2023-02-13T20:50:16”,“last use date”:“2023-02-13T20:50:47”,“name”:“Phoscon#B1280x884”},“97FB86ACCB”:{“create date”:“2023-10-20T19:58:23”,“last use date”:“2023-10-20T19:58:23”,“name”:“Domoticz”},“98CE42231B”:{“create date”:“2023-10-20T20:28:40”,“last use date”:“2023-10-24T04:06:18”,“name”:“Domoticz”},“B40B9396EC”:{“create date”:“2023-10-20T20:43:16”,“last use date”:“2023-10-20T21:27:13”,“name”:“Phoscon#B1600x1060”},“D00F32D077”:{“create date”:“2023-10-20T20:17:12”,“last use date”:“2023-10-20T20:29:37”,“name”:“Phoscon#B1600x1060”},“FF5F5E1509”:{“create date”:“2023-10-22T09:46:24”,“last use date”:“2023-10-24T03:30:31”,“name”:“Phoscon#B1600x1060”}},“zigbeechannel”:0}
2023-10-24 06:06:18.089 deconz-bridge: Classic Data : {‘UTC’: ‘2023-10-24T04:06:18’, ‘apiversion’: ‘1.16.0’, ‘backup’: {‘errorcode’: 0, ‘status’: ‘idle’}, ‘bridgeid’: ‘00212EFFFF085C06’, ‘datastoreversion’: ‘93’, ‘dhcp’: True, ‘disablePermitJoinAutoOff’: False, ‘factorynew’: False, ‘fwversion’: ‘0x00000000’, ‘gateway’: ‘’, ‘internetservices’: {‘internet’: ‘connected’, ‘remoteaccess’: ‘disconnected’, ‘swupdate’: ‘connected’, ‘time’: ‘connected’}, ‘ipaddress’: ‘’, ‘lightlastseeninterval’: 60, ‘linkbutton’: False, ‘localtime’: ‘2023-10-24T06:06:18’, ‘mac’: ‘8e:42:b7:fa:4b:11’, ‘modelid’: ‘deCONZ’, ‘name’: ‘Phoscon-GW’, ‘netmask’: ‘’, ‘networkopenduration’: 180, ‘panid’: 0, ‘portalconnection’: ‘disconnected’, ‘portalservices’: False, ‘portalstate’: {‘communication’: ‘disconnected’, ‘incoming’: False, ‘outgoing’: False, ‘signedon’: False}, ‘proxyaddress’: ‘none’, ‘proxyport’: 0, ‘replacesbridgeid’: None, ‘rfconnected’: False, ‘starterkitid’: ‘’, ‘swupdate’: {‘checkforupdate’: False, ‘devicetypes’: {‘bridge’: False, ‘lights’: , ‘sensors’: }, ‘notify’: False, ‘text’: ‘’, ‘updatestate’: 0, ‘url’: ‘’}, ‘swupdate2’: {‘autoinstall’: {‘on’: False, ‘updatetime’: ‘’}, ‘bridge’: {‘lastinstall’: ‘2023-10-01T12:32:06’, ‘state’: ‘noupdates’}, ‘checkforupdate’: False, ‘lastchange’: ‘’, ‘state’: ‘noupdates’}, ‘swversion’: ‘2.23.2’, ‘timeformat’: ‘12h’, ‘timezone’: ‘Europe/Berlin’, ‘uuid’: ‘d188cbe8-7ce6-4a55-af05-cceea41ef477’, ‘websocketnotifyall’: True, ‘websocketport’: 8088, ‘whitelist’: {‘235159C37F’: {‘create date’: ‘2023-02-13T20:50:47’, ‘last use date’: ‘2023-02-13T20:50:56’, ‘name’: ‘Phoscon#B1280x884’}, ‘8FE2467DF1’: {‘create date’: ‘2023-02-13T20:50:16’, ‘last use date’: ‘2023-02-13T20:50:47’, ‘name’: ‘Phoscon#B1280x884’}, ‘97FB86ACCB’: {‘create date’: ‘2023-10-20T19:58:23’, ‘last use date’: ‘2023-10-20T19:58:23’, ‘name’: ‘Domoticz’}, ‘98CE42231B’: {‘create date’: ‘2023-10-20T20:28:40’, ‘last use date’: ‘2023-10-24T04:06:18’, ‘name’: ‘Domoticz’}, ‘B40B9396EC’: {‘create date’: ‘2023-10-20T20:43:16’, ‘last use date’: ‘2023-10-20T21:27:13’, ‘name’: ‘Phoscon#B1600x1060’}, ‘D00F32D077’: {‘create date’: ‘2023-10-20T20:17:12’, ‘last use date’: ‘2023-10-20T20:29:37’, ‘name’: ‘Phoscon#B1600x1060’}, ‘FF5F5E1509’: {‘create date’: ‘2023-10-22T09:46:24’, ‘last use date’: ‘2023-10-24T03:30:31’, ‘name’: ‘Phoscon#B1600x1060’}}, ‘zigbeechannel’: 0}
2023-10-24 06:06:18.089 deconz-bridge: Acquiring GIL for ‘onHeartbeatCallback’

I can’t see the wood from the trees! Please suggest what I can try next. Thanks

Hello, you are not a good place, better to use the domoticz forum, or the plugin github.
But I can say something, your deconz installation is not working


If you go on the phoscon/gateway page, you will have no firmware number displayed.
And If I m right, on domoticz you have the message “Startup failed. retrying…”.

And If I m right, it’s effectively a deconz issue (and not a domoticz one)

On the domoticz plugin, you have the line “### Request config” every 5s perhaps, up you have a firmware number, the plugin use this way to be sure deconz is running.

Are you sure not having 2 deconz instance ? the headless and the GUi one ?

438 ? Ssl 0:26 /usr/bin/deCONZ -platform minimal --http-port=80
2522 ? Ssl 0:39 /usr/bin/deCONZ --http-port=80

Thanks for replying. Actually I do have a firmware number on the gateway page.
Anyhow your hint that I might be running 2 instances, headless and GUI was correct!
After running
$ sudo systemctl disable deconz-gui
$ sudo systemctl stop deconz-gui
$ sudo systemctl enable deconz
I can now see deconz is running correctly and receiving data.

Does this mean that every when I want to install more sensors I must enable the GUI first to install and then disable so that Domoticz can use the data?

Thanks again.

I m not sure to understand.
To install new supported device, you can use phoscon (with “add new device”) or domoticz, you can make with the headless version.
If you want to manage more precisely your zigbee network or make a DDF for an unsupported device you need the GUI.

You can have only 1 deconz instance, the one you prefer (or need according what you want to do), so you need to close one before lauching the second one. (Else one version will be not able to connect to the conbee)

Domoticz can use both version, but in the plugin setting, the IP and the PORT need to match. If you use same setting, you can switch version headless<>GUI, the plugin will disconnect but when deconz is back it will remake a connexion with the used version (There is a check every 5-10s after a disconnection)

Thanks again. Using your info I was able to add two more water sensors.
So far so good!
Then I tried to add an Aqara door switch. Without success.
First using the Phoscon app then…
I tried the info in this thread.

but had NO success.

Here is the product info.

Is this switch supported or am I wasting my time trying to connect to it.
Thanks for your help.

Well I got it working! Using deConz. So I’m beginning to understand it better.

The next challenge is a Tuya smart power plug.
Using the control panel and basic pairing, deConz sees it as On/Off plug-in unit 1.
I can then find it in Domoticz but sending on/off does nothing and it is always on.
I guess that means that it’s not installed correctly but I don’t know what to do next.

What you have done for this device ?

For the tuya plug, if you give me the manufacture name/ model id (on zigbee side, not from the box) I have perhaps some information.
Some tuya stuff use the tuya cluster instead of classic cluster, so need a special DDF.

Well after restarting the Raspi everything suddenly worked properly. Thank you so much for your help.
Do you have a donations page as I would like to repay your kindness in helping me so patiently!
Cheers it’s much appreciated.

1 Like

You can find some links on the deconz domoticz plugin page on github, or on my github profile (Smanar too)
But you have solved most of yours issues yourself or with restarting the system ^^

I had a problem with the Stripe system it just didn’t accept my card. How about adding PayPal… :slight_smile:

This time I m sure it’s not a deconz issue ^^.
There is a “buymeacoffee” link on the domoticz plugin page on github, it use paypal. Else don’t worry with that, BTW thx for proposition :slight_smile: