Raspbee II hat with RPi 4 and HA

Hello, new here. I have a Raspberry Pi 4 running Raspbian Version 12 (bookworm) and have been trying to bring up a Raspbee ii on it. I made this change to the config.txt: enable_uart=1 and dtoverlay=pi3-miniuart-bt as suggested in the documentation for deconZ in HA. The Raspbee II never comes up as connected. I have tried various combinations of the config.txt settings, as I understand that the Bluetooth needs to be disabled. Can anyone at deCONZ give me the magic formula for running the Raspbee II? I know that the Raspbee II I am using works, because I have it running on a Pi Zero 2W. The Conbee stick works fine. Thanks for any help.

Here is the log from the deCONZ add-on. When I first start the add-on it says : The add-on seems to not be ready, it might still be starting. Do you want to try again?
18:13:36:747 DB cleanup
18:13:36:748 DB create temporary views
18:13:36:815 [INFO] - Timezone read is ‘Etc/UTC’
18:13:36:815 [INFO] - Environment variable TZ found: America/New_York…
18:13:36:817 Started websocket server on, port: 8081
18:13:36:817 create default username and password
18:13:36:820 [INFO] - Found file containing button maps. Parsing data…
18:13:36:829 [INFO] - Button maps loaded.
18:13:36:830 found node plugin: libde_rest_plugin.so - REST API Plugin
18:13:36:831 found node plugin: libde_signal_plugin.so - Signal Monitor Plugin
18:13:36:843 OTAU: create 117C-1101-23089631.zigbee
18:13:36:844 OTAU: create 117C-11C5-24040006.zigbee
18:13:36:849 OTAU: create 117C-2201-23087631.zigbee
18:13:36:850 OTAU: create 117C-2803-23093631.zigbee
18:13:36:851 OTAU: create 117C-2801-23086631.zigbee
18:13:36:853 OTAU: create 117C-2203-23087631.zigbee
18:13:36:854 OTAU: create 117C-1187-24040013.zigbee
18:13:36:855 OTAU: create 117C-1102-23086631.zigbee
18:13:36:856 OTAU: create 117C-4204-23095631.zigbee
18:13:36:858 OTAU: create 117C-11C8-20022623.zigbee
18:13:36:859 OTAU: create 1189-0019-00102428.zigbee
18:13:36:871 found node plugin: libstd_otau_plugin.so - STD OTAU Plugin
18:13:37:085 dlg action: Read binding table
18:13:37:895 dev /dev/ttyAMA0
18:13:37:896 COM: /dev/ttyAMA0 / serialno: , RaspBee
18:13:38:846 dev /dev/ttyAMA0
18:13:38:847 COM: /dev/ttyAMA0 / serialno: , RaspBee
18:13:42:153 dev /dev/ttyAMA0
18:13:42:820 dev /dev/ttyAMA0
18:13:42:821 COM: /dev/ttyAMA0 / serialno: , RaspBee
18:13:43:249 Announced to internet https://phoscon.de/discover
18:13:43:249 discovery server date: Mon, 05 Feb 2024 23:13:43 GMT
18:13:43:250 local time seems to be ok
18:13:43:821 dev /dev/ttyAMA0
18:13:43:822 COM: /dev/ttyAMA0 / serialno: , RaspBee
18:13:45:220 DEV Tick.Init: booted after 8000 seconds
18:13:47:861 dev /dev/ttyAMA0
18:13:47:861 COM: /dev/ttyAMA0 / serialno: , RaspBee
18:13:48:820 dev /dev/ttyAMA0
18:13:48:821 COM: /dev/ttyAMA0 / serialno: , RaspBee
18:13:52:320 dev /dev/ttyAMA0
18:13:52:819 dev /dev/ttyAMA0
18:13:52:820 COM: /dev/ttyAMA0 / serialno: , RaspBee
18:13:53:851 dev /dev/ttyAMA0
18:13:53:852 COM: /dev/ttyAMA0 / serialno: , RaspBee
18:13:56:799 start reconnect to network
18:13:57:820 dev /dev/ttyAMA0
18:13:57:820 COM: /dev/ttyAMA0 / serialno: , RaspBee

One of my test setups is the same. Usually you only need to configure the serial port via raspi-config as described in the steps “deCONZ installation”


Does this work?

No it does not. I’m starting to suspect that the serial port GPIO pins are not working.

Would you still have the config.txt settings?

config.txt (2.1 KB)

This is the config currently active on my setup which is connected via /dev/ttyS0 aka /dev/serial0.

Could it be that another instance of deCONZ is running? To be checked with: pidof deCONZ

OK I will take out the line dtoverlay=pi3-miniuart-bt and use ttyS0 instead of ttyAMA0

Still doesn’t work. No response from Raspbee. I tried what you suggested, only one instance running. It must be a problem with the RPi hardware.

Is the Raspberry Pi 4 using the sd-card or an SSD/USB for storage? The latter can cause some heavy interference. In my setup I’m using a USB dongle for storage, but had to move it away from the Raspberry Pi by using a USB extension cable.

On a lower level you can also check connectivity to the RaspBee with GCFFlasher (with deCONZ closed):

pi@rpi4:~ $ GCFFlasher_internal -d /dev/serial0 -c
packet: 8 bytes, 0701000800A20000
packet: 8 bytes, 0702000800A20000

The packet lines are shown when something is received from the firmware.

I don’t appear to have the GCFFlasher installed. There is no USB. The Pi simply does not appear to have connectivity. Thanks for all your help. I think I’m going to try another pi, there must be something wrong with the serial port on this one.