Problem with Conbee II and RPI 4 / Domoticz

Hi, all,
I am new to this forum. I usually try to figure out myself what is going wrong, but afte four days of doing so, it is time to ask for help.
Situation is as follows.
I had a RPI with SSD and Domoticz and ConBee II and that worked fine with a number of devices from IKEA and LIDL (Silvercrest?).
Then I moved to another country and Zigbee does not work anymore.
I see the PHOSCON app and i can use it, but my devices do not want to pair with the ConBee II anymore.
So, I stripped the RPI to a bare computerboard and it still does not work.

When I put the Conbee II in my windows PC all devices work fine.
When I pair the devices to the LIDL hub, all devices work fine.

Only not in the RPI4 / Conbee comby.
I tried several USB cables and power supplies.

Please help.

Hello. May not an issue but did you chnage the timezone in Phoscon, according to the timezone On your RPI ?

Hello, when you use phoscon, have you a firmware number displayed on the “gateway” page ?

You have just changed country ? same raspberry (same local ip) ?

Do you make a zigbee network restauration, or just make test on an empty network ?

It’s a raspberry 4, from my memory you have usb 2 and usb 3 on it ? Have you tried only with usb 2 ?

Have you a desktop or headless OS ? (to know if we have access to the complete application for log)


Firmware is 26780700
Both are on Europe/Amsterdam timezone.
I tried it all. I also started a new RPI4 from scratch with only Domoticz and deCONZ and Conbee II.
I tried it on USB2 and 3.
I have headless, but desktop via VNC on my PC.

Ok so no more idea, if you have started from scratch it will be ok, but just to try can you use thoses request.

sudo systemctl status deconz
sudo systemctl status deconz-gui

You need to have one enabled and one disabled.

I have headless, but desktop via VNC on my PC.
Are you sure of you ? have you enabled or not the VNC in raspiconfig ? Your debian is the headless version ?
Because on some setting launching the VNC mean start a new session.

Can you try to run deconz with command line and debug enabled ? (nothing will be stored, just look at the line for something “strange”)

/usr/bin/deCONZ -platform minimal --dbg-info=2 --dbg-error=2

But you need to close your deconz service first

sudo systemctl stop deconz-gui
sudo systemctl stop deconz

When I use your command, I can pair devices. If I only state ‘sudo systemctl stop deconz’ I cannot.
device with your command are found and with sudo systemctl stop deconz they are not.

The command is using the headless mode.
IDK if your OS is headless or desktop natively, I know you can use VNC, but I had so much problem with that, you can have a desktop OS without keyboard and without display.

sudo systemctl stop deconz Is to stop the headless mode.

Because you can have 2 deconz instances, it’s for that I m asking to close the 2 services before using the command line.

If you want to use the headless mode can try

sudo systemctl disable deconz-gui
sudo systemctl stop deconz-gui
sudo systemctl enable deconz

Then restart the machine.

Hi Smanar,
Just to prevent for misunderstandings, allow me to explain my steps:
First I took a brand new SD card and put Raspberry Pi OS on it, with VNC on.
Then, I changes timezone to Europe/Amsterdam, gave it a fixed IP address.
Then I followed the At that moment only deCONZ was active.
Using the webinterface, on https:///pwa I could not pair any device at all.

Then you gave me the alternative and that worked, but I cannot keep that screen open, so I closed it.
I did the sudo systemctl enable deconz again, but no pairing was possible.

Then I put Domoticz on the SD, via the easy was.
After that I added the plugin, following

The device I previously paired, appeard in Domoticz, but the can not be handled.
It is also nog possible anymore to pair new devices.

Just for information you have SD card image here ConBee SD-card images with raspbian+deconz

First I took a brand new SD card and put Raspberry Pi OS on it, with VNC on.

This is important, wich one image have you used, the desktop or the headless one ? Raspberry 3 / 4 haven’t problem with desktop.
You have enabled the VNC using raspi-config ?

The procedure you have on the phoscon website is for the Desktop version ONLY.

For me your issue is a deconz instance conflict.

If you have used an headless version of Buster, forget the VNC, the headless version is a light incomplete version.

Just type

sudo systemctl disable deconz-gui
sudo systemctl stop deconz-gui
sudo systemctl enable deconz

Restart the pi and never use VNC.

Ok, I think something goes wrong here.
Lately, I use the Raspberry Pi imager and choose the Debian Bullseye with desktop as the basis for Domoticz. This gives me the opportunity to remote access the computer.
I enabled VNC in the settings of the imager.

Well, I got it working with your explanation. Many thanks.

Yes, it’s for me the better option, raspberry 3 / 4 haven’t performance issue with desktop OS.
With this OS, when using VNC you will use exactly the same session, it s like connecting a display to the raspberry, less problem.