Problem "preset", "schedule_on" on Thermostat Moes xHT-GA-006


after a while I tried again to connect my thermostat Moes ZHT-GA-006 (BHT-006) to deconz (
I use Docker / Deconz 2.25.1

The device is regognized as _TZE200_aoclfnxz / TS0601",

    "config": {
        "heatsetpoint": 1900,
        "locked": false,
        "mode": null,
        "offset": -300,
        "on": true,
        "preset": "auto",
        "reachable": true,
        "schedule": {
            "W127": [
                    "heatsetpoint": 2050,
                    "localtime": "T08:31"
                    "heatsetpoint": 2050,
                    "localtime": "T16:11"
                    "heatsetpoint": 2050,
                    "localtime": "T18:31"
                    "heatsetpoint": 1950,
                    "localtime": "T21:31"
        "schedule_on": false,
        "setvalve": false
    "ep": 1,
    "etag": "fffff",
    "lastannounced": null,
    "lastseen": "2024-01-13T08:52Z",
    "manufacturername": "_TZE200_aoclfnxz",
    "modelid": "TS0601",
    "name": "Thermostat 104",
    "state": {
        "lastupdated": "2024-01-13T08:53:16.119",
        "on": false,
        "temperature": 2150
    "type": "ZHAThermostat",
    "uniqueid": "vvvvv"

By now I have 2 Problems:

First : I could not to set the attribute “preset”. Other values than “auto” like “manual” will be not be accepted.


        "error": {
            "address": "/sensors/104/config/preset",
            "description": "Could not set attribute",
            "type": 608


It is similar to the first. I could set the “schedule_on” attribute to “true” / “false” , but there is no change at the device… at the device it did not change the icon from “the clock” to "the “hand”(?).

any idea ?

I m reading the code, it seem this device support only “auto” and “program”.

And I don’t think “schedule_on” is working for Tuya device, you change the working mode using “preset”.

Ok, thank you.

I tried with value “program” before, but I see now, that I could set it so “program”, but in the same second it switches back to “auto”…

Changing this mode at the device , no change in deconz…

Also adding a schedule via API will be not transfered to the device (what is the correct schedule number for Saturday ? )

Any Idea why ?

Long time I have see someone trying this feature, you can probably found some help here Moes Tuya Thermostat BTH-002 · Issue #3304 · dresden-elektronik/deconz-rest-plugin · GitHub

Have checked the code again, I m not seeing something special, when you set the mode to “auto” or “program” it enable or disable 2 thing

  • the schedule on DPID = 0x03
  • the forced mode on DPID = 0x02

If you have the GUI you can take a look with flag “info”, you will see incoming (when you use manualy) and outcoming request from and to the device to compare.