Please create a repo for Debian 11 Bullseye

Please create a debian repo for the Bullseye. You currently only support Buster Debian 10

Debian 11 was released in August and is the current stable Debian. Buster is now old but still under LTS

Unfortunately projects like Home Assistant insist in deprecating with only few months notice so many will be forced to upgrade. For me personally I run HA on another machine but I have some other software (nothing to do with Deconz) where I need to upgrade to new Debian stable ie. Bullseye Debian 11

I tried this but you have not yet created the new repo. I doubt there is much work with this as Debian 11 is not much of a jump from their Debian 10 and may even simplify things as you also support Ubuntu which is using more up to date repos in general.

deb [arch=amd64] http://phoscon.de/apt/deconz bullseye-beta main
deb [arch=amd64] http://phoscon.de/apt/deconz bullseye main

Sorry for the bug report. I had forgotten you now want requests here on forum

2 Likes

Hey @KennethLavrsen ,

we will morph all versions together, so that in the future there is only one version for all distributions.
This will happend in a few weeks, stay tuned.

3 Likes

More than a few weeks has passed. Anything happening soon. Also latest beta was promissed this weekend but nothing was released.

1 Like

It might be a little bit off-topic, but I would like to promote a solution based on docker images. There is some effort to learn how to deal with docker, on the other side it decouples applications running on the same server. I run on a single raspberry pi 4/4GB a stack of applications (openhab, raspberrymatic, influxdb, mosquito, ebusd, grafana, wireguard, deconz, landroid). This makes also the backup a piece of cake, as well as a rebuilding of the environment on another server.
btw. the beta version was just a few days after release already on the docker hub available.

1 Like

The latest beta (2.13.0) was released last wednesday: https://github.com/dresden-elektronik/deconz-rest-plugin/releases

About the topic: it´s a long term thread for us, we are a very small team and this isn´t our no. one topic atm.

2.13.0 is not released in your current Buster repo. It is the first time in years that you do not release Deconz on your repo and normally building a deb is running the same script you have run for years. If you want us to test betas you have to make it available to us.

For the first days the release is only available for manual installation, APT repositories will be updated later.

Yesterday deCONZ version 2.13.0 came out and it’s also available in APT repository.

Hi there, at the time of the upcoming v2.13.2-beta release the generation of the APT repositories got a major rewrite to better support various operation systems and architectures.

Bullseye will be in the APT repositories supported as well as a new generic Debian and Ubuntu “branch”. Ubuntu will be based on the minimum supported “recent” version (Bionic). This one is compatible with newer versions of Ubuntu and will be referenced soon in the Installation docs. Debian will be based on Buster version.

I’d like to base it all on the Ubuntu Xenial version but this turned out to be problematic, since Xenial uses a dogs old version of OpenSSL which doesn’t provide the functionality we need for Alarm Systems and ZGP we need.

2 Likes

Raspbian/RaspberryPi OS based on Debian 11 “Bullseye” is now also officially released.

Thanks for your work on deconz. I see that v2.13.2-beta release was also released 3 days ago, yet there is no bullseye APT repo yet.

When can we roughly expect the bullseye repo? Week-ish? Month-ish? Unknown timeline?

Edit: Just noticed bullseye-beta is already available.

@de_employees

Update: That was with bullseye, it seems bullseye-beta is available. I will try it!

Update 2: bullseye-beta repo works well.

Stable isn’t released yet for the 2.13, that’s why probably

I was able to install on raspberry pi3b with bullseye.
Phoscon start, but not see Conbee II
I upgraded firmware with 26720700
The usb works with other installation (Hassio and Deconz addon)
But no way to see Conbee into raspbian bullseye
What can I do?
Bye
Sandro

Did you disable ModemManager?

Not present on raspbian
immagine

And the user running Deconz is member of dialout group?
The default in most Linux distros is that users have no access to serial ports (really annoying default)

First of all thanks a lot for the support. Solved
I put here what I done for who has my same problem
Added pi user to group dialout
sudo adduser pi dialout
Edited /usr/lib/systemd/system/deconz.service
was user 1000, with user pi
reloaded the systemd
sudo systemctl daemon-reload
sudo systemctl restart deconz

That’s it.
Thank you so much again.
Sandro