Phoscon App does not detect Conbee ii

Hi, complete smarthome, raspberry, homebridge and phoscon noob here!

I’m just starting out with building a smarthome… or atleast, trying to. I ordered a Raspberry pi 4 to use with Homebridge and a Conbee ii stick. A few days ago I had installed my Raspberry pi with Homebridge. That worked. Then I installed the Conbee ii stick. That also worked. I shutdown everything for a few days and today I booted it all up again to work on the smarthome again.

But now my homebridge can’t connect to/find the conbee. Since I am a total noob I’m not sure why. I have not changed a thing on the setup. I Googled some stuff, tried some stuff… but I can’t seem to find the problem.

In homebridge I get this error:

When searching for the direct link to the conbee in my webbrowser I get this error:

Then trying to find the gateway with the phoscon web app thing, I get nothing. So I assume that means it can’t find the device:

I’ve tried some stuff I found on the web, but it al didn’t work and now I have really not a single idea of what I can do to fix it.

I hope someone here is able to help me out!

Hello, are you are sure deconz is running ?

On headless

sudo systemctl status deconz

On desktop

sudo systemctl status deconz-gui

I tried the command within the Homebridge web platform terminal. Does that work? Or do I need to do the command on the raspberry pi itself.

Anyway, when I did the command, this is what came up:

No clue what it means… I hope you can tell me

I have a doubt ^^
I think you need to have

Active: active (running) since Sun …

I m not sure but for me it’s not running. 2 think to try :

  • restart the service
sudo systemctl stop deconz
sudo systemctl start deconz
  • try running with command line and logs
    /usr/bin/deCONZ -platforminimal .......

You just need to make a copy/paste from the previous command, you have the complete command on your capture, can add --dbg-info=2 --dbg-error=2 to have some logs, but can be tto talkative for sd card, so if you haven’t error message, stop with Ctrl+C


I don’t think this worked… or maybe I’m doing something wrong?

You have perhaps a hint here [SOLVED] Could not load the Qt platform plugin "xcb" in "" even though it was found - #3 by arkroan - Rapid Photo Downloader -

The problem is the missing package is not always the same looking issue on google …


The manual install didn’t work because it says it is already installed properly. The other thing about a rapid photo downloader or something really goes waay above my head, I’m afraid.

But thinking back… it did all work the first time when I set it all up. Isn’t that weird? That it suddenly stopped?

Could it somehow be that the Conbee stick broke?? Is there any way I can test that? Plugging it in on a windows system or something?

No, for me the problem is from your OS.

And yes you can test the conbee on a windows machine, the network setting is stored on the conbee, but the device setting are stored on hte host, so it will work but you will be not able to see correclty your devices (and the API will be empty)

And it’s almost impossible to broke the conbee.

Perhaps a deconz re-installation, it will check depency during installation.



Deconz re-installation I have tried several times already, but it just says it is already installed properly. Is there a way to override that and do a clean install?

If not… Maybe I’ll just try and do a complete re-install of Homebridge on the Pi. Maybe then it works…

Can try

sudo apt remove deconz
sudo apt install deconz

But I think you will loose your configuration.

On google there is so much to try

sudo apt-get install libqt5x11extras5
sudo apt-get install --reinstall libxcb-xinerama0
sudo apt-get install libxcb-xinerama0
sudo apt-get --reinstall install libqt5dbus5

Seriously there so much lib that cause this issue, you don’t remember having updated something ?

Try to update the whole OS

sudo apt-get update
sudo apt upgrade


Tried it all, nothing worked…

I am 100% sure nothing was updated or changed. I literally shut the system down one day when everything worked. Then after turning it on 2 days later, it didn’t. Nothing changed. So I really don’t have any idea of what it could be. None.

I will do everything over and do a clean install of homebridge on the raspberry. I’ll let you know what happens.


So it seems to be all working again now. Installed everything from scratch. However, I don’t want to get too happy just yet… because I got this far before. The problem only occurred a few days later. So we’ll have to see how this ends.

I was just thinking; Do I have to properly shutdown the raspberry pi if I turn it off? Last time I just pulled the power plug out. Could that have broken something?

Anyway, for now it was a succes. Hopefully it keeps working this time! Thank you for all the help!

Yes, like in all computer.

There is a command “sudo halt”, but you probably have the command available in FHEM.