Phoscon app broken with deCONZ 2.17.0

The Gateway screen is broken in deCONZ 2.17.0. The menu icons are in the wrong language and they are also not working/no link on the icons.
This in Brave browser. When I open the app directly on the deCONZ app on the RPi it looks fine.

1 Like

Work around is clearing the browser cache.

Hmm it does not seem to fix it to delete the site cache. And I do think it is getting deleted since I have to login again.

The browser cache not site cache.

If you’re on Windows you may try Ctrl+F5 (force reload).

There is some functionality in the app to refresh the cache automatically but I think a few places are missing :thinking:

Use cache cleaner extension in chrome, that should fix most problems after updates…

Thanks! Ctrl+F5 worked. I didn’t know about that one before.

1 Like

deCONZ 2.17.0 here. I have the same problem. Gateway does not work and buttons are not English.
Reset browser cache does not solve the issue.

Chrome development console show errors:

@ChrisHae can you check this please looks like a missing guard.

Yes there is a typo in the code. Will be fixed in next release.

Same after updating (from 2.16.1) to 2.17.1. Fixed by deleting browser cache.

thanks, Ctrl+F5 worked on Windows to fix the “display issue”