Phoscon App always ask for new password and bridge name after reboot / DeConz restart

Good morning everyone.

I’ve installed the Openhabian spin using rpi_imager and tried installing deconz from the openhabian-conf which wasn’t possible. So i followed the Phoscon Installation Guide for the Raspbee which works as expected.
I can login to the web frontend of the phoscon app ( hhtp://my_ip:8081 ) and can set a password and bridge name.
I can also connect one! sensor in the app ( if i connect more, the last connected will be in the list and all others are missing ).

I experience this behaviour ( asking for bridge name and a password, flush of the sensor list ) always after reboot / DeConz restart.
I think it’s a problem with some system rights and i tried to find a solution for this problem but unfortunatly i didn’t find one.

Do someone has any suggestions?

Usefull information:

System: Raspberry 4B
Controller: Raspbee2
System: Openhabian 3.3.0
DeConz: 2.18.02

ps aux | grep -i deconz

root       363  0.1  0.0   8380  2872 ?        Ss   11:52   0:05 /bin/bash /usr/bin/
root       366  0.5  0.0   8904  3684 ?        Ss   11:52   0:19 /bin/bash /usr/bin/
pi           367  1.8  0.6 154756 49652 ?        Ssl  11:52   1:08 /usr/bin/deCONZ -platform minimal --http-port=8081
openhab-cli info

Version:     3.3.0 (Build)
User:        openhab (Active Process 864)
User Groups: openhab tty dialout audio bluetooth gpio

Directories: Folder Name      | Path                        | User:Group
             -----------      | ----                        | ----------
             OPENHAB_HOME     | /usr/share/openhab          | openhab:openhab
             OPENHAB_RUNTIME  | /usr/share/openhab/runtime  | openhab:openhab
             OPENHAB_USERDATA | /var/lib/openhab            | openhab:openhab
             OPENHAB_CONF     | /etc/openhab                | openhab:openhab
             OPENHAB_LOGDIR   | /var/log/openhab            | openhab:pi
             OPENHAB_BACKUPS  | /var/lib/openhab/backups    | openhab:openhab

Seems to be some issue where it can’t save anything in the zll.db file.

@de_employees seems we see this more often nowadays.


I have tried all this before about a year ago but had to put it aside bc off other projects.
But now i’m back on the topic with a fresh setup and it happens again.

Problem solved.

It seems to be a problem resulting from the possibility to add an administrator user to the initial openhabian configuration.
It seems that if you do so the deCONZ folder containing the zll.db under /var/lib/openhabian/persistence is created with “user:openhabian” ownership and group rights set to r+x.
Changing the ownership to “openhabian:openhabian” or the group rights to rwx solves the problem.

Thanks for the hint :slight_smile: .

Topic can be closed.

1 Like